Hilfee, XAMPP unter Mac OS X

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Kristian Marcroft » 03. March 2005 16:16

Hi,

XAMPP wurde bei dir nicht gestartet...
Auf der Seite siehst du genau das was angezeigt werden muss, das er auch wirklich gestartet ist.

Du hast aber die Meldung bekommen:
"You must be root to start XAMPP" richtig?
Somit ist XAMPP nicht gestartet. Übersetze mal obigen englishen Text ins Deutsch und erkläre mir warum er es hätte starten sollen?

Wenn du in der Terminal shell bist und
sudo su eingibst, kommt eine neue Zeile in der es heisst:
Password: Wenn du nun etwas eintippst siehst du weder das Passwort noch sternchen. Das ist normal, das jemand der hinter dir steht nicht sieht wieviele Zeichen du eingibst.
Gebe einfach das Passwort eines Admin Accounts ein und drücke <return>
Wenn keine Fehlermeldung erscheint bist du nun root.
nun startest due XAMPP mit:
/usr/local/xampp/mampp start

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Ceelight » 03. March 2005 16:16

OT: Kann mal ein Mod den Thread ins MAC-Forum schieben?

thx
Cee
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby kaddus » 03. March 2005 17:12

Hi,

Juhu *freu*, grins, jubel!!!!! :D ich habe es gewusst..... nicht das es läuft, war ja klar, das problem war von anderer natur: Nach dem ich nen Reload und restart eingegeben habe, war das Problem gelöst. Wenn also solche Probleme bei anderen Auftauchen sollten, den Rat mit dem reload weitergeben oder gleich auf die Homepage stellen. Ich bin echt ins Zweifeln gekommen......


zu "XAMPP wurde bei dir nicht gestartet...
Auf der Seite siehst du genau das was angezeigt werden muss, das er auch wirklich gestartet ist."
XAMPP habe ich schon gestartet bekommen, ich habe ja gesehen, wie die Startbefehle abgelaufen sind, und DANACH nur den Zugriff auf den Apache von meinem Rechner gehabt. Warscheinlich weil Mein Apache nicht richtig deaktiviert war.

Danke für den Support und die wirklich schnelle Hilfe.
User avatar
kaddus
 
Posts: 8
Joined: 20. December 2004 13:52
Location: Berlin

Postby saldoran » 04. March 2005 11:59

Kristian Marcroft wrote:xampp installiert sich noch nach /usr/local/xampp
Ist sehr blöd zu erreichen via der Oberfläche...

Wir sind bereits an der nächsten Version dran, die leider (oder zum Glück)
besser platziert wird und dann unter /Applications bzw "Programme" zu finden ist.

Vielleicht könnte man ja so dreisst sein und das ohnehin bei OSX schon vorhandene $HOMEDIR/Sites Verzeichnis zu benutzen, welches sonst der MacOSX Apache benutzt.
Auf der anderen Seite spricht das natürlich gegen das Konzept bei AF, dass alles in einem Bundle ist. Außerdem ist es ja auch schnell in der httpd.conf geändert.
War nur so ein Gedanke. :roll:

Danke trotzdem fürs Lesen.
saldoran
 
Posts: 6
Joined: 04. July 2003 12:10

Postby PF4 » 04. March 2005 12:41

Hallo,

wie du schon sagst würde gegen die Idee gehen nichts im System zu veränden bzw. zu benutzen.
Sollten hier zufälligerweise Leute die Objective-C können oder mit x-code klarkommen einfach mal melden.

mfg

Florian Pollini
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby sin » 19. April 2005 13:11

Jetzt hab ich aber auch einen Mac (G4 PowerBook, Mac OS X Panther V.10.3.7.) und es gibt keine wirklich einfache Möglichkeit das komplette Bundle (wiederhole KOMPLETTE) inklusive MySQL so schnell zum laufen zu bringen wie es mit LAMPP und WAMPP möglich ist. Logisches Fazit: MAMPP
Leute von Apachefriends: Ihr habt es so unglaublich drauf, dass ich mir sicher bin, dass in euren Händen auch für den Mac das Packet perfekt geschnürt wird.
Es wäre mir auch eine Ehre, wenn ich es testen dürfte.


Ich schließe mich voll und ganz an! Ich habe die gleiche Hardware, 10.3.8 und leider zwei Probleme mit mampp:

Beim Start von mampp kommt folgende Meldung:
Powerbook:~ mo$ sudo su
Powerbook:/Users/mo root# /Applications/xampp/xamppfiles/mampp start
Starting XAMPP for MacOS X 0.2 (BETA)...
dyld: /Applications/xampp/xamppfiles/bin/php can't open library: /usr/X11R6/lib/libSM.6.dylib (No such file or directory, errno = 2)
XAMPP: Starting Apache...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for MacOS X started.


Und somit komme ich zu meinem zweiten Problem:
Ich kann http://localhost zwar aufrufen, werde dann auch in das xampp-Verzeichnis weitergeleitet, dann jedoch öffnet weder Safari noch Firefox oder m$ ie die .php Datei, was ja eigentlich eine Grundvorraussetzung sein sollte. Ich kann den .php-Dateien auch keinen Browser als Standartanwendung zuweisen. Was tun ? :)
sin
 
Posts: 1
Joined: 19. April 2005 12:58
Location: Hamburg

Postby PF4 » 19. April 2005 14:13

Hi,

das kommt davon wenn man ein XAMPP saugt der nicht verlinkt ist ;)
Benutze die 0.1 Version!
In der Version bei SF sind noch einige Libfehler.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby Kristian Marcroft » 21. April 2005 07:52

Hi,

die nun behoben sind.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby cellardoor » 29. October 2005 21:10

Hallo!

Ich bekomme immer die Fehlermeldung "You need to start XAMPP as root!", wenn ich Xampp unter Eclipse aufrufen will. Kann man sich den die Anmeldeprozedur als Root ersparen und das Programm sofort starten??

Grüße, cellardoor
cellardoor
 
Posts: 4
Joined: 29. October 2005 21:08

Postby deepsurfer » 29. October 2005 21:58

cellardoor wrote:Hallo!

Ich bekomme immer die Fehlermeldung "You need to start XAMPP as root!", wenn ich Xampp unter Eclipse aufrufen will. Kann man sich den die Anmeldeprozedur als Root ersparen und das Programm sofort starten??

Grüße, cellardoor

Dazu müsstest du den XAMPP vom System aus automatisch starten lassen.
in diesem Thread wurden Lösungswege erarbeitet.
http://community.apachefriends.org/f/viewtopic.php?t=11712
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby cellardoor » 29. October 2005 22:04

Danke ;)
cellardoor
 
Posts: 4
Joined: 29. October 2005 21:08

Previous

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests