XAMPP 5.6.11 und XDebug

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 5.6.11 und XDebug

Postby rhufsky » 11. August 2015 20:14

Das Einrichten von xdebug hat seit XAMPP 5.6.11 ein bisschen gelitten, jedenfalls, wenn man PHP als Embedded Webserver in PHPStorm verwendet:

1. Laut Howto auf http://localhost/dashboard/docs/activate-use-xdebug.html reicht es, in /Applications/XAMPP/xamppfiles/etc/php.ini die Zeile
extension = xdebug.so
einzugeben.

2. Wenn mann dann den Embedded WebServer startet,
/Applications/XAMPP/bin/php -S localhost:9999 -t "/Users/me/Documents/myproject"

moniert PHP, dass Xdebug als PHP Extension eingebunden werden will. Also Eintrag geändert auf:

zend_extension = xdebug.so.

Jetzt ist der Embedded PHP Webserver beim Starten zufrieden, das Howto ist an dieser wohl Stelle falsch. Die Scripts bleiben in Breakpoints allerdings nicht stehen.

3. Also eine Konfiguration ausgegraben, die auf einer älteren Version mal lief und in php.ini eingetragen:

[xdebug]
zend_extension = xdebug.so
xdebug.remote_enable=1
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_autostart=1
xdebug.profiler_enable=1
xdebug.profiler_output_dir=/tmp
xdebug.idekey=PHPSTORM

Nun funktionieren auch Breakpoints. In älteren XAMPP Versionen war (fast) genau dies bereits in php.ini ab Werk eingetragen und auskommentiert, es mussten nur die Kommentar-Semikolons entfernt werden und alles war gut.

Warum ist in XAMPP als Entwicklungssystem XDEBUG nicht überhaupt schon per default eingeschaltet?
rhufsky
 
Posts: 1
Joined: 11. August 2015 19:54
Operating System: OSX 10.11 beta

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest

cron