bestehendes XAMPP mit älterer Version überschreiben?

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

bestehendes XAMPP mit älterer Version überschreiben?

Postby sandrusen » 26. April 2014 11:58

Hi,
ich habe hier XAMPP 1.8.3-3 installiert und benötige zu meinem größten Übel für die Spiegelung eines älteren Shopsystems(Veyton4.1) eine ältere PHP-Version (5.3), da er auf PHP5.5 nicht läuft.
Kann ich nun problemlos XAMPP 1.7.3 darüber installieren und erhalte dann PHP5.3 ?

Was passiert mit den aktuellen Projekten auf meinem Server, wie ein Oxid-Shop und Wordpress-Sites.
Werden diese beim Überspielen von XAMPP 1.7.3 gelöscht? Oder besteht die Chance, dass sie problemlos weiter funktionieren?

Tausend Dank,
lieben Gruß, Sandra
sandrusen
 
Posts: 6
Joined: 15. April 2014 18:25
Operating System: OS X 10.8.5

Re: bestehendes XAMPP mit älterer Version überschreiben?

Postby Altrea » 26. April 2014 16:27

Hallo Sandra,

Drüberinstallieren führt in aller Regel zu unerwünschtem Verhalten, Datenverlust inbegriffen. Davon ist also strikt abzuraten.
Ich habe keinen Mac und kann dir daher keinen Ratschlag zur empfohlenen Vorgehensweise geben.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: bestehendes XAMPP mit älterer Version überschreiben?

Postby sandrusen » 29. April 2014 11:15

Ok,
also emfpiehlst Du das bestehende XAMPP vor der Neuinstallation zu deinstallieren?
Also nicht überschreiben?
Danke, Sandra
sandrusen
 
Posts: 6
Joined: 15. April 2014 18:25
Operating System: OS X 10.8.5

Re: bestehendes XAMPP mit älterer Version überschreiben?

Postby Altrea » 29. April 2014 13:23

Ja, das würde ich definitiv empfehlen.
Also vorher alle deine Projekte sichern (Dateien wegkopieren UND Datenbanken exportieren), u.U. vorgenommene benötigte Konfigurationsänderungen an den XAMPP Komponenten notieren, Datenbankbenutzer, Passwörter und Berechtigungen notieren und XAMPP restlos deinstallieren.
Dann die gewünschte XAMPP Version installieren und die Projektumgebung nach und nach wiederherstellen. Das sollte in jedem Fall funktionieren. Man muss beim Backup and Restore nur sehr sorgfältig sein, nicht dass du hinterher ein Projekt nichtmehr zurückgespielt bekommst (besser doppelt oder dreifach mit unterschiedlichen Backup-Methoden absichern).

Auf Windows gäbe es noch eine andere Möglichkeit, nämlich mehrere XAMPP Pakete nebeneinander zu installieren. Diese Möglichkeit besteht bei Mac aber sehr wahrscheinlich nicht.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: bestehendes XAMPP mit älterer Version überschreiben?

Postby sandrusen » 30. April 2014 12:33

Ok, dann weiss ich ja was ich zu tun habe.
Vielen Dank, liebe Grüße, Sandra
sandrusen
 
Posts: 6
Joined: 15. April 2014 18:25
Operating System: OS X 10.8.5


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests