Probleme mit Rewriteengine

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit Rewriteengine

Postby rhodes » 04. October 2013 12:10

Hallo zusammen,
ich entwickle gerade ein Portal mit Drupal, dessen Herzstück ein vbulletin5 Diskussionsforum ist. Das Board selber ist unter meinedomain.de/vb5/ erreichbar. Auf dem Webserver funktioniert alles prima, aber nicht auf dem xampp. Da scheint das rewriting nicht zu funktionieren. Aber der Reihe nach.

So sieht die htaccess aus.

Code: Select all
<IfModule mod_rewrite.c>
    Options +FollowSymLinks
   RewriteEngine On
   
   #In some cases where you have other mod_rewrite rules, you may need to comment out the following line
   #and change it to match your folder name. This resets the other mod_rewrite rules for just this directory
   #If your site was www.example.com/forum, the setting would be /forum/
   RewriteBase /vb5/

   # Send css calls directly to the correct file VBV-7807
   RewriteRule ^css.php$ core/css.php [NC,L]

   # Main Redirect
   RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

   # Because admincp is an actual directory.
   RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
...
...


Mein lokaler Xampp lässt sich als vhost über develop.dev aufrufen. Das Forum ist über http://develop.dev/vb5 erreichbar, zieht aber z.B. keine Stylesheets.

Man sieht an der htaccess, dass der Aufruf von http://develop.dev/vb5/css.php die Datei css.php im Unterverzeichnis core ziehen sollte. Das tut es aber nicht. Wie gesagt auf dem Webserver funktioniert mit derselben htaccess alles perfekt.

Jetzt bin ich mit meinem Latein am Ende.

Bin für jeden Tipp dankbar.

Viele Grüße rhodes
rhodes
 
Posts: 4
Joined: 04. October 2013 11:55
Operating System: OSX

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests