ImageMagick Problem (über MacPorts unter XAMPP)

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

ImageMagick Problem (über MacPorts unter XAMPP)

Postby Tyna » 09. May 2011 10:10

Hallo,

ich habe ein Problem bei der Installtion von ImageMagick unter Mac OS X 10.6.7 und XAMPP 1.7.3.

Ich wollte nach dieser Anleitung vorgehen: http://benford.bluhelix.com/installing-imagemagick-php-libraries-on-macos-with-xampp/

Ich habe MacPorts installiert und dann über ImageMagick über
Code: Select all
sudo port install ImageMagick

Das sah auch alles sehr gut aus, es gab keine Fehlermeldungen, aber wenn ich dann den Test
Code: Select all
convert logo logo.gif

durchführe, erhalte ich die Meldung:
Code: Select all
convert: unable to open image `logo': No such file or directory @ error/blob.c/OpenBlob/2587.
convert: no decode delegate for this image format `logo' @ error/constitute.c/ReadImage/532.
convert: missing an image filename `logo.gif' @ error/convert.c/ConvertImageCommand/3011.


Ich habe trotzdem den nächsten Schritt ausprobiert und im bin-Verzeichnis von XAMPP diesen Befehl ausgeführt:
Code: Select all
pecl download imagick

Dann kommt die Fehlermeldung
Code: Select all
-bash: pecl: command not found

Wenn ich aber den aber den Inhalt des Ordner aufliste, gibt es eine pecl-Datei.

Wo liegt mein Fehler? Kann mir jemand sagen, was ich als nächstes tun muss oder kennt ein gutes Tutorial?

Danke und viele Grüße
Tina


EDIT:
Noch eine Info: Unter den installierten Paketen von MacPorts wird ImageMagick @6.6.9-1_1+q16 (active) aufgeführt.
Tyna
 
Posts: 5
Joined: 29. September 2010 10:02

Re: ImageMagick Problem (über MacPorts unter XAMPP)

Postby QuadEYE » 23. July 2011 14:57

Hi Tyna,

hast Du das Problem schon lösen können? Ich habe nämlich das gleiche:

ImageMagick wurde per MacPort erfolgreich installiert. Der Test funktioniert natürlich nur, wenn auch ein Bild zum Bearbeiten im aktuellen Verzeichnis liegt. Z.B:
Code: Select all
convert input.png -rotate 30 output.jpg


Nur leider lässt sich jetzt die imagick-Erweiterung nicht installieren. Nach dieser Anleitung: http://woshiadai.blogsome.com/2008/12/27/imagick-for-xampp-on-mac-leopard/ habe ich die imagick.so in den Ordner /Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/ kopiert und in der php.ini mit "extension=imagick.so" registriert. XAMPP-Neustart: Nichts!

Vielleicht hilft auch dieser Tipp mit dem Developer Package weiter: http://stackoverflow.com/questions/6196210/install-imagemagick-for-xampp-on-mac (wegen einer miserablen Internetverbindung kann ich das momentan nicht runterladen und ausprobieren...)

Über jegliche Hilfe wäre ich sehr dankbar!

Grüße, Quad
QuadEYE
 
Posts: 1
Joined: 23. July 2011 13:36

Re: ImageMagick Problem (über MacPorts unter XAMPP)

Postby Tyna » 25. July 2011 08:17

Hi Quad,

nein, ich habe das Problem nicht gelöst. Ich habe mich jetzt erst mal damit zufrieden gegeben, dass auf meinem Webserver ImageMagick schon vorinstalliert war und dort alles getestet. Zwar nicht die schönste Lösung, aber geht...

Danke noch mal für die weiteren Links. Ich werde mich bei Gelegenheit noch mal ransetzen und mich melden, falls ich weiterkomme.

Gruß
Tina
Tyna
 
Posts: 5
Joined: 29. September 2010 10:02


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests