xampp + macports + imagemagick

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

xampp + macports + imagemagick

Postby webcam » 18. November 2010 14:15

Hallo Team!

Die letzten zwei Wochen haben mir bestimmt fünf Jahre meines Lebens geraubt. :)

Kurze Rede, langer Sinn:

Mit sudo port install ImageMagick installiere das Paket. Dazu noch das Imagick und fertig.
Nachdem ich den Pfad von ImageMagick endlich korrekt anlegen konnte, läuft Imagick jetzt ohne Probleme.

Wenn ich jetzt aber auf die GD Library zurückgreife (welche ja bei XAMPP schon dabei ist), haut das NUR bei jpeg nicht hin.
Warum? Weil ich jetzt zwei Versionen von libjpeg habe.

Die eine von XAMPP:
Code: Select all
/Applications/XAMPP/xamppfiles/lib/libjpeg.62.0.0.dylib


und die neue von ImageMagick:
Code: Select all
/opt/local/lib/libjpeg.8.dylib


Kann mir einer einen Tipp geben, wie ich das am besten lösen könnte? Ich glaub ich seh vor lauter Bäumen den Wald nicht mehr...
webcam
 
Posts: 1
Joined: 18. November 2010 14:01

Re: xampp + macports + imagemagick

Postby Nobbie » 19. November 2010 11:23

webcam wrote:Wenn ich jetzt aber auf die GD Library zurückgreife (welche ja bei XAMPP schon dabei ist), haut das NUR bei jpeg nicht hin.


Was heißt das? GIbt es keine bessere Fehlermeldung als "haut nicht hin"??

webcam wrote:Warum? Weil ich jetzt zwei Versionen von libjpeg habe.


Woher weißt Du, dass es daran liegt?
Nobbie
 
Posts: 6577
Joined: 09. March 2008 13:04


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest