MySQL does not work

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL does not work

Postby Magellan » 13. November 2010 20:40

Hi, sorry for writing in english since i'm not german.

I just started learning php, and been using xampp for a little while now. It has worked very well untill now. I had some permission issues with a file so i thought, why not change the whole applications folder to read/write capability. But when i did that everything stopped working. I tried to fix it using the disk utility tool, but it still does not work. I can start apache and FTP but when I try to start mySQL i get this message: The operation couldn’t be completed. (XAMPPErrorDomain error 1.). I can't log in to phpmyadmin either. I also changed the whole xampp folder to read/write capability but still does not work. I think it must be a permissions problem but I can't figure out what to do...

The xampp error log says:

[Thu Nov 11 23:40:11 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Nov 11 23:40:13 2010] [notice] Digest: generating secret for digest authentication ...
[Thu Nov 11 23:40:13 2010] [notice] Digest: done
[Thu Nov 11 23:40:15 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu Nov 11 23:43:46 2010] [notice] caught SIGTERM, shutting down
[Thu Nov 11 23:43:53 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Nov 11 23:43:54 2010] [notice] Digest: generating secret for digest authentication ...
[Thu Nov 11 23:43:54 2010] [notice] Digest: done
[Thu Nov 11 23:43:54 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations

I hope someone here has a solution so I can continue to learn PHP!

Thank you!// Magellan
Magellan
 
Posts: 1
Joined: 13. November 2010 02:10

Re: MySQL does not work

Postby bergmich » 13. December 2010 17:35

Hi Magellan,

do you use the HFS+ filesystem with upper/lower case senstivity?

I had exactly the same problem an I could solve it by recreating the symbolic link to mysql.starter.

ls -l /Applications/XAMPP/xamppfiles/bin/mysql.server
lrwxrwxrwx 1 root admin 55 Sep 8 15:11
/Applications/XAMPP/xamppfiles/bin/mysql.server ->
/Applications/xampp/xamppfiles/share/mysql/mysql.server

The "xampp" has to be in upper case letters! This way it is correct:

bash-3.2# pwd
/Applications/XAMPP/xamppfiles/bin
bash-3.2# ls -l /Applications/XAMPP/xamppfiles/bin/mysql.server
lrwxr-xr-x 1 root admin 55 Jan 22 19:39
/Applications/XAMPP/xamppfiles/bin/mysql.server ->
/Applications/XAMPP/xamppfiles/share/mysql/mysql.server

This nasty bug is present at least since January 2010, when I discovered it the first time. Unfortunately I didn´t document it, so I had to dig for it for hours again last week ;-(

I hope, this workaround solves your problem, too.

Regards
Michael
bergmich
 
Posts: 1
Joined: 13. December 2010 17:19


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests