Älteres Download (mit PHP 5.2.x) verfügbar?

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Älteres Download (mit PHP 5.2.x) verfügbar?

Postby kuk » 12. September 2009 11:17

Hallo,

ich suche eine ältere XAMPP Kompilation, die noch PHP 5.2 enthält. Ist so was verfügbar?

Grund: Verwende Joomla 1.5, welches nicht mit PHP 5.3.x funktioniert.

Danke
kuk
 
Posts: 3
Joined: 12. September 2009 11:07

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby Altrea » 12. September 2009 20:00

Versuchs mal bei sourceforge
http://sourceforge.net/projects/xampp/files/

Behalte aber im Hinterkopf, dass eine ältere Apache- oder PHP-Version Sicherheitslücken enthalten könnte, die in der neueren Version schon geschlossen sind.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby kuk » 13. September 2009 12:48

Danke! :D

Stand gestern etwas auf der Leitung, habe die Quelle dann selbst später noch entdeckt.

Das mit dem Sicherheitshinweis ist schon richtig. Nützt aber herzlich wenig, wenn Joomla bis Version 1.5.14 nur unter PHP 5.2.x korrekt läuft.
Die Joomla Programmierer arbeiten zwar daran (Beta 1.5.15 steht für Testzwecke zum Download bereit), doch machen noch unter anderen Drittanbieter Erweiterungen Probleme.

In dem Fall geht das Zusammenspiel aller Komponenten vor. PHP 5.2 unter Snow Leopard zum laufen zu bringen ist/war wirklich ein Akt.
Alle (incl. Apple) setzen auf PHP 5.3. Läuft auch prima direkt unter OS X zusammen mit MySQL. Was aber in einem Fall wie meinem machen?
Die Entropy PHP Kompilation funktioniert nur bis Leopard, zurück zu Leopard aber nicht erwünscht. Eine Parallel-Installation wie XAMPP ist da nötig.
Klappt auch gut, wenn man dem XAMPP Apache und MySQL eine andere Port-Nummer zu weist.

Insoweit grossen Dank an die XAMPP Gruppe!! :mrgreen:
kuk
 
Posts: 3
Joined: 12. September 2009 11:07

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby Nobbie » 13. September 2009 20:31

kuk wrote:Das mit dem Sicherheitshinweis ist schon richtig. Nützt aber herzlich wenig, wenn Joomla bis Version 1.5.14 nur unter PHP 5.2.x korrekt läuft.


Das ist, wie ich hier schon an anderer Stelle geschrieben habe, nicht richtig. Joomla läuft auch (zumindest bei mir) unter PHP 5.3. Man muss lediglich die Fehlermeldungen abschalten (die auch keine "Fehler" sind, sondern nur Notices und Warnings).
Nobbie
 
Posts: 6920
Joined: 09. March 2008 13:04

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby kuk » 15. September 2009 13:02

Das kann ich nicht bestätigen. Bei mir treten schon Fehler bei Joomla Kernbereichen auf (z.B. Top Menüs werden nicht angezeigt), ganz wie es auch offiziell dargestellt wird. Noch schlimmer wird es dann mit Drittanbietererweiterungen (z.B. Community Builder)... Produktiv nicht zu verwenden.
kuk
 
Posts: 3
Joined: 12. September 2009 11:07

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby Altrea » 15. September 2009 14:02

Bei der aktuellen Joomla-Version ist es leider nicht damit getan, einfach die Fehler zu verstecken. Eine ungemoddete Joomla-Version im Standarddesign wird man vielleicht noch einigermaßen zum laufen bekommen können (übrigens ist hier die Chance bei den Releases v1.5.10 und v1.5.11 größer als bei den aktuelleren), aber sobald man von den core-Modulen abweicht schaukeln sich die Fehler immer weiter hoch.

Neben den kleineren Dingen wie referenzieren von Objektreferenzen benötigt vorallem die JHTML Klasse von Joomla eine gründlichere Überarbeitung um PHP5.3 fähig zu werden. Es gibt zwar auch hierfür Workarounds die mehr oder weniger gut funktionieren... Ich rate in solchen Fällen aber lieber dazu zu warten oder noch auf PHPH5.2.9/10 zu setzen. Man spart sich einiges an Nerven, und Joomla v1.5.15 wird hoffentlich auch recht bald stable.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Älteres Download (mit PHP 5.2.x) verfügbar?

Postby Nobbie » 15. September 2009 17:41

Altrea wrote:Ich rate in solchen Fällen aber lieber dazu zu warten oder noch auf PHPH5.2.9/10 zu setzen. Man spart sich einiges an Nerven, und Joomla v1.5.15 wird hoffentlich auch recht bald stable.


Was wohl in Anbetracht der sich anhäufenden Fehler die richtige Entscheidung ist.

Was ich ganz furchtbar finde: das liegt ja nicht daran, dass PHP 5.3 "nicht funktioniert", sondern es liegt daran, dass Joomla (leider auch) grauenhaft schlecht(!) programmiert ist und mehr oder minder "zufällig" nur deswegen bislang läuft, weil PHP vor Version 5.3 extrem (viel zu extrem) fehlertolerant ist und mehr oder minder die Fehler selbst ausbügelt.

Da rollen sich mir die Fussnägel hoch, wenn ich das sehe, was (zu Recht) heute von PHP 5.3 angemault wird. Die unsägliche Vermischung von "Call-By-Value" und "Call-by-Reference", die sich inkonsistent bis zum Erbrechen durch die Module zieht, ist wirklich kaum zu glauben.
Nobbie
 
Posts: 6920
Joined: 09. March 2008 13:04


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests