testing cgi-bin/test-cgi ?

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

testing cgi-bin/test-cgi ?

Postby crucco37 » 28. April 2009 22:17

Ha, jetzt beantworte ich meine Fragen hier gleich selbst. Der cgi-bin Ordner unter xampp 1.01 für Mac osx
bringt rein garnix. der geht nur mit Dateien für den unix/linux user nobody so nene vogel kann man sich selbst
als root nicht erzeugen, weil der schon standardmäßig im unsichtbaren orkus existiert.
wenn man aber perl-scripte einfach in den htdocs ordner schmeißt und sie mit der Startzeile:
'#!/Applications/xampp/xamppfiles/bin/perl' versieht, dann laufen Sie. Jetzt weiß ich auch, das DBI und DBD
nicht im xampp-Perl integriert sind obwohl Kai 'Oswald' Seidler das versprochen hat, weil mein perl-testscript
das:
Serverfehler!

Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
Can't locate DBI.pm in @INC (@INC contains: /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0/darwin-2level /Applications/XAMPP/xamppfiles/lib/perl5/5.10.0 /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.0/darwin-2level /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.0 . /Applications/XAMPP/xamppfiles) at /Applications/XAMPP/xamppfiles/htdocs/mysql-test.pl line 3. BEGIN failed--compilation aborted at /Applications/XAMPP/xamppfiles/htdocs/mysql-test.pl line 3. ,

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 500
localhost
Tue Apr 28 23:03:16 2009
Apache/2.2.11 (Unix) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.7l PHP/5.2.9 mod_perl/2.0.4 Perl/v5.10.0

auswirft.

Also wer kann mir helfen, perl module DBI und DBD in dieses xampp-perl zu integrieren?

schöne Grüße

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: testing cgi-bin/test-cgi ?

Postby Wiedmann » 28. April 2009 22:36

Bei deinem Problem kann ich dir gerade leider auch nicht helfen. Nur eine kurze Frage:

Jetzt weiß ich auch, das DBI und DBD nicht im xampp-Perl integriert sind obwohl Kai 'Oswald' Seidler das versprochen hat,

Wo kann ich das nachlesen?

(BTW: Der Maintainer von XAMPP für Mac OS X ist nicht Oswald.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: testing cgi-bin/test-cgi ?

Postby crucco37 » 29. April 2009 12:12

Das steht in seinem Blog Oswaldism, da habe ich die Frage nach DBI/DBD mal im letzten Jahr gepostet. Kleinweby alias Speich hat damals geantwortet, er würde sich das notieren und für die Weiterarbeit mit aufnehmen. Wie gesagt, das war zu Zeiten der Version 0.74, die ich gerade aufgrund dessen eben nicht installiert habe.

Hier der Link:

http://blog.oswaldism.de/2007/09/02/sch ... mo-seiten/

liebe Grüße

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: testing cgi-bin/test-cgi ?

Postby Wiedmann » 29. April 2009 12:46

Das steht in seinem Blog Oswaldism,

Stimmt. Da geht es um die Ideen um Pläne des (irgendwann) kommenden XAMPP 2.x. (nicht um aktuelle XAMPP Versionen)

Kleinweby alias Speich hat damals geantwortet, er würde sich das notieren und für die Weiterarbeit mit aufnehmen.

Hat er wohl vergessen.

BTW:
Kann man beim Mac nicht einfach das Modul mit CPAN installieren (wie bei Linux/Windows)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: testing cgi-bin/test-cgi ?

Postby Nobbie » 29. April 2009 13:54

Wiedmann wrote:Kann man beim Mac nicht einfach das Modul mit CPAN installieren (wie bei Linux/Windows)?


Das geht ganz sicher, spätestens wenn man ActivePerl auf OSX installiert, dann steht automatisch auch der Perl Packet Manager (ppm) zur Verfügung.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: testing cgi-bin/test-cgi ?

Postby crucco37 » 30. April 2009 11:00

Hi,

spannender Tip mit dem ActivePerl werde ich mal probieren demnächst.

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: testing cgi-bin/test-cgi ?

Postby crucco37 » 04. May 2009 16:31

Hallo Nobi,

das Activestate Perl für Mac OS X würde sehr wahrscheinlich das vorhandene Perl 5.8 was beim Mac integriert ist, auf die Version 5.10 updaten.
Wenn man das aber nicht will, sondern nur das in xampp integrierte Perl updaten will, was müsste man denn da tun? Könnte da jemand
helfen?

Danke

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests