Apache startet nicht (error.log)

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht (error.log)

Postby egalegal » 21. April 2009 00:22

Habe XAMPP installiert und wollte apache starten, doch es kommt ein leeres Fenster mit einem Ausrufezeichen und einer Schaltfläche "OK".
In der error.log steht folgendes:
[Tue Apr 21 01:10:51 2009] [alert] (EAI 7)No address associated with nodename: mod_unique_id: unable to find IPv4 address of "noname"
Configuration Failed


in der apachestart.log
httpd: Could not open configuration file /Applications/XAMPP/xamppfiles/etc/httpd.conf: Too many levels of symbolic links


könnt ihr mir helfen, vielen dank
egalegal
 
Posts: 1
Joined: 21. April 2009 00:05

Re: Apache startet nicht (error.log)

Postby moles » 25. April 2009 18:44

hi,
habe das gleiche problem seit gestern. zuvor hat es einwandfrei funktioniert.
hast du schon eine lösung.

lg, m
moles
 
Posts: 1
Joined: 25. April 2009 18:41

Re: Apache startet nicht (error.log)

Postby kleinweby » 25. April 2009 19:12

Huhu,

ist ja komisch...

Koenntet ihr/einer von euch mal den Terminal oeffnen und die Ausgaben folgender commandos hier einfuegen:
Code: Select all
ls -hal /Applications/XAMPP/xamppfiles/etc
ls -hal /Applications/XAMPP/xamppfiles/etc/httpd.conf
ls -hal /Applications/XAMPP/etc
ls -hal /Applications/XAMPP/etc/httpd.conf


Grueße,
Christian
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
XAMPP Version: 1.8.3-2
Operating System: Mac OS X 10.7

Re: Apache startet nicht (error.log)

Postby mvd » 09. June 2009 21:07

Hi,

hab das gleiche Problem (MacOS 10.4.11). Die Ausgaben von ls sehen aber unverdächtig aus:

-rw-rw-r-- 1 root admin 17K Apr 13 11:49 /Applications/XAMPP/etc/httpd.conf
-rw-rw-r-- 1 root admin 17K Apr 13 11:49 /Applications/XAMPP/xamppfiles/etc/httpd.conf

und die Verzeichnisse werden richtig gelistet.

gruß
mvd
 
Posts: 1
Joined: 09. June 2009 21:01

Re: Apache startet nicht (error.log)

Postby donpasquale » 11. June 2009 19:14

Hallo allerseits,

sehe die gleiche Fehlermeldung auf einem Mac-PPC mit 10.4.11 und allen security patches.

Ergebnis der ls-Aufrufe:

Code: Select all
Welcome to Darwin!
brombeere:~ administrator$ ls -hal /Applications/XAMPP/xamppfiles/etc
lrwxr-xr-x   1 administ  admin  6B Jun 11 17:34 /Applications/XAMPP/xamppfiles/etc -> ../etc
brombeere:~ administrator$ ls -hal /Applications/XAMPP/xamppfiles/etc/httpd.conf
-rw-rw-r--   1 root  admin    17K Apr 13 11:49 /Applications/XAMPP/xamppfiles/etc/httpd.conf
brombeere:~ administrator$ ls -hal /Applications/XAMPP/etc
total 448
drwxrwxr-x   24 root      admin   816B Apr 13 11:49 .
drwxr-xr-x    9 administ  admin   306B Jun 11 17:40 ..
-rw-rw-r--    1 root      admin    12K Jun 11 17:41 .DS_Store
drwxrwxr-x   14 root      admin   476B Apr 13 11:49 extra
-rw-rw-r--    1 root      admin     3K Apr 13 11:49 freetds.conf
-rw-rw-r--    1 root      admin    17K Apr 13 11:49 httpd.conf
-rw-rw-r--    1 root      admin    16K Apr 13 11:49 httpd.conf.bak
-rw-rw-r--    1 root      admin   362B Apr 13 11:49 locales.conf
-rw-rw-r--    1 root      admin    12K Apr 13 11:49 magic
-rw-rw-r--    1 root      admin    30K Apr 13 11:49 mime.types
-rw-rw-r--    1 root      admin     2K Apr 13 11:49 my.cnf
drwxrwxr-x    4 root      admin   136B Apr 13 11:49 openldap
lrwxr-xr-x    1 administ  admin    56B Jun 11 17:34 openssl.cnf -> /Applications/xampp/xamppfiles/share/openssl/openssl.cnf
drwxrwxr-x    4 root      admin   136B Apr 13 11:49 original
-rw-rw-r--    1 root      admin     1K Apr 13 11:49 pear.conf
-rw-rw-r--    1 root      admin    38K Apr 13 11:49 php.ini
-rw-rw-r--    1 root      admin   219B Apr 13 11:49 pool.conf
-rw-rw-r--    1 root      admin     2K Apr 13 11:49 proftpd.conf
-rw-rw-r--    1 root      admin     1K Apr 13 11:49 proftpd.conf.orig
drwxrwxr-x    3 root      admin   102B Apr 13 11:49 ssl.crt
drwxrwxr-x    3 root      admin   102B Apr 13 11:49 ssl.key
-rw-rw-r--    1 root      admin    23K Apr 13 11:49 webalizer.conf
-rw-rw-r--    1 root      admin    23K Apr 13 11:49 webalizer.conf.sample
drwxrwxr-x    4 root      admin   136B Jun 11 17:41 xampp
brombeere:~ administrator$ ls -hal /Applications/XAMPP/etc/httpd.conf
-rw-rw-r--   1 root  admin    17K Apr 13 11:49 /Applications/XAMPP/etc/httpd.conf


Wie vielen "symbolic links" muß Apache denn folgen, bis er die httpd.conf findet? Könnte man testweise eine Kopie der Konfiguration an den Ort legen, wo zuerst gesucht wird?

Danke, P.
donpasquale
 
Posts: 3
Joined: 11. June 2009 19:03

Re: Apache startet nicht (error.log)

Postby ache » 20. June 2009 18:04

Gleiches Problem hier. Hat schon jemand eine Lösung?
ache
 
Posts: 1
Joined: 20. June 2009 18:01

Re: Apache startet nicht (error.log)

Postby donpasquale » 21. June 2009 16:41

Nein, leider nicht ...
donpasquale
 
Posts: 3
Joined: 11. June 2009 19:03

Solved: Apache startet nicht (error.log)

Postby mcJack » 28. June 2009 23:05

Moin,

hatte eben das selbe Problem...
Nach etwas suchen und aus dem Terminal starten kam ich drauf:
/Applications/XAMPP/xamppfiles/share/xampp/diagnose: line 64: /Applications/XAMPP/xamppfiles/mampp: No such file or directory


Ich denke das war ein Typo und es sollte xampp gestartet werden, also in der Datei:
/Applications/XAMPP/xamppfiles/share/xampp/diagnose
die letzte Zeile geändert von:
Code: Select all
/Applications/XAMPP/xamppfiles/mampp startapache

in
Code: Select all
/Applications/XAMPP/xamppfiles/xampp startapache


...und alles klappt, sowohl aus dem Terminal als auch mit dem "XAMPP Control"

Viel Spaß dabei...

Grüße
mcJack
mcJack
 
Posts: 1
Joined: 28. June 2009 22:57

Re: Apache startet nicht (error.log)

Postby donpasquale » 05. July 2009 17:33

Ich musste auf einem Mac mit XAMPP als Erstinstallation zusätzlich einmal:

Code: Select all
 sudo /Applications/XAMPP/xamppfiles/xampp startapache

aufrufen. Dadurch wurde meine "/etc/hosts"-Datei ergänzt.

Erst jetzt funktioniert auch "XAMPP Control".

Übrigens läßt sich jetzt neben Apache auch FTP starten.

Danke & Grüße
donpasquale
 
Posts: 3
Joined: 11. June 2009 19:03


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest