VHosts: Aufruf über wird immer auf /xamp/ geleitet?

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

VHosts: Aufruf über wird immer auf /xamp/ geleitet?

Postby Adagio » 09. April 2009 13:42

Moin,

heute steh ich irgendwie auf dem Schlauch - ich hab schon mehrmals ohne Probleme VHosts bei XAMPP aktiviert und nutzen können, aber heute will es nicht wirklich. Ich nutze die Version 0.7.4 auf MacOS X (Leopard).

Wenn ich z.B. alles korrekt für http://www.meintest.local einrichte (host datei, vhosts conf etc.), funktioniert der Direktaufruf nicht ... ich lande dabei immer auf http://www.meintest.local/xampp/index.php

Rufe ich allerdings manuell http://www.meintest.local/index.php auf, funktioniert es ohne Probleme. Bei Unterseiten muss ich das nicht, da geht http://www.meintest.local/ursel/bla/ ohne Angabe von index.php

Wieso kann ich das Hauptverzeichnis nicht einfach so aufrufen? Muss ich außer der host und vhost Datei noch etwas an der XAMPP Konfiguration ändern?

Code: Select all
NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
    DocumentRoot "/Applications/xampp/xamppfiles/htdocs/drabke"
    ServerName meintest.local
    ServerAlias www.meintest.local
   ErrorLog "/Applications/xampp/xamppfiles/htdocs/drabke/errorlog.log"
</VirtualHost>

<VirtualHost 127.0.0.1:80>
    ServerName localhost
    DocumentRoot "/Applications/xampp/xamppfiles/htdocs/xampp"
</VirtualHost>


Code: Select all
127.0.0.1   localhost
255.255.255.255   broadcasthost
::1             localhost
fe80::1%lo0   localhost
127.0.0.1   www.meintest.local meintest.local
Adagio
 
Posts: 23
Joined: 09. February 2003 16:05
Location: Bärlin :o)

Re: VHosts: Aufruf über wird immer auf /xamp/ geleitet?

Postby sili » 28. August 2009 16:38

Dieses Problem wirst du warscheinlich mit dem Löschen des Caches in deinem Browser lösen können.
sili
 
Posts: 67
Joined: 15. March 2003 16:05


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests