ProFTPd login problem

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

ProFTPd login problem

Postby serpens.mors » 17. March 2009 14:39

Hi,

hab an der Standard-Config nix verändert und ich komme auf Teufel komm raus nicht auf den FTP drauf. Login mit nobody und xampp funktioniert nicht. Versucht mit Cyberduck und mit dem Finder selbst. Nix.

LG
serpens.mors
 
Posts: 1
Joined: 17. March 2009 14:35

Re: ProFTPd login problem

Postby DJ DHG » 18. March 2009 19:29

Moin Moin!

Inhalt von LogDateien?
Error / Fehlermeldung?
Darf man die Konfig mal sehen?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Re: ProFTPd login problem

Postby rustyy » 19. March 2009 22:58

Hi ich habe ein ähnliches Problem, ich komme mit dem Standard-Nutzer nobody:xampp nicht auf den ftp drauf … habe auch schon versucht in den Dokus nach dem Problem zu suchen, jedoch bin ich nicht wirklich schlau daraus geworden …

Hinweise zum Passwort finde ich in der proftpd.conf.rej … inwieweit mir diese Datei weiterhilft, weiß ich jedoch nicht …

Ich hoffe jemand kann weiterhelfen, muss dazu sagen, bin was proftpd angeht auch noch auf Neuland :/ …

Danke schonmal im Voraus.

Der Vollständigkeit halber hier nochmal die Conf, die jedoch dem Standard entsprechen müsste …

Code: Select all
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName         "ProFTPD Default Installation"
ServerType         standalone
DefaultServer         on

# Port 21 is the standard FTP port.
Port            21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask            022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances         30

# Set the user and group under which the server will run.
User            nobody
Group            admin

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot /Applications/xampp/htdocs


# Normally, we want files to be overwriteable.
AllowOverwrite      on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  DenyAll
</Limit>

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
  User            ftp
  Group            ftp

  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias         anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients         10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin         welcome.msg
  DisplayChdir         .message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>
</Anonymous>
rustyy
 
Posts: 1
Joined: 19. March 2009 22:50

Re: ProFTPd login problem

Postby klunz » 27. March 2009 16:16

Ich wollte hier nur mal das Problem meiner beiden Vorposter bestätigen, ich hab genau das gleiche:
Komplett jungfräuliches XAMPP, alles funktioniert soweit, ausser Login auf dem ftp-Server, weder mit cyberduck, noch mit filezilla oder ftp. Filezilla sagt mir:
Code: Select all
Status:   Verbinde mit 127.0.0.1:21...
Status:   Verbindung hergestellt, warte auf Willkommensnachricht...
Antwort:   220 ProFTPD 1.3.1 Server (Tobis Server) [127.0.0.1]
Befehl:   USER nobody
Antwort:   331 Password required for nobody
Befehl:   PASS ****
Antwort:   530 Login incorrect.
Fehler:   Herstellen der Verbindung zum Server fehlgeschlagen

Aufgrund der Vorhandenen Willkommensnachricht ("Tobis Server" ist von mir von Hand in die Config-Datei eingetragen) schliesse ich das soweit eigentlich alles funktioniert, aber der user nobody ein anderes Passwort haben muss.

Wenn ich in der Konsole
Code: Select all
dscacheutil -q user


aufrufe, bekomme ich als Ausgabe unter anderem:
Code: Select all
name: nobody
password: *
uid: -2
gid: -2
dir: /var/empty
shell: /usr/bin/false
gecos: Unprivileged User

Der user scheint also zu existieren, der eine Asterix beim Passwort irritiert mich allerdings ein wenig, keine Ahnung was das bedeutet.

Ich hab jetzt längere Zeit in der proftpd Dokumentation rumgesucht, aber das ist doch alles nur für Linux-Systeme, das hilft mir alles nicht wirklich weiter, ich hab echt keinen Plan was jetzt zu tun wäre...

Wäre toll wenn jemand uns weiterhelfen könnte....

Mfg und schönes Wochenende
Tobi
klunz
 
Posts: 3
Joined: 27. March 2009 16:04

Re: ProFTPd login problem

Postby Nobbie » 27. March 2009 18:15

Was ist der Sinn eines FTP Servers auf 127.0.0.1?

>Der user scheint also zu existieren, der eine Asterix beim Passwort irritiert mich allerdings ein wenig, keine Ahnung was das bedeutet.

Das bedeutet, dass man sich als User "nobody" grundsätzlich nicht einloggen kann, weil er kein gültiges Passwort besitzt. Wenn der User Nobody ein gültiges Passwort besitzen soll, musst Du das für ihn einrichten. Das geht am einfachsten als "root" mit dem Shell Kommando "passwd nobody" - danach wirst Du geben, ein Passwort zu vergeben.

Das hat mit Xampp übrigens rein gar nichts zu tun, das scheint unter OSX so vorinstalliert zu sein.

>Ich hab jetzt längere Zeit in der proftpd Dokumentation rumgesucht, aber das ist doch alles nur für Linux-Systeme, das hilft mir alles nicht wirklich weiter,

Nicht ganz - wenn Du es verstehen würdest, würde es durchaus weiterhelfen, denn auch OSX basiert auf einem UNIX System (wie Linux).
Nobbie
 
Posts: 7151
Joined: 09. March 2008 13:04

Re: ProFTPd login problem

Postby klunz » 28. March 2009 10:38

Hallo, zunächst mal danke für die Antwort,

Was ist der Sinn eines FTP Servers auf 127.0.0.1?

xampp wird an vielen Stellen im Internet als lokale Testumgebung für Webseiten empfohlen, insofern macht es durchaus Sinn das ganze erstmal unter 127.0.0.1 laufen zu lassen. Dass der ftp in dieser Konstellation natürlich keinen sinnvollen Zweck erfüllt ist mir klar, aber er gehört nunmal zum Packet, und ich hätte das Ganze gerne erstmal komplett am laufen bevor ich alles irgendwo hochlade.
Wenn der ftp in meiner lokalen, komplett von mir kontrollierten Umgebung schon nicht läuft....

Das bedeutet, dass man sich als User "nobody" grundsätzlich nicht einloggen kann, weil er kein gültiges Passwort besitzt. Wenn der User Nobody ein gültiges Passwort besitzen soll, musst Du das für ihn einrichten. Das geht am einfachsten als "root" mit dem Shell Kommando "passwd nobody" - danach wirst Du geben, ein Passwort zu vergeben.

Das hat mit Xampp übrigens rein gar nichts zu tun, das scheint unter OSX so vorinstalliert zu sein.

Vielen Dank für die Info, das wusste ich nicht, man lernt doch immer noch dazu :oops:

>Ich hab jetzt längere Zeit in der proftpd Dokumentation rumgesucht, aber das ist doch alles nur für Linux-Systeme, das hilft mir alles nicht wirklich weiter...
Nicht ganz - wenn Du es verstehen würdest, würde es durchaus weiterhelfen, denn auch OSX basiert auf einem UNIX System (wie Linux).

Mal ganz abgesehen davon dass solche Kommentare wirklich absolut niemandem weiterhelfen: ich habe geschrieben dass mir die Doku nicht weiterhilft, dass impliziert durchaus dass es mir zwar weiterhelfen könnte, ich es aber einfach nicht verstehe.
Weiterhin weiss ich durchaus dass OSX auf BSD basiert und somit mit Linux verwand ist, nichtsdestotrotz handelt es sich nunmal um 2 letztlich doch verschiedene Betriebssysteme mit gleichem Kern.

Im Abschnitt "Authentication" im Proftpd User Guide finden sich folgende Abschnitte die ich hier vielleicht mal zitieren darf:
The standard in ProFTPD is the Pluggable Authentication Modules system, or PAM. Support is also provided for the classic /etc/passwd and /etc/shadow password files as well as more "interesting" solutions such as SQL and LDAP.
.....
FreeBSD

FreeBSD does not support PAM session directives. If you remove the following line from the FreeBSD section of README.PAM, PAM should work properly under recent versions of FreeBSD.

Example 8-4. FreeBSD configuration

ftp session required pam_unix.so try_first_pass

Über OSX findet sich keine einzige Silbe. Für mich heisst das: PAM wird von FreeBSD nicht unterstützt....
So wie ich das sehe bringt mir die Verwandschaft zwischen OSX und Linux in diesem Fall also nicht wirklich weiter. Ich lasse mich aber gern eines besseren belehren.

Mal ganz abgesehen davon, Zitat von der XAMPP-Website:
Die Pakete haben gemeinsam, dass sie nur ausgepackt und gestartet werden müssen und schon funktioniert alles. Keine Einträge in der Registry (außer bei der Windows-Installer-Version), kein Ändern von Konfigurationsdateien. Einfacher kann es eigentlich nicht mehr sein.

Wenn man sowas auf seine Website schreibt sollte man vielleicht auch davon ausgehen dass sich eine Menge Leute für das Packet interessieren die keine Cracks sind und genau das suchen was da beschrieben wird: eine einfach Lösung die möglichst bald läuft, ohne dass man sich groß um die Konfiguration kümmern muss.
Da hier jetzt innerhalb einer Woche 3 Leute genau dasselbe Problem beschreiben liegt zumindest der Verdacht nahe, dass es sich um ein prinzipielles Problem in der default-Konfiguration handelt oder wir alle den selben einen kleinen Fehler machen, und es nicht an meiner persönlichen Blödheit liegt die doch recht technische ProFTPd-Dokumentation zu verstehen. Wenn man dem Anspruch aus dem Zitat genügen will, wäre es also evtl. nicht schlecht das Problem anzugehen, wobei ich gerne bereit bin mich an der Lösung zu beteiligen, aber mich offensichtlich nicht gut genug auskenne um allein daran zu arbeiten.
Was anderes hab ich auch nie behauptet.

Mfg
Tobi
Last edited by klunz on 28. March 2009 16:49, edited 1 time in total.
klunz
 
Posts: 3
Joined: 27. March 2009 16:04

Re: ProFTPd login problem

Postby Nobbie » 28. March 2009 11:45

klunz wrote:Da hier jetzt innerhalb einer Woche 3 Leute genau dasselbe Problem beschreiben liegt zumindest der Verdacht nahe, dass es sich um ein prinzipielles Problem in der default-Konfiguration handelt oder wir alle den selben einen kleinen Fehler machen, und es nicht an meiner persönlichen Blödheit liegt die doch recht technische ProFTPd-Dokumentation zu verstehen.


Nö, momentan erkenne ich bei allen dreien, dass sie keinerlei Kenntnisse über die OSX Benutzerverwaltung besitzen - was ja mit ProFTP und/oder Xampp überhaupt nichts gemeinsam hat.

Ich habe kein OSX und auch kein ProFTP - aber wenn ich es hätte, würde ich als erstes einen neuen Benutzer unter OSX anlegen, speziell auf Xampp zugeschnitten, wo die Homepage beispielsweise mit dem htdocs-Ordner von Xampp übereinstimmt. Und wenn es dann möglich wäre, sich mit diesem User und dem für diesen User vergebenen User unter ProFTP einzuloggen, dann wäre die Aussage richtig, dass man in Xampp keinerlei default-Konfigurationen anpassen muss, um sofort loslegen zu können. Erst wenn das nicht funktioniert, würde ich anfangen, nach Ursachen zu suchen (und Doku zu lesen).

Man könnte dem Xampp Team möglicherweise vorwerfen, dass die Formulierung nahelegt, alles wäre einfach und man müsse von nichts eine Ahnung haben - das ist ganz sicher nicht der Fall. Eine Installation von so komplexen Serverkomponenten erfordert im Gegenteil mindestens existenzielle Systemkenntnisse, Xampp nimmt nur die Arbeit der Grundinstallation ab (was allein schon sehr schwierig sein kann), aber der vermittelte Eindruck, alles wäre einfach und jeder könnte das, der ist schlicht falsch. Das ist nicht einfach und es ist eben nicht einfack "klicki-bunti-apple-welt", sondern es geht ans Eingemachte. Solche Arbeiten verrichten bei professionellen Firmen eigens ausgebildete Administratoren - und hier versucht das jeder, der eine Maus bedienen kann, auf eigene Faust. Da ist zwingend vorprogrammiert, dass beim allerersten klitzekleinen Problem die Installation hakt - und dieser Fall ist beispielhaft. Das ist jetzt kein Vorwurf, es ist eben nicht jeder ein Systemfreak, aber das bedeutet auch, dass nicht jeder diese Software installieren kann - und wenn die Default-Einstellungen noch so einfach wie möglich gehalten sind. Es scheitert ja hier allein schon daran, dass das (Basis-)Wissen fehlt, dass ein '*' im Passwort eines Benutzers eine Login-Sperrre bedeutet - was mit Xampp (wie gesagt) überhaupt nichts zu tun hat.
Nobbie
 
Posts: 7151
Joined: 09. March 2008 13:04

Re: ProFTPd login problem

Postby kleinweby » 28. March 2009 16:11

Huhu,

Das man sich nicht als nobody mit dem Password 'xampp' einloggen kann ist ein Bug in XAMPP fuer Mac OS X 0.7.4. Desweiteren fehlen in dieser Version die Zeilen die es ermoeglichen sich mit Systembenutzern von OSX beim ProFTPd anzumelden.

Im Anschluss die proftpd.conf wie sie sein muesste:
Code: Select all
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName         "ProFTPD Default Installation"
ServerType         standalone
DefaultServer         on

# Port 21 is the standard FTP port.
Port            21

# Don't use IPv6 support by default.
#UseIPv6            off

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask            022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances         30

# Set the user and group under which the server will run.
User            nobody
Group            admin

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot /Applications/xampp/htdocs

# Normally, we want files to be overwriteable.
AllowOverwrite      on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  DenyAll
</Limit>

# nobody gets the password "xampp"
UserPassword nobody 2TgxE8g184G9c
RequireValidShell off

#to login with "OSX Users"
AuthPAM on
AuthPAMConfig ftpd

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
#<Anonymous ~ftp>
#  User            ftp
#  Group            ftp
#
#  # We want clients to be able to login with "anonymous" as well as "ftp"
#  UserAlias         anonymous ftp
#
#  # Limit the maximum number of anonymous logins
#  MaxClients         10
#
#  # We want 'welcome.msg' displayed at login, and '.message' displayed
#  # in each newly chdired directory.
#  DisplayLogin         welcome.msg
#  DisplayChdir         .message
#
#  # Limit WRITE everywhere in the anonymous chroot
#  <Limit WRITE>
#    DenyAll
#  </Limit>
#</Anonymous>


Diese sollte funktionieren. Der Fehler wird natuerlich in der naechsten XAMPP Version behoben.

Ich hoffe das ich euch damit ein wenig geholfen hab und XAMPP wird durchgehend groß geschrieben ;)

Grueße,
kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
XAMPP Version: 1.8.3-2
Operating System: Mac OS X 10.7

Re: ProFTPd login problem

Postby klunz » 29. March 2009 08:58

Klasse, vielen Dank kleinweby, damit ist das Problem gelöst :P

Wobei bei mir mit den 4 zusätzlichen Zeilen nicht nur meine Standard-OSX-User draufkommen sondern auch der "nobody" mit Passwort "xampp" (in diesem Falle ausnahmsweise kleingeschrieben :wink: ).
Scheint also kein Bug zu sein sondern lediglich die in unserer Ursprungskonfig fehlenden UserPassword und RequireValidShell Zeilen...

Jedenfalls nochmal vielen herzlichen Dank für deine schnelle Hilfe

Mfg
Tobi
klunz
 
Posts: 3
Joined: 27. March 2009 16:04

Re: ProFTPd login problem

Postby FFder1. » 17. April 2009 06:57

Ja, nach Änderung des Quellcodes klappt das; aber nur lokal.
Über das Internet mit Dyndns bekomme ich immer Fehlermeldungen, das Passwort stimme nicht.!?!

Weiß jemand Rat?

Gruß
FFder1.
 
Posts: 4
Joined: 17. April 2009 01:18

Re: ProFTPd login problem

Postby crucco37 » 28. April 2009 10:19

Hallo an alle,
bin neu hier und habe das Problem mit dem proFTPD auch. Wollte erstmal lesen, was es hier für Lösungsvorschläge gibt. Werde die hier gepostete conf demnächst auf meinen Mac zuhause ausprobieren.
Leider muss ich feststellen, das man auch hier anscheinend wenn man nicht so superschlau ist, die gleiche freundliche Ansprache erhält, wie in vielen anderen Foren. Fühle mich also gleich wieder heimisch. Nur ist das leider sehr kontraproduktiv. Hoffentlich wirds nicht zu arg schlimm. Besonders wenn ich an anderer Stelle hier meine Fragen zu Perl, cgi-bin, DBI und DBD posten werde, denn ich habe gehofft, das das laufen wird, wie von Kai Seidler versprochen. Im Moment gehts nämlich auch nicht, aber Schritt 1 bezüglich Dateirechte konnte ich noch nicht angehen.

Liebe Grüße an Alle in der Hoffnung auf freundliche Unterstützung

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: ProFTPd login problem

Postby crucco37 » 28. April 2009 21:04

na das ist schon echt lustig mit dem ProFTPd login Problem. Es ist nur die Verschlüssung des Passworts xampp für nobody.
In der der mitgelieferten proftpd.conf steht dafür 'kUbgxp3dvAUVg' drin, in der von kleinweby geposteten conf heißt
diese Verschlüsselung vom Passwort xampp aber '2TgxE8g184G9c'. Dann kann das ja auch nicht gehen.
Mit der zweiten Verschlüsselung klappt der Zugang sofort. Damit keine Misverständnisse auftreten: Ich spreche hier
von der xampp-Version 1.01 für Mac OS X.

Liebe Grüße
an Alle

_thomas

(auf sowas schräges wäre ich nicht im Traum gekommen)
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: ProFTPd login problem

Postby crucco37 » 29. April 2009 17:17

Weil ich das so schräg fand, habe ich es gleich mit einem zweiten Mac-Rechner nochmal ausprobiert. Xampp jungfräulich installiert, alles gestartet, Zugang mit Transmit auf localhost und nobody xampp versucht, login abgelehnt. Alles runtergefahren, in die noch jungfräuliche proftpd.conf den anderen Schlüssel von kleinweby reingeschrieben, abgespeichert, alles wieder gestartet, neuen Versuch mit Transmit auf localhost mit den zuvor gesicherten Zugangsdaten und siehe da, sofort login und Zugriff auf htdocs. Da muss man sich mal vorstellen, was hier vorher in diesem Thread alles so gepostet wurde. Da fällt man doch glatt vom Glauben ab und meint Arroganz ist eine Untugend, die man sich ganz schnell abgewöhnen sollte. Ein wenig Demut dazu hilft dann auch noch ein wenig.

Bis denne zum nächsten Problem

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: ProFTPd login problem

Postby crucco37 » 29. April 2009 17:24

Besonders witzig ist ja, das bei kleinweby die conf von 0.7.4 beschrieben wird. Wieviel Versionsschritte gab es denn zwischen der und der jetzigen 1.0.1?
Hat das tatsächlich seitdem niemand bemerkt oder hat vielleicht niemand den FTP-Zugang überhaupt benutzt? Vielleicht gibts deswegen den nobody?

naja nix für ungut

_thomas
User avatar
crucco37
 
Posts: 15
Joined: 28. April 2009 10:04
Location: Berlin

Re: ProFTPd login problem

Postby kleinweby » 29. April 2009 17:35

Huhu crucco,

so wie es aussieht ist (frag mich nicht wie das passieren konnte) nur die haelfte der Anderungen an der proftpd.conf uebernommen wurden und das PW blieb außenvor.

Das Problem bestand auch schon unter XAMPP 0.7.4. (danach kam dann 1.0.0 und dann 1.0.1).

Grueße,
kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
XAMPP Version: 1.8.3-2
Operating System: Mac OS X 10.7

Next

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest