phpMyAdmin - Fehler....cannot start session without errors..

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin - Fehler....cannot start session without errors..

Postby Oli Krause » 01. September 2008 17:59

Hallo zusammen,

nachdem ich verzweifelt versuche Xampp unter Leopard zu installieren und gangbar zu machen, wende ich mich nun an Euch.

Als Anfänger bezüglich dynamischer Web-Programmierung habe ich mir das Buch DreamWaever CS3 besorgt. Nach dieser Anleitung habe ich dann das mitgelieferte Xampp 0.7 auf meinem MBP installiert. Soweit so gut. Die Apache-Site wird richtig geöffnet.
Nun schreibt der Autor, daß man den erstellten Order Htdocs komplett löschen soll. Dann zeigt der Browser (Firefox) nur noch die Seite mit "Index Of"...scheint also auch zu passen.
Nächster Schritt ist, den Root auf ein anderes Laufwerk zu verbiegen. Auch das klappt nach mehreren Versuchen noch. Jetzt schreibt der Autor, daß das Verzeichnis phpMyAdmin in das neu erstellte Root kopiert werden soll. Getan und dann den Browser geöffnet, zeigt mir "IndesOf" den Ordner an.
Klicke ich nun auf diesen Link/Ordner "phpMyadmin", so bekomme ich folgende Fehlermeldung:

phpMyAdmin - Fehler
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

Da ich leidergottes auf dem OSx und gleichzeitig bezüglich Webserver/PHP blutiger Anfänger bin, drehe ich mich nun im Kreis.....
:roll:

A) wo finde ich das angesprochene log-file und
b) wahrscheinlich wisst Ihr bereits woran es bei mir krankt ?
Viele Grüße

Oli
Oli Krause
 
Posts: 4
Joined: 01. September 2008 09:02

Postby glitzi85 » 01. September 2008 18:14

Hallo,

gerade als Anfänger sollte man nicht so viel verbiegen. Am besten du installierst dir XAMPP nochmal neu. Das htdocs-Verzeichnis bitte nicht löschen, sonst fehlt die komplette XAMPP-Seite, die gerade für Anfänger doch ganz brauchbar ist.

Du kannst dir jetzt im htdocs Ordner einfach weitere Ordner erstellen, zb. test. Darin packst du dann deine ganzen Dateien und rufst es im browser einfach mit http://localhost/test auf.

phpMyAdmin braucht übrigens nicht verschoben werden, das wird über ein Alias direkt aus dem xampp Verzeichnis eingebunden, hat mit dem htdocs Ordner also erstmal gar nichts zu tun (auch wenn's so aussieht).

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Oli Krause » 01. September 2008 18:21

hai glitzi,

ersma dankeschön für Deine spontane Antwort.
Ich bin gleich hergegangen und habe alles wieder zurückgebogen. Alles läuft wieder so wie es installiert wurde..kann auch aus der Xampp-Konsole alles ohne Fehlermeldung starten.
Wenn ich nun aus der Xampp den phpmyadmin starte bekomme ich die gleiche Fehlermeldung....
Kann es daran liegen, daß irgenwelche Rechte auf meiner Maschine nicht stimmen ?
Viele Grüße

Oli
Oli Krause
 
Posts: 4
Joined: 01. September 2008 09:02

Postby Oli Krause » 01. September 2008 18:46

Hai zusammen,

jetzt hab ich noch was ausprobiert:

Xampp nochmal komplett neu installiert.
Dann aus der Xampp-Konsole mit dem Button "alle Komponenten" -- Start alles gestartet.
Dann Browser geöffnet und folgendes Ziel eingegeben:

"http://localhost/phpmyadmin/ " eingegeben. ...Ergebnis: gleicher Fehler wie oben.

Wenn ich jetzt aber bei der Konsole auf PHP Version gehe, dort den Button "aktiviere PHP4" drücke und anschließend nochmal die gleiche Adresse im Browser eingebe, dann kome ich bei phpMyAdmin- 2.11.1 raus.

....schon komisch, oder ?
Viele Grüße

Oli
Oli Krause
 
Posts: 4
Joined: 01. September 2008 09:02

Postby Oli Krause » 02. September 2008 19:23

Hai all,

ich glaube, daß ich die Lösung gefunden habe...

-----------------------------------------------------------
Just as I thought - the problem is to do with the "session.save_path" directive.
Open the file /xmapp/etc/php.ini
and uncomment the line that reads
; session.save_path = /tmp
to read
session.save_path = /tmp
Save the file. Restart xampp. All done.

-----------------------------------------------------------
Viele Grüße

Oli
Oli Krause
 
Posts: 4
Joined: 01. September 2008 09:02


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest