Weiterleitung immer auf /xampp/index.php bei Aufruf von /

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Weiterleitung immer auf /xampp/index.php bei Aufruf von /

Postby florian_ » 17. July 2008 11:36

Hallo,

Habe heute wieder XAMPP installiert, nur habe ich grobe Probleme bei den vhosts.
egal welchen vhost ich aufrufe, apache leitet immer auf /xampp/index.php weiter, diese dateien existieren unter dem aufgerufenen vhost natürlich nicht.

sprich:
localhost -> /www/xampp/index.php Richtig
localhost/code/ -> /www/code/ Richtig
code.dev -> /www/code/xampp/index.php Falsch, richtig wäre /www/code
code.dev/subdir -> /www/code/subdir Richtig

Ich hatte damit bisher noch nie Probleme, muss irgendwie an den XAMPP spezifischen Einstellungen in der httpd.conf liegen. MAMP oder selbst-installierte apaches funktionieren bei mir tadellos (die natürlich nicht laufen).

Habe schon die ganze httpd.conf durchgekaut, entsprechende .htaccess files habe ich auch nicht gefunden. Sicherheitshalber habe ich auch die index.htm gelöscht (die einen redirect beinhaltet), obwohl es daran eigentlich nicht legen kann.

Wie gesagt: sobald ich eine "domain" ohne weitere Verzeichnisangabe aufrufe wird immer xampp/index.php angehängt.

Vielen Dank schon jetzt für die HIlfe
florian_
 
Posts: 2
Joined: 17. July 2008 11:23

Postby kleinweby » 17. July 2008 20:03

huhu florian_,

leere mal deinen Browser Cache.

Grüße,
kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby florian_ » 17. July 2008 21:01

oh, danke. das hat tatsächlich funktioniert, auf diese idee wär ich nie gekommen. danke.
florian_
 
Posts: 2
Joined: 17. July 2008 11:23


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest