Autoincrement Problem

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Autoincrement Problem

Postby udow » 24. June 2008 20:05

Servus! - Ich hab ein massives Autoincrement Problem mit 0.72: Bei einer Änderung (z.b. auch durch einen import) springt der Autowert immer zur höchstmöglichen Zahl, sodass ein hinzufügen weiterer Sätze nicht möglich ist.

Das ist aber ein MySQL Problem und ist wohl mit Version 5.0.51b wieder behoben. Ein Workaround ist hier:
http://community.apachefriends.org/f/viewtopic.php?t=29577
Da ich selbst aber nicht soooo fit in der ganzen Materie bin (sonst würd ich ja XAMPP nicht benötigen) und jetzt schon stundenlang rumprobiert hab, frag ich doch mal nach, ob irgendwann demnächst ein Update ansteht...

Merci - und vielen Dank für XAMPP!
udow
udow
 
Posts: 2
Joined: 24. June 2008 19:47

Postby kleinweby » 25. June 2008 15:58

huhu udow,

Ja es steht für demnächst wieder ein Upgrade an. Die Betas für Windows und Linux sind ja schon raus und die neue Mac OS X Version folgt dann mit dem fertigen Release von Linux und Windows.

Sollte nicht mehr lange dauern :)

Grüße,
kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby udow » 25. June 2008 16:34

Super! :)
Vielen Dank!

Eins hatte ich noch, weiss aber nicht ob das auch an der mysql Version liegt (auf anderen Installationen war es richtig). Ich hatte Sätze nach einem nicht indizierten Feld sortiert, das integer war und die Datensätze mit dem Wert 1 wurden immer als letzte ausgegeben. Bei mir nicht weiter problematisch, da 'nur' in der Entwicklungsumgebung, live wäre das aber unpraktisch.

Grüße aus dem Süden,
udow
udow
 
Posts: 2
Joined: 24. June 2008 19:47


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests