Neuling in Server-Dingen ; Basiskonfiguration von Mampp

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Neuling in Server-Dingen ; Basiskonfiguration von Mampp

Postby noknok » 28. April 2008 23:29

Bisher habe ich zwei Domänen (eine .org und eine .net) auf einem kommerziellen Server hosten lassen, aber nun habe ich mampp installiert auf meinem Mac Mini, den ich künftig als Server nutzen möchte. Allerdings kriege ich die Sache irgendwie nicht in die Gänge und einige grundlegende Sachen habe ich auch noch nicht verstanden.

Mein Mac Mini ist über ein ADSL Modem/Router mit der weiten Welt verbunden. Ich habe von meinem Service-Provider eine eigene IP AAA.BBB.CCC.DDD bekommen, und die erscheint auch, wenn ich den Test über whatismyip.com durchführe.
Aber ich habe eine eigene Testdatei test-index.html erstellt in htdocs und wenn ich mampp starte, dann erscheint zwar alles bei Eingabe von
http://localhost/test-index.html
im Firefox, aber nur eine Fehlermeldung, wenn ich über mein Laptop (auch am selben Router angeschlossen)
http://AAA.BBB.CCC.DDD/test-index.html
eingebe. Ich bin also nicht von draussen sichtbar, nehme ich an.
noknok
 
Posts: 3
Joined: 28. April 2008 22:08

Postby Nobbie » 29. April 2008 10:48

Wenn Du von außen die Adresse AAA.BBB.CCC.DDD eingibst, wird ja nur Dein Router aufgerufen, denn der hat diese IP, aber nicht Dein MacMini. Der hat eine ganz andere, interne IP (Beispielsweise 192.168.1.2).

Diese interne IP ist aber von außen gar nicht aufrufbar.

Deswegen muss man im Router ein sog. Portforwarding einstellen, dass Zugriffe auf bestimmte Ports (bei Apache ist das per Default der Port 80) in Wirklichkeit gar nicht dem Router gelten, sondern einem internen Rechner.

Und dazu stellst Du im Router für den Port 80 ein Portforwarding auf Deinen MacMini ein. Wie das genau geht, hängt vom Router ab, da mußt Du Dich mal durch die Menus hangeln.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Postby noknok » 29. April 2008 21:18

Ey Mann Nobbie, vielen Dank für Deine Hilfe. Klinkt einleutend, was Du da sagst. Ich habe durch den Router und sein dürftiges Handbuch (E-tech ADSL2+ Modemrouter ADRT04) geblättert und das Web konsultiert. Aber klappen will es dennoch nicht.

Im Router Menü gibt es eine Option Advanced >> Port Forwarding. Dann erscheint ein Feld mit dem folgenden Inhalt:
WAN Connection: Xs4all (das ist mein Access-Provider)
Select LAN group: LAN group 1 (das ist die einzige, voreingestellte Option)
LAN IP: 192.168.1.2 oder 192.168.1.3

Woher wusstest Du das mit dem "192.168.1.2"? Sind die beiden "LAN IP" Nummern für meinen Mac mini und mein Laptop?

Wenn ich dann eine der beiden LAN IP ausgewählt habe, kann ich ein Kategorie wählen (Games, VPN, Audio/Video, Apps, Servers, User). Ich finke also "Servers" an und erhalte eine Liste mit "Available Rules" (Web server, FTP server, Telnet server, ...), die ich aktivieren kann zu "Applied Rules". Ich mache also "Web servers" zu eine der "Applied Rules" und aktiviere. Ich bekomme eine Tabelle zu sehen:

Rule Name: Web Server
Protocol PortStart PortEnd PortMap
TCP 80 80 80
TCP 443 443 443

Ich lasse alles speichern und neu starten. Aber meine Situation hat sich wie am Anfang nicht geändert: Auf meinem Mac erscheint bei Eingabe von
http://localhost/test.html
meine Testseite, aber auf meinem Laptop sehe ich bei
http://AAA.BBB.CCC.DDD/test.html
immer noch nichts.

Ich habe alles für beide LAN IP Nummern durchgespielt.
Was mache ich noch nicht richtig?[/img]
noknok
 
Posts: 3
Joined: 28. April 2008 22:08

Postby Nobbie » 29. April 2008 21:53

Vielleicht ist auf dem MacMini eine Firewall dazwischen? Oder im Router eine Firewall aktiv?

Wenn Du außerdem noch ein Notebook im LAN hast, dann probiere doch auch mal http://192.168.1.2/test.html aus - geht das wenigstens?

Im Prinzip ist das im Router die richtige Stelle gewesen, aber viel mehr kann ich dazu nicht mehr sagen, weil ich nichts davon hier sehen kann.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Postby noknok » 29. April 2008 22:45

Hi Nobbie, ich schulde Dir was. Vielen Dank.

Inzwischen habe ich festgestellt, dass unter "DHCP clients" tatsächlich 192.168.1.2 mein Laptop und 192.168.1.3 mein Mac mini ist. Auf dem Mac mini ist (habe noch einmal nachgesehen) keine Firewall installiert. Auf dem Router gab es eine Option "Firewall/NAT services" und die war "enabled". Ich habe es disabled, aber auch das ändern nichts an meinen Befunden.

Und auf meinem Laptop führt
http://192.168.1.3/test.html
zu "Fehler, Wartezeit auf den Server ist überschritten".

So ich meine Hardware in den Müll schmeissen?
noknok
 
Posts: 3
Joined: 28. April 2008 22:08


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests