Noch jemand mit Installationsproblemen bzw. Erfahrung?

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Noch jemand mit Installationsproblemen bzw. Erfahrung?

Postby ben2223 » 11. December 2007 02:19

Hallo,

ich hatte Xampp erfolgreich installiert (tar xfvz xampp-macosx-0.7.0.tar.gz -C / ) und alles funktionierte. Dann habe ich es entfernt (rm -rf /Applications/xampp ) und reinstalliert.

Beim starten mit ( /Applications/xampp/xamppfiles/mampp start ) erschien zuerst die Fehlermeldung zu MySQL:

2-computer:/Users/2 root# /Applications/xampp/xamppfiles/bin/mysql.server: line 159: kill: (28799) - No such process


Also, wieder alles deinstalliert (s.o) und reinstalliert. Diesesmal gab es auch ein Problem mit Apache und MySQL.


2-computer:/Users/2 root# sudo su
2-computer:/Users/2 root# /Applications/xampp/xamppfiles/mampp start
Starting XAMPP for MacOS X 0.7.0...
XAMPP: File permissions are being checked... this may take a while.
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!

XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for MacOS X started.
2-computer:/Users/2 root# /Applications/xampp/xamppfiles/bin/mysql.server: line 159: kill: (28799) - No such process


Meine Vermuting ist, dass irgendwas von der alten installation übrig geblieben ist...

Hat jemand Erfahrung bzw. ein ähnliches Problem gehabt?

Thx,
Ben

OS X 10.4.10 ist das OS.


PS: Das MySQL problem war schon hier präsent: http://community.apachefriends.org/f/viewtopic.php?t=24835
Last edited by ben2223 on 11. December 2007 09:09, edited 1 time in total.
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

Postby kleinweby » 11. December 2007 06:47

huhu,

was steht den in der error_log in /Applications/xampp/logs/?

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

logs/error

Postby ben2223 » 11. December 2007 07:04

im error log: nichts

im apache log:
(48)Address already in use: make_sock: could not bind to address [::]:80
(48)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

Postby kleinweby » 11. December 2007 07:07

du hast warscheinlich vergessen xampp zu stoppen bevor du es gelöscht hast.

Einfach mal in der Aktivitätsanzeige alle httpd, mysqld programme beenden
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Aktivitätsanzeige?

Postby ben2223 » 11. December 2007 07:17

hey!

vielen dank für die schnelle Antwort. Was ist die "Aktivitätsanzeige"? bin neu bei Mac. wo finde ich diese?
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

Postby ben2223 » 11. December 2007 07:45

Kleinweby wrote:du hast warscheinlich vergessen xampp zu stoppen bevor du es gelöscht hast.

Einfach mal in der Aktivitätsanzeige alle httpd, mysqld programme beenden


aktivitätsanzeige habe ich gefunden, finde dort aber kein Apache oder mysql server???
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

logs

Postby ben2223 » 11. December 2007 07:54

Dec 11 00:01:37 2-computer lookupd[18255]: lookupd (version 369.6) starting - Tue Dec 11 00:01:37 2007
Dec 11 00:49:12 2-computer kernel[0]: System SafeSleep
Dec 11 00:49:12 2-computer kernel[0]: hibernate_page_list_setall start
Dec 11 00:49:12 2-computer kernel[0]: hibernate_page_list_setall time: 526 ms
Dec 11 00:49:12 2-computer kernel[0]: pages 638273, wire 81698, act 76138, inact 87941, zf 11098, could discard act 59259 inact 322139
Dec 11 00:49:12 2-computer kernel[0]: hibernate_page_list_setall found pageCount 638273
Dec 11 00:49:12 2-computer kernel[0]: IOHibernatePollerOpen, ml_get_interrupts_enabled 0
Dec 11 00:49:12 2-computer kernel[0]: IOHibernatePollerOpen(0)
Dec 11 00:49:12 2-computer kernel[0]: writing 637883 pages
Dec 11 00:49:12 2-computer kernel[0]: image1Size 127251456
Dec 11 00:49:12 2-computer kernel[0]: all time: 12372 ms, comp time: 2476 ms, deco time: 0 ms,
Dec 11 00:49:12 2-computer kernel[0]: image 484754432, uncompressed 1050562560 (256485), compressed 481886580 (45%), sum1 3a58d92a, sum2 bec5e444
Dec 11 00:49:12 2-computer kernel[0]: hibernate_write_image done(0)
Dec 11 00:49:12 2-computer kernel[0]: sleep
Dec 11 00:49:12 2-computer kernel[0]: Enabling XMM register save/restore and SSE/SSE2 opcodes
Dec 11 00:49:12 2-computer kernel[0]: Started CPU 01
Dec 11 00:49:12 2-computer kernel[0]: IOBluetoothHCIController::restartShutdownWL this is a wake from sleep
Dec 11 00:49:12 2-computer kernel[0]: System Wake
Dec 11 00:49:12 2-computer kernel[0]: IOUSBWorkLoop::closeGate - interrupt Thread being held off
Dec 11 00:49:16 2-computer configd[35]: AppleTalk startup
Dec 11 00:49:16 2-computer BatteryUpdater[18264]: Battery is already up-to-date with BatteryUpdater v 1.2
Dec 11 00:49:19 2-computer configd[35]: posting notification com.apple.system.config.network_change
Dec 11 00:49:19 2-computer lookupd[18271]: lookupd (version 369.6) starting - Tue Dec 11 00:49:19 2007
Dec 11 00:49:22 2-computer configd[35]: AppleTalk startup complete
Dec 11 01:18:10 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 01:18:18 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 02:18:09 2-computer authexec: executing /System/Library/ScriptingAdditions/StandardAdditions.osax/Contents/MacOS/uid
Dec 11 02:27:16 2-computer su: pam_authenticate: User not known to the underlying authentication module
Dec 11 02:46:39 2-computer mdimportserver[24279]: Could not find an index xml for doc at /Applications/xampp/etc/ssl.key
Dec 11 02:47:03 2-computer su: pam_authenticate: User not known to the underlying authentication module
Dec 11 02:47:14 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 02:48:48 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 02:51:33 2-computer /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow: Login Window Application Started
Dec 11 02:51:34 2-computer loginwindow[19882]: Login Window Started Security Agent
Dec 11 02:51:49 2-computer /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport: Currently connected to network bala
Dec 11 02:51:49 2-computer /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport: Currently connected to network bala
Dec 11 02:52:54 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 02:53:22 2-computer mdimportserver[19892]: Could not find an index xml for doc at /Applications/xampp/etc/ssl.key
Dec 11 02:53:40 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 02:54:01 2-computer KernelEventAgent[29]: tid 00000000 received unknown event (12)
Dec 11 02:55:14 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 02:56:02 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 02:57:02 2-computer authexec: executing /System/Library/ScriptingAdditions/StandardAdditions.osax/Contents/MacOS/uid
Dec 11 02:57:05 2-computer authexec: executing /System/Library/ScriptingAdditions/StandardAdditions.osax/Contents/MacOS/uid
Dec 11 02:57:13 2-computer authexec: executing /System/Library/ScriptingAdditions/StandardAdditions.osax/Contents/MacOS/uid
Dec 11 02:57:13 2-computer sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 02:57:56 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 02:58:35 2-computer mdimportserver[19892]: Could not find an index xml for doc at /Applications/xampp/etc/ssl.key
Dec 11 03:01:23 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 03:02:59 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:26:44 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:38:14 2-computer sudo: 2 : TTY=ttyp1 ; PWD=/Users/2 ; USER=root ; COMMAND=/usr/bin/su
Dec 11 03:40:23 2-computer mdimportserver[19892]: Could not find an index xml for doc at /Applications/xampp/etc/ssl.key
Dec 11 03:42:33 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:45:55 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:46:03 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:46:10 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:46:16 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:49:15 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 03:49:18 2-computer mdimportserver[19892]: Could not find an index xml for doc at /Applications/xampp/etc/ssl.key
Dec 11 08:04:03 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 08:32:29 2-computer sudo: 2 : TTY=unknown ; PWD=/Users/2 ; USER=root ; COMMAND=/Applications/xampp/xamppfiles/bin/mysql.server start
Dec 11 08:37:41 2-computer KernelEventAgent[29]: tid 00000000 received unknown event (12)
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

error 403

Postby ben2223 » 11. December 2007 09:07

Ok. Habe noch einmal alles deinstalliert.

Wenn nach Deinstallation folgendes eingebe http://localhost/xampp/index.php eingebe erhalte ich error 403: Forbidden

You don't have permission to access /xampp/index.php on this server.


Es scheint also, dass xampp noch immer existiert, OBWOHL ich es mit su sudo und rm -rf /Applications/xampp gelöscht hab.

Da ich Xampp unter Windows benutze und begeistert bin, möchte ich helfen es für MAC zu verbessern.

Aktuell helfe ich mir mit Mamp.
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

Re: error 403

Postby kleinweby » 11. December 2007 14:06

ben2223 wrote:Es scheint also, dass xampp noch immer existiert, OBWOHL ich es mit su sudo und rm -rf /Applications/xampp gelöscht hab.


Du musst bedenken das löschen und stoppen nicht unbedingt das gleiche ist. Der Apache läuft nämlich auch weiter obwohl er gelöscht wurde...

Und du suchst auch nach httpd in der Aktivitätsanzeige und nicht nach Apache?
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby ben2223 » 11. December 2007 15:17

in der Aktivitätsanzeige steht nirgendwo etwas von httpd wenn ich xampp gelöscht habe.


wenn ich mamp laufen habe, dann sehe ich natürlich httpd und mysqld, wobei dann httpd mehrfach vorkommt.

was nun?
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07

Postby kleinweby » 11. December 2007 15:23

und beim starten kommt die meldung

Code: Select all
(48)Address already in use: make_sock: could not bind to address 0.0.0.0:80


bzw. steht in der log? Ist den evtl. der Apache vom System an?
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby ben2223 » 11. December 2007 16:12

Kleinweby wrote:und beim starten kommt die meldung

Code: Select all
(48)Address already in use: make_sock: could not bind to address 0.0.0.0:80


bzw. steht in der log? Ist den evtl. der Apache vom System an?


wie sehe ich ob der apchace from system an ist.

Logs habe ich oben gepostet.

kleinweby - hast du skype? kannst du mir deinen nick per pm schicken, wäre super!
ben2223
 
Posts: 9
Joined: 11. December 2007 02:07


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests