XAMPP unter Leopard

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP unter Leopard

Postby lookbook » 27. October 2007 21:37

Hallo,

habe heute von Tiger auf Leopard geupdatet. Auf den ersten Blick dachte ich xampp funktioniert ohne Probleme jedoch spuckt PHP folgende Fehlermeldung aus und meine ganzen Logins funktionieren nicht mehr:



Code: Select all
[27-Oct-2007 22:22:41] PHP Warning:  Unknown: open(/var/folders/cR/RRuvWd45E+8ZhH1dfg38NKDR+++TI/-Tmp-//sess_745d91dc490cac84531545253057b0f, O_RDWR) failed: Permission denied (13) in Unknown on line 0
[27-Oct-2007 22:22:41] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0
[27-Oct-2007 22:22:42] PHP Warning:  session_start() [<a href='function.session-start'>function.session-start</a>]: open(/var/folders/cR/c56vWd56RE+8ZhH16738NKDU+++TI/-Tmp-//sess_785d561dc490cac67453167b7c253057b0f, O_RDWR) failed: Permission denied (13) in /Applications/xampp/xamppfiles/htdocs/access_check.php on line 4


phpmyadmin gibt folgende meldung raus:

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


Weiß jemand wie man xampp unter Leopard wieder zum Laufen bekommt?
lookbook
 
Posts: 8
Joined: 31. July 2007 21:41

Postby themaverick » 27. October 2007 23:06

ich hänge am selben Problem.
PHP läuft bei mir allerdings sonst ok.. nur phpmyadmin geht nicht und in xampp Status steht deaktiviert...

Ich werkel da jetzt noch ein wenig dran herum .. Ergebnisse folgen hoffentlich.
themaverick
 
Posts: 2
Joined: 27. October 2007 23:02

Postby themaverick » 27. October 2007 23:18

ok mein phpmyadmin geht zumindest schonmal

geh ins Verzeichniss
/Programme/xampp/etc/

öffne die php.ini in nem beliebigen texteditor
sich nach "session.save_path" (voraussichtlich zeile 839)
und entferne das ; vor der gleichnamigen Zeile


damit sollten die sessions und damit verbundene Logins wieder funktionieren
damit das xampp eigene phpmyadmin wieder funktioniert must du, sofern du das standarpasswort mit dem xampp hilfestool auf der konsole geändert hast noch folgende Änderung vornehmen:

unter
/Programme/xampp/xamppfiles/phpmyadmin/
änderst du die "config.inc.php" auf zeile 34 (password) ab in dem du am ende der zeile zwischen die '' dein passwort setzt und die datei wieder speicherst.

hoffe das hat erstmal geholfen... ich bin selbst noch am durchtesten ...
themaverick
 
Posts: 2
Joined: 27. October 2007 23:02

Postby lookbook » 27. October 2007 23:51

herzlichen dank!
scheint alles erstmal wieder wie gehabt zu funktionieren ...
lookbook
 
Posts: 8
Joined: 31. July 2007 21:41

Danke...

Postby eLapaloma » 02. December 2007 16:27

Hatte das Problem auch, hat super geklappt :D
nicht so wichtig
eLapaloma
 
Posts: 1
Joined: 02. December 2007 16:05

Postby taeb.de » 23. December 2007 03:53

themaverick wrote:ok mein phpmyadmin geht zumindest schonmal

geh ins Verzeichniss
/Programme/xampp/etc/

öffne die php.ini in nem beliebigen texteditor
sich nach "session.save_path" (voraussichtlich zeile 839)
und entferne das ; vor der gleichnamigen Zeile


damit sollten die sessions und damit verbundene Logins wieder funktionieren
damit das xampp eigene phpmyadmin wieder funktioniert must du, sofern du das standarpasswort mit dem xampp hilfestool auf der konsole geändert hast noch folgende Änderung vornehmen:

unter
/Programme/xampp/xamppfiles/phpmyadmin/
änderst du die "config.inc.php" auf zeile 34 (password) ab in dem du am ende der zeile zwischen die '' dein passwort setzt und die datei wieder speicherst.

hoffe das hat erstmal geholfen... ich bin selbst noch am durchtesten ...


warum wird sowas von der entwicklerseite nicht eingebaut und somit behoben? :)



bin der Anleitung gefolgt - alles super ;)


wenn ich die Dienste normal beenden möchte erscheint folgendes

Image

öhm wie kann ich phpmyadmin updaten da folgende Lösung nicht gezogen hat: http://localhost/phpmyadmin/Documentation.html#faq1_16

kapiere das nicht ganz - hab jetzt die 3 werte in der phpini geändert - auch mit dem letzten Tip
One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.
konnte ich keine Veränderung erkennen :(
taeb.de
 
Posts: 3
Joined: 23. December 2007 03:35
Location: Erlangen

Postby kleinweby » 23. December 2007 11:07

taeb.de wrote:
themaverick wrote:ok mein phpmyadmin geht zumindest schonmal

geh ins Verzeichniss
/Programme/xampp/etc/

öffne die php.ini in nem beliebigen texteditor
sich nach "session.save_path" (voraussichtlich zeile 839)
und entferne das ; vor der gleichnamigen Zeile


damit sollten die sessions und damit verbundene Logins wieder funktionieren
damit das xampp eigene phpmyadmin wieder funktioniert must du, sofern du das standarpasswort mit dem xampp hilfestool auf der konsole geändert hast noch folgende Änderung vornehmen:

unter
/Programme/xampp/xamppfiles/phpmyadmin/
änderst du die "config.inc.php" auf zeile 34 (password) ab in dem du am ende der zeile zwischen die '' dein passwort setzt und die datei wieder speicherst.

hoffe das hat erstmal geholfen... ich bin selbst noch am durchtesten ...


warum wird sowas von der entwicklerseite nicht eingebaut und somit behoben? :)
;

meinst du das mit session.save_path? wenn ja -> Als die letzt XAMPP for Mac OS X raus kamm gabs noch kein leopard, bzw. wir hatten keins. Daher wusten wir nicht das diese option unter leopard probleme bereiten tut. In der nächsten version wird sie aber gesetzt sein.

oder meinst du die config.inc.php? -> Es wurde schon öfters diskutiert, aber auf jeden fall kam man zum entschluss das es sinnlos wäre das Password in Mysql zu ändern und dann wieder im klartext in die config.inc.php zu schreiben...

taeb.de wrote:
bin der Anleitung gefolgt - alles super ;)


wenn ich die Dienste normal beenden möchte erscheint folgendes

Image

öhm wie kann ich phpmyadmin updaten da folgende Lösung nicht gezogen hat: http://localhost/phpmyadmin/Documentation.html#faq1_16

kapiere das nicht ganz - hab jetzt die 3 werte in der phpini geändert - auch mit dem letzten Tip
One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.
konnte ich keine Veränderung erkennen :(


Du möchtes phpmyadmin updaten? Ganz einfach: Neue version herrunter laden und die alte im xamppfiles ordner ersetzen.

Du must nichts an den php-einstellungen drehen um phpmyadmin zu updaten. Oder hab ich was falsch verstanden.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby taeb.de » 27. December 2007 00:08

hi

thx. also phpmyadmin hab ich jetzt updaten können ;)

ABER

wie kann ich die Dateigröße zum Importieren ändern?

(Maximale Dateigröße: 131 kKiB)

vielen dank!
taeb.de
 
Posts: 3
Joined: 23. December 2007 03:35
Location: Erlangen

Postby sari42 » 27. December 2007 01:51

siehe FAQ 1.16 : Stichwort "UploadDir" (dorthin kann man die dumps auch "g-zipped" hochladen)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby taeb.de » 27. December 2007 02:30

sari42 wrote:siehe FAQ 1.16 : Stichwort "UploadDir" (dorthin kann man die dumps auch "g-zipped" hochladen)


das hatte ich auch gesehen - ehrlich gesagt verstehe ich das so, dass ich per ftp einfach die file dorthin laden kann wo diese uploaddir ist und somit die phpmyadminsuploadlimitbla umgehe

nur wo ist dieser uploadordner ;) ?
taeb.de
 
Posts: 3
Joined: 23. December 2007 03:35
Location: Erlangen

Postby sari42 » 27. December 2007 21:15

den kann man frei wählen, z.B.:
Code: Select all
$cfg['UploadDir'] = 'd:/ausserhalbHtdocs/impex';
$cfg['SaveDir']   = 'd:/ausserhalbHtdocs/impex';
(in config.inc.php)

Auf den Import-/Export-Seiten erscheint dann ein neuer Menüpunkt
(bei Import allerdings nur, wenn dort passende Dateien vorhanden sind).

p.s.
Das hab ich aus phpmyadmin/Documentation.html ;)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests