MySQL deaktiviert - XAMPP 0.3 auf 10.3.9

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL deaktiviert - XAMPP 0.3 auf 10.3.9

Postby Pallas » 12. August 2007 16:13

Hiho!

Habe grade XAMPP 0.3 installiert (hoeher geht nicht, da mein OS so alt ist - 10.3.9).

Problem: MySQL ist laut der Status-Seite deaktiviert.
Die PHP-MyAdmin-Seite sagt auch:
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Obwohl beim Start folgendes kam:
Starting XAMPP for MacOS X 0.3...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for MacOS X started.

Scheint ja kein unbekanntes Problem zu sein, aber leider hat mir keine der Antworten in der anderen Postings geholfen.

Z.B. habe ich "sudo killall mysql" ausprobiert. Ergebnis:
"No matching processes were found"

Komisch daran ist, dass der mysqld in der Prozessliste auftaucht:
" 9773 std S 0:00.04 sh /Applications/xampp/xamppfiles/bin/mysqld_safe --d
9798 std S 0:00.31 /Applications/xampp/xamppfiles/sbin/mysqld --basedir="

Keinen der beiden Prozesse kann ich killen. (Auch nicht mit -9.)
Wenn ich Mampp stoppe sind sie aber weg.

Hab Mampp jetzt mehrmals gestoppt und gestartet (der alte Windows-Trick), leider ohne das sich der Fehler behoben haette.

Ich hab alles als "root" gemacht und ich weiss, dass ich frueher schon mal ein XAMPP installiert hatte. Damals war alles supereinfach!

Zwischen der damaligen Installation und heute habe ich eine PostgreSQL-Datenbank installiert. Koennte der Fehler daran liegen? Die Postgre-DB laeuft aber laut "ps ax" nicht.

In anderen Postings stand man solle sich die Error-Datei angucken. Ich werd leider nicht schlau draus, aber vielleicht weiss eine/r von euch was damit anzufangen:

070812 16:17:59 mysqld started
070812 16:18:00 [Warning] Setting lower_case_table_names=2 because file system for /Appl
ications/xampp/xamppfiles/var/mysql/ is case insensitive
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
070812 16:18:00 InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
070812 16:18:06 InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
070812 16:18:07 InnoDB: Log file ./ib_logfile1 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
070812 16:18:10 InnoDB: Started; log sequence number 0 0
/Applications/xampp/xamppfiles/sbin/mysqld: ready for connections.
Version: '4.1.12-log' socket: '/tmp/mysql.sock' port: 3306 Source distribution
070812 16:31:18 [Note] /Applications/xampp/xamppfiles/sbin/mysqld: Normal shutdown

Danke schonmal fuer's Lesen. Bin fuer jeden Hinweis dankbar!

Vielen Dank im Voraus & schoenen Abend noch,

Pallas

PS: Welche Sprache ist eigentlich besser fuer Postings (= mehr Antworten), en oder de?
Pallas
 
Posts: 2
Joined: 12. August 2007 15:43

Upsi, Rechtschreibfehler - funzt aber trotzdem nicht :(

Postby Pallas » 12. August 2007 16:41

Ich nochmal. Wer genau aufgepasst hat, hat vielleicht gemerkt, dass ich faelschlicherweise "killall mysql" statt "killall mysqld" geschrieben hatte. Mit dem d hintendran werden die Prozesse zwar gefunden und beendet, aber leider aendert das nix am "deaktiviert"en Status :(

[Hab das "killall" beim laufenden und beim gestoppten XAMPP probiert und auch bei gestartetem XAMPP mal 'startmysql' probiert. Keine Kombination hat funktioniert, obwohl die Meldung immer lautet "XAMPP: Starting MySQL..."

Und in den Prozessen isser auch:
10221 std S 0:00.03 sh /Applications/xampp/xamppfiles/bin/mysqld_safe --datadir=/
10246 std S 0:00.94 /Applications/xampp/xamppfiles/sbin/mysqld --basedir=/Applica

Arrgh, ich raff es nicht. Bin verzweifelt...]
Pallas
 
Posts: 2
Joined: 12. August 2007 15:43


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest