Browser lädt index.php runter anstatt sie auszuführen

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Browser lädt index.php runter anstatt sie auszuführen

Postby Braeburn » 05. April 2007 09:10

Moin,

habe xampp-macosx-0.5.tar.bz2 (etwas ältere Version, da dies die einzig verfügbare für PPC-Architektur ist) installiert.

Während der Installation wurde ich nach dem Admin Account gefragt, so daß die Installation als root durchgeführt wurde. Wenn XAMPP anschließend von der GUI aus mittels "mamppstart" gestartet wird, wird dies mit einer Erfolgsmeldung quittiert.

Wenn ich aber über die Shell "sudo ../xamppfiles/mampp phpstatus" ausführe, erscheint folgende Fehlermeldung:

Code: Select all
Unknown option: n
Usage: head [-options] <url>...
    -m <method>   use method for the request (default is 'HEAD')
    -f            make request even if head believes method is illegal
    -b <base>     Use the specified URL as base
    -t <timeout>  Set timeout value
    -i <time>     Set the If-Modified-Since header on the request
    -c <conttype> use this content-type for POST, PUT, CHECKIN
    -a            Use text mode for content I/O
    -p <proxyurl> use this as a proxy
    -P            don't load proxy settings from environment
    -H <header>   send this HTTP header (you can specify several)

    -u            Display method and URL before any response
    -U            Display request headers (implies -u)
    -s            Display response status code
    -S            Display response status chain
    -e            Display response headers
    -d            Do not display content
    -o <format>   Process HTML content in various ways

    -v            Show program version
    -h            Print this message

    -x            Extra debugging output


Wollte dann im mampp-script den Aufruf fixen, da existiert aber überhaupt kein "head"-Aufruf.

Wer weiß nun weiter?

Grüße,

B.
Braeburn
 
Posts: 1
Joined: 05. April 2007 08:54

die lösung...

Postby kritzikratzi » 19. July 2007 23:19

ich hatte das selbe problem.
und zwar benötigt eines der startscript den befehl "head", der normalerweise die ersten x zeilen einer datei anzeigt.

bei mir war der befehl "head" duch einen befehl der http header anzeigen kann ausgetauscht worden (eine schlampiges installationsprogramm schätz ich mal).

kopier die datei /usr/bin/head von einem neuen os x auf deinen computer und das problem wird gelöst sein.
kritzikratzi
 
Posts: 2
Joined: 19. July 2007 23:14


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests