Apache und ProFTPD startet nicht

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Kristian Marcroft » 14. December 2006 21:28

Hallo,

wie lautet die Fehlermeldung bei dir genau?
Bitte schaue ebenfalls in die apachestart.log

Gruß
Kristian Marcroft
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Sisko86 » 15. January 2007 18:45

Also ich habe den gleichen Fehler gehabt und gelöst,
vieleicht hilfts jemandem:

in der /etc/hosts muss stehen
IP name alias

der alias ist dann der name des computers
diesen erfährt man mit dem befehl: hostname

bei mir:
127.0.0.1 localhost powerbook

Hoffe ich konnte helfen
Sisko86
 
Posts: 1
Joined: 15. January 2007 18:37

hosts editieren

Postby rk1954m » 15. January 2007 21:39

Also nehmt euch erstmal einen Editor, der Unix Files erstellt/bearbeitet. Im OS X wird z.B. PICO mitgeliefert, wenn ihr gerne was komfort mässiges hättet SubEthaEdit, BBedit, ...

An ins Terminal.

$ cd /etc
$ sudo su
# pico hosts

GNU nano 1.2.4 File: hosts

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost mac
255.255.255.255 broadcasthost
::1 localhost

Den Editor mit ^O zurückschreiben und mit ^X verlassen und Xampp starten.

Wenn's nicht klappt - melden. Bei Notstand per Skype...
rk1954m
 
Posts: 5
Joined: 15. January 2007 20:48

Postby .local » 07. February 2007 12:53

ich habe echo '127.0.0.1 username' >> /etc/hosts
angewendet und bekomme leider immer noch die selbe fehlermeldung

Starting XAMPP for MacOS X 0.5...
XAMPP: Starting Apache with SSL (and PHP4)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: - getaddrinfo '123' error: No address associated with nodename
- warning: unable to determine IP address of '123'
- error: no valid servers configured
- Fatal: error processing configuration file '/Applications/xampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for MacOS X started.

xampp lief bis vor ein paar tagen völlig problemlos
und jetzt auf einmal nicht mehr, ich kann mir das höchstens mit einem security update über die software aktualisierung erklären, denn sonst hat sich nichts verändert …

oder woran kann das noch liegen
.local
 
Posts: 2
Joined: 07. February 2007 12:44

Postby PF4 » 07. February 2007 13:38

Code: Select all
echo '127.0.0.1 username' >> /etc/hosts


ähm username?

Code: Select all
echo "127.0.0.1 `hostname`" >> /etc/hosts
ist richtig!
Bitte copy und paste! die ` und " sind wichtig!
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby .local » 07. February 2007 13:58

danke !!
.local
 
Posts: 2
Joined: 07. February 2007 12:44

hab das gleiche problem

Postby oli686 » 25. April 2007 22:10

hallo,

bin auch neu mit dem ganzen thema und mich nervst schon richtig.
lese und lese und es gibt kein weiterkommen. ich hoffe das hier ist meine rettung.

bekomme wie viele hier unter Mac OS X 10.4.9 den Apache und das Ftpd nicht ans laufen.
Ich habe ein Mac Book Pro (Intel).

hier der fehler der einige bestimmt schon langweilt:

darth-vader:/Users/oliverschran root# /Applications/xampp/xamppfiles/mampp startStarting XAMPP for MacOS X 0.6.1...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: XAMPP-MySQL is already running.
XAMPP: Starting ProFTPD...
XAMPP: - IPv4 getaddrinfo 'darth-vader' error: No address associated with nodename
- warning: unable to determine IP address of 'darth-vader'
- error: no valid servers configured
- Fatal: error processing configuration file '/Applications/xampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for MacOS X started.
darth-vader:/Users/oliverschran root#


hab nun auch alle möglichen vorschläge von oben durch und bekomme das ding nicht an den start....

gibt es irgentwo einen verbindlichen lösungsvorschlag?
auf der page wo ich es geladen habe ist die problemsection noch im aufbau.

ich bin für jeden input dankbar. bitte bei der antwort rücksicht nehmen, da das ganze thema recht neu für mich ist.

vielen dank für eure hilfe.

oli
oli686
 
Posts: 1
Joined: 25. April 2007 22:02

Viele Antworten, aber viele Details ungeklärt

Postby mitomedia » 20. August 2007 00:21

Aus der Diskussion habe ich einiges verstanden, aber leider sind immer noch ein paar Fragen offen. Ich bekomme dieselbe Fehlermeldung (Apache startet nicht) und offensichtlich muss ich noch den Namen meines Rechners als Host festlegen. Ich habe auch echo '127.0.0.1 Macintosh.local' >> /etc/hosts eingegeben (und Macintosh.local durch meinen Rechnernamen aus den System Preferenzen ersetzt) und XAMPP neu gestartet. funktioniert nicht, erhalte immer noch die gleiche Fehlermeldung.

Ich habe folgende Fragen, die mir hoffentlich jemand beantworten kann:

1. Im Ordner /etc/ gibt es keinen Unterordner oder Datei mit dem Namen "hosts". Mir ist unklar wieso nicht. Ich habe auch gelesen, dass man diesen Wert manuel im Texteditor ändern kann. Aber wo, wenn es keine Datei gibt? Ich habe nur im httpd.conf Datei einen Eintrag für den ServerNamen gefunden.

2. Beim Eingeben des Hostnamens muss ich das .local hinzufügen. Ich frage nur deswegen, will in einer der Erklärunge das .local nicht dabei war.

Besten Dank im Voraus,

Michael
mitomedia
 
Posts: 1
Joined: 19. August 2007 23:04

Re: Viele Antworten, aber viele Details ungeklärt

Postby kleinweby » 20. August 2007 08:29

mitomedia wrote:Aus der Diskussion habe ich einiges verstanden, aber leider sind immer noch ein paar Fragen offen. Ich bekomme dieselbe Fehlermeldung (Apache startet nicht) und offensichtlich muss ich noch den Namen meines Rechners als Host festlegen. Ich habe auch echo '127.0.0.1 Macintosh.local' >> /etc/hosts eingegeben (und Macintosh.local durch meinen Rechnernamen aus den System Preferenzen ersetzt) und XAMPP neu gestartet. funktioniert nicht, erhalte immer noch die gleiche Fehlermeldung.

Ich habe folgende Fragen, die mir hoffentlich jemand beantworten kann:

1. Im Ordner /etc/ gibt es keinen Unterordner oder Datei mit dem Namen "hosts". Mir ist unklar wieso nicht. Ich habe auch gelesen, dass man diesen Wert manuel im Texteditor ändern kann. Aber wo, wenn es keine Datei gibt? Ich habe nur im httpd.conf Datei einen Eintrag für den ServerNamen gefunden.

Das ist aber sehr komisch. Du darfst nicht in Finder schaun, der blendet unter umständen mal was aus!.
[qoute]
2. Beim Eingeben des Hostnamens muss ich das .local hinzufügen. Ich frage nur deswegen, will in einer der Erklärunge das .local nicht dabei war. [/quote]

Nein musst du nicht. Es muss nur dein hostname sein.
Am einfachsten geht das im Terminal so:

Code: Select all
sudo -s #Dein PW musst du hier eingeben
echo "127.0.0.1 $(hostname)" >> /etc/hosts
exit


kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Previous

Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests