Links funktionieren nicht…

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Links funktionieren nicht…

Postby M030 » 24. January 2023 19:21

Hallo in die Runde,
bin in Sachen Xampp Neuling. Ich habe im Ordner htdocs einen Unterordner A angelegt. Hier befindet sich auch eine index.php. Diese wird auch angezeigt. Wenn ich auf einen Link zu einer Seite in einem Unterordner klicke, funktioniert das ebenfalls. Nur von einem weiteren Unterordner in einen anderen wird mir der error404 angezeigt. Von einem Unterordner in einen andern funktioniert es dann nicht? Verstehe ich gerade nicht ganz…

Htdocs -> Ordner A -> Index.php, funktioniert wird angezeigt
Von Index.php per Link nach Ordner B zur Seite Test.php, funktioniert alles
Vom Ordner B Seite Test.php per Link auf Ordner C zu einer Seite ergibt error404!?

:? Hoffe das ist verständlich!? Muss man da irgendwo in den Einstellungen etwas vornehmen? Die Pfadangaben stimmen zu 100%!

Vielen Dank…
M030
 
Posts: 1
Joined: 24. January 2023 18:51
XAMPP version: 8.2.0
Operating System: MacOS Ventura

Re: Links funktionieren nicht…

Postby Altrea » 24. January 2023 19:30

Hi,

XAMPP ist da erstmal raus. Der Apache verarbeitet das PHP zwar und liefert es aus, aber danach ist der raus. Wenn du dann einen Link klickst, wird ein neuer Request gefeuert, der für sich genommen verarbeitet wird. Funktioniert ein Link nicht, liegt die Datei entweder nicht am richtigen Platz, dein Link ist verkehrt oder der Aufruf der initialen php/html Datei.

Mehr kann ich dazu nicht sagen ohne den Quelltext zu kennen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 11743
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Links funktionieren nicht…

Postby Nobbie » 24. January 2023 22:54

M030 wrote:Vom Ordner B Seite Test.php per Link auf Ordner C zu einer Seite ergibt error404!?


Error 404 hat verschiedene Ursachen:

1) verlinkte Datei existiert nicht
2) der verlinkte Ordner existiert nicht
3) die verlinkte Datei / der verlinkte Ordner darf nicht von Apache System User gelesen werden.

Leider wissen wir hier rein gar nichts über die verlinkten Dateien, das macht es unmöglich, präziser zu helfen.
Nobbie
 
Posts: 12705
Joined: 09. March 2008 13:04


Return to XAMPP für macOS

Who is online

Users browsing this forum: No registered users and 2 guests