Massive Problem mit XAMPP 1.8.3

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 27. October 2013 00:20

Ich bin kein Neuling mit XAMPP und habe es immer gerne benutzt.
Seit einem halben Jahr habe ich eine iMac auf dem lief bis dato XAMPP 1.7.3, einwandfrei.
Jetzt habe ich diese Version entfernt und mir die neue heruntergeladen und entsprechend der Dokumentation installiert.
Das hat auch noch funktioniert.
Nur dann fingen die Probleme an. Ich weiß es sit open source aber ich darf doch erwarten das alle Komponenten auch da hochlaufen.
Xampp gestartet. sah auch noch gut aus.
Da ich mit MYSQL Datenbanken arbeite wollte ich in PHPADMIN neue Datenbanken anlegen. Was soll ich sagen. Folgende Fehlermeldung erschien: Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen.
Ich habe gegoogled und gegoogled aber nichts hat geholfen.
selbst über manage-osx started der server aber zeigt dann anschliessend wieder gestopped. Ich weiss nicht mehr vor oder zurück. In den LOGS steht nichts auswertbares. also was könnte das sein.

ich werde es jetzt zum 5 mal neu installieren und schauen ob es dann funktioniert. Wenn es dann nicht funktioniert wo bekomme ich die vorgängerversion her.
Frust :cry:
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 27. October 2013 00:33

gerade mit der neu installation fertig geworden. Nichts. Mysql startet nicht. Ich werde auch währen der installation nicht nach irgedn einem user und passwort für den MYSQL beutzer gefragt. Hier hakt die installation noch mächtig. Wenn ich aber selbst einen Fehler gemacht haben sollte dann helft mir mal.
Ich hab keine Ahnung wo?
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 27. October 2013 09:13

Ist schon sehr merkwürdig was hier geschehen ist.
Da habe ich dann um 01:20 UHR Rechner ausgeschaltet und eben neu gestartet und siehe da, MySQL läuft auf einmal. Nur bin ich jetzt einmal gespannt wie lange. Ich verstehe es nicht.
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 27. October 2013 21:46

schon wieder ich. Ja jetzt ist es 21:45 und wieder läst sich MySql nicht starten. Wo gibt es noch die 1.7 die 1.8.3 macht mir nur Probleme.
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby Altrea » 27. October 2013 22:31

Ältere Versionen findet man, wie immer, bei Sourceforge: http://sourceforge.net/projects/xampp/f ... %20OS%20X/

Wenn du allerdings mal Probleme hast und mal funktioniert es, würde ich darauf tippen, dass du Störeinflüsse wie blockierte Ports oder ähnliches hast und dann kämst du auch mit einer älteren Version nicht dort heraus. Aber probieren kann nicht schaden.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6670
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 28. October 2013 07:46

Erst mal danke für den Hinweis auf Sourcforge, hätte ich fast selbst drauf kommen können. Das mit den Ports verstehe ich nicht, mir zeigt sich das anders.
Mal alles von vorne.
Ich habe die alte Version von meienm MAC entfernt mit allem was dazu gehört. Dann habe ich mir die 1.8.3 von bitnami geladen und installiert.
Da hatte ich schon meine ersten Zweifel das das so funktioniert. Denn es gab keine Abfrage über den MYSQL user und Passwort. Das kam mir dann schon einmal spanisch vor.
Das führte auch dann zum Post vom 27.10 um 1:20.
Dabei bin ich dann, nachdem die erste Installation Fehlgeschlagen ist auf die Suche nach den config Dateien gegagen und habe dort auch passwörter und user eingetragen, denn die waren nicht vorhhanden obwohl ich mit xaampp sec... alles versucht habe zu korrigieren.
Dann habe ich mal mysql manuel gestartet und es lief auch für eine Weile. Dann habe ich Joomla 3.1 installiert und war happy das es funktionierte. Dann habe ich um auch alles zu testen MYSQL wieder gestoppt, Apache gestoppt und anschliessend apache wieder gestartet und mir den Status und den sicherheitstest angeschaut. User root hatte unbekannt, was auch nicht zu verweundern war den Mysql hatte ich nocht nicht gestartet. Dann habe ich anschliessend über manager-osx versuc ht Mysql zu starten und es ging wieder nicht.
Wieder alle Config dateien angeschaut, wieder alle user und paswörter eingetragen, aber es funktionierte trotzdem nicht.
Dies führte dann zum Post um 01:33 Uhr.
Genervert den Rechner runtergefahen und erst mal Matratzenhorschdienst.
8 Stunden später Rechner nei gestartet, über MANAGER-OSX apache und Mysql gestartet und das führte zum Post um 10:13. Das kann also nichts mit einem Port Problem zu tun haben.
Am mittag noch mal geschaut, lief immer noch.
Dann waren wir weg und um 21:45 habe ich nochmal geschaut und das war dann der post um 22:46.
Ich würde fast eine Wette eingehen das wenn der Rechner heute Nachmittag wieder angeschaltet wird dann läuft auch MYSQL wieder und das ist Schrott. Damit kann man nicht arbeiten.
Das sehe ich doch richtig? ODER?

09:03-Habe mal die Windows Version installiert unter VMWARE und Windows 7x64 und diefunktioniert einwandfrei. Soweit ich das bis jetzt beurteilen kann. Noch ist die Datenbank da
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby Altrea » 28. October 2013 09:12

Was für eine Antwort erwartest du nun?
Die XAMPP Entwickler werden mit Sicherheit nichts eingebaut haben, was Uhrzeitabhängig bestimmte Prozesse zulässt bzw. blockt.

Die häufigste Ursache für temporäre Funktionslosigkeit sind nunmal geblockte Ports durch Drittprogramme.
Weitere Ursache könnten Abhängigkeiten sein (zum Beispiel zu externen (Netz-)Laufwerken die mal erreichbar mal nicht sind).
Oder Berechtigungsprobleme benötigter Dateien (zum Beispiel dass eine Komponente nicht in seine Logdatei schreiben kann).
Zu guter Letzt würden auch von dir gemachte Änderungen in Betracht kommen.

Andere Gründe würden mir spontan nicht einfallen. Erst Recht nicht wenn du sagst, dass die Logdateien nichts hergeben.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6670
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 28. October 2013 10:20

Eine Antwort hätte ich gerne? Wo werden die einzelnen Logdateien denn hingestellt. Ich suche immer in den log-verzeicnissen und würde dort auch die logs von mysql erwarten aber leider nichts. Bei eine installation über bitnami hätte ich eigentlich erwartet, auch als root, das alle rechte entsprechend des benötigten Umfangs wergeben werden. Ich arbeite selbst in eine UNIX Umgebung und unsere Scripte erstellen immer entsprechende Rechte auf Verzeichnisse und Dateien.
Sollte es so sein das rechte fehlen kann ich es ändern daher wäre für mich interessant zu wissen wo z.B. Mysql versucht sein log zu schreiben.

10:41 28.10.2013
Könnte es sein das folgender Thread hier auch zuschlägt.
http://community.apachefriends.org/f/viewtopic.php?f=16&t=66746#p230644
Der wurde auch wohl so gelöst
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 28. October 2013 16:25

Wette gewonnen. Mysql läuft wieder. Bin mal gespannt wie lange
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby Altrea » 28. October 2013 17:17

bowie1304 wrote:Eine Antwort hätte ich gerne? Wo werden die einzelnen Logdateien denn hingestellt. Ich suche immer in den log-verzeicnissen und würde dort auch die logs von mysql erwarten aber leider nichts.
Bei eine installation über bitnami hätte ich eigentlich erwartet, auch als root, das alle rechte entsprechend des benötigten Umfangs wergeben werden.

Ich kenne weder die XAMPP Version für Mac OS X noch kann ich einen Mac mein Eigen nennen, um besagte Version testen zu können. Ich kann dir daher keine gesicherten Antworten auf deine Fragen geben, lediglich Vermutungen anstellen.
In der XAMPP für Windows Version befindet sich die MySQL Logdatei im MySQL data Ordner.

Wirkliche Antworten zu der aktuellen XAMPP Version von Bitnami kann dir vermutlich nur Bitnami selbst geben, hier in Person von Beltran. Dazu eröffnest du am besten einen neuen Thread in Englisch im XAMPP for Mac OS X Forum.

bowie1304 wrote:Könnte es sein das folgender Thread hier auch zuschlägt.
viewtopic.php?f=16&t=66746#p230644
Der wurde auch wohl so gelöst

Wäre dies dein Fehler würde MySQL garnicht mehr starten und nicht nur manchmal nicht. Ich wage auch zu bezweifeln, dass die Mac OS X Version von XAMPP MySQL auf dem selben Weg beendet wird wie auf Windows und selbst wenn muss das nicht zwangsläufig dieselben Auswirkungen zeigen.
Ich habe dieses spezielle Verhalten zumindest nur auf Windows verfolgen können und bin auch bei meinen Recherchen auf keine Linux/Mac OS X Umgebungen gestoßen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6670
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 29. October 2013 07:20

Das hat mir doch schon weiter geholfen. den jetzt weiß ich wo ich mich hinwenden kann.
Nichts desto trotz das Verhalten welches sich im genannten Windows Thread darstellt war auch unter OSX fest zu stellen.
daher hat es mir coh weiter geholfen.
Danke
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick

Re: Massive Problem mit XAMPP 1.8.3

Postby Altrea » 29. October 2013 08:13

bowie1304 wrote:Nichts desto trotz das Verhalten welches sich im genannten Windows Thread darstellt war auch unter OSX fest zu stellen.

Das bedeutet du bekommst dieselben Fehlermeldungen?
Denn "MySQL startet nicht" kann unzählige Ursachen haben und der Bugreport bezieht sich auf eine ganz bestimmte Ursache.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6670
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Massive Problem mit XAMPP 1.8.3

Postby bowie1304 » 31. October 2013 07:56

Hallo Altera,
und es ist unter XAMPP für MAC das gleiche Problem, wie du auf der Englischen Seite für BUGS in XAMPP Beschrieben hast,nur das der Kill Process hier nicht immer dazu führt das die Datenbank kaputt ist.
Der Shutdown ist sauberer, aber das ist denke ich allen bewußt die täglich damit umgehen. Bin erst vorgestern auf diese Sache gestoßen, aber jetzt weiss ich auch wich das lösen kann, nachdem ich mir de Artikel im Bug durchgelesen hatte.

Gruß
Willi
bowie1304
 
Posts: 10
Joined: 26. October 2013 18:41
XAMPP Version: 1.8.3-3
Operating System: MAC OSX 10.9 Maverick


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests