Mehrere Frage zu Filezilla Server (Useracc)(Ports hinterNAT)

Alles, was den FileZilla betrifft, kann hier besprochen werden.

Mehrere Frage zu Filezilla Server (Useracc)(Ports hinterNAT)

Postby Nooby » 22. September 2006 13:40

Moin moin!
Ich hab mich hier mal in das nette Forum gelesen, ihr sprecht mein größtes Problem x mal an, wird aber nie ganz beantwortet. Ich habe 2 große Probleme und werde da auch nicht ganz schlau drauß, da genau nach Anleitung vorgegangen. Hoffe auf die Hilfe eines Filezilla Server erfahrenden.

1. Das größte Prob: Ich habe den Server (Win2k) hinter nem Router also NAT, wenn ich das richtig verstanden habe muss ich in diesem Fall den Passiv Modi benutzen. Ich benutze SSL über Port990 (offen und geroutet) genau wie die Ports 20-21. Trotzdem konnte ich nur von intern auf den Server verbinden, von extern kam die berühmte Zeile 425 Can't open data connection. Ich habe alle Modi durch getestet, bis ich irgendwann feststellte das die Clienten immer auf anderen Ports versuchen (z.B. 4&30) Verbindung aufzubauen. Wir sind alle Settings durchgegangen und haben hier keine einstellmöglichkeit gefunden. Darauf bin ich in die Router Settings und habe mal alle Ports auf meine interne Ip geroutet und siehe da, es geht. Nur kann ich jetzt nachts nicht mehr ruhig schlafen, wie kann ich das auf z.B. eine Range eingrenzen, mach ich was falsch?

2.Ich benutze die Version des Servers (0.9.18 beta), wenn ich jetzt nach Anleitung vorgehe und erstmal eine Gruppe und dann einen User dieser Gruppe zuweise bekomme ich immer nur ein ausgewählten Ordener angezeigt auf den Clients. Egal ob ich die Ordner in der Gruppe oder dem User selber verweise. Ich kann nur einen einzigen Ordner freigeben somit nur einen Überordner mit schreibrechten. Ich würde gerne einen gemeinsammen Download Ordner für alle (also Gruppe) mit Leserechten und einen für jeden User mit vollen Rechten, das will aber nicht weder in Gruppe noch ohne Gruppe.

Dann noch eine Frage mal ganz allgemein. Welche Settings würdet ihr für Sinnvoll halten bezüglich der SSL einstellung bzw. kann mir jemand deren Bedeutung genau erklären, finde da keine guten Infos zu:
auf den Clienten!
-FTP über SSL/TLS (Implizite Verschlüsselung) aktuell benutzt
-FTP über SSL (Explizite Verschlüsselung)
-SFTP über SSH2
-FTP über TLS (Explizite Verschlüsselung)
(und den Settings auf dem Server)
-Key Password unter dem Zertifikat, habe eins eingegeben, würde noch nie abgefragt
-Allow explicit ssl/tls on normal connection
-Force " " "
-Force Prot P to encrypt Data channel ...

Ufff was viele Fragen, eigentlich muss ich nur wissen was ist wirklich sicher? Will nix in klartext und ich habe nun schon das 2te mal in kurzer Zeit nen Asia Hacker drauf gehabt, der sich lustig als Admin anmelden wollte (lass das natürlich nur Loakal zu) nur es gibt überall Lücken und wir leben im Zeitalter des Meta-exploits wo jedes Kind ne Anleitung findet ne Lücke zu finden :)
Besten Dank für den der die Ruhe weg hatte sich das hier alles zugeben!
Ich möchte hier eigentlich auch keinen riesen Thema aufmachen, nur über jemand mit Erfahrung wäre ich sehr Dankbar!
Besten Dank
THX
NOOBY
Nooby
 
Posts: 7
Joined: 22. September 2006 12:38

Postby din0815 » 01. March 2007 18:01

schade, daß es hier keine antwort gibt. schlage mich mit dem selben problem herum, nur daß selbst bei heruntergefahrener firewall und absolut offenem router keine ssl verbindung von außen möglich ist. intern geht es perfekt, aber wer braucht schon intern eine ssl verschlüsselung.

na ich werd mal weiter suchen...

vielleicht kann mir ja trotzdem jemand hier einen tip geben.
din0815
 
Posts: 2
Joined: 10. March 2004 12:42

SSL

Postby Caesar » 01. June 2007 20:37

Hallo,

auch ich habe das Problem, dass ich nur einen Ordner pro User anzeigen kann...Das mit SSL ist bei mir so, dass komischerweise nur TLS funktioniert. Keine Ahnung warum, aber eigentlich ist das ja das Beste, oder?
Jedenfalls habe ich im Router die Ports 990 (SSL), 21 und 20 geforwarded und ansonsten wieder alles in FZ auf die Standardeinstellungen eingestellt (das Problem 425 hatte ich vorher auch, als ich meine Ports festgelegt habe), so dass mein FileZilla die Standardports benutzt. Man kann allerdings die Ports auch bestimmen, indem man die Portrange für die Antwort begrenzt (zum Beispiel 20-21). Und ich habe die Erfahrung gemacht, dass FileZilla es merkt, wenn ein Port aus diesem Bereich als Steuerport dient (so wie eben 21 als Standard)...Übrigens auch dran denken, dass auch die Clients Einstellmöglichkeiten für Ports haben - auch daran kanns scheitern...

Gruß
caesar
Caesar
 
Posts: 1
Joined: 01. June 2007 20:29

Postby Woody/mC » 08. June 2007 01:44

hallo zusammen,

vielleicht hilft euch das hier wenigstens ein kleines stückchen weiter:

meiner meinung nach gibts an der beschriebenen stelle noch etliche bugs im server-quellcode, die ich aber auch noch nicht einkreisen konnte/wollte :wink:
bei mir funktioniert der ganze spass (fast) so, wie er soll:
connections innerhalb des lokalen subnetzes und auch über den router nach aussen, und zwar sowohl unverschlüsselt als auch per ssl (ports 20/21, auf ports 989/990 ssl-only). auf der client-seite erfordert das die einstellung "ftp via ssl (explizite verschlüsselung)". router forwarded die genannten 4 ports plus eine 100-port-range für den passive mode.

und genau hier ist der knackpunkt:
ssl-connects funktionieren offensichtlich nur bei korrekt konfiguriertem passive mode ("use the following ip" / "retrieve external..." + "use custom port range"), während unverschlüsselte verbindungen nur im active mode zustande kommen (besser im client einstellen, wenn möglich - deaktivieren des passive-mode per ip-setting "default" geht zwar auch, aber dann ist nix mehr mit ssl).

das äußert sich wie folgt:
ssl+active mode: can't open data connection
ssl+passive mode: OK
non-ssl+active mode: OK
non-ssl+passive mode: entering passive mode (...), als reaktion sofort server-seitiger disconnect

das dumme daran ist, dass manche browser-clients (z.b. seamonkey, mozilla, firefox vllt. auch?) weder ssl-ftp unterstützen noch in den active mode umschaltbar sind und damit in die kategorie "sofortiger disconnect nach PASV" fallen. das dient nicht gerade der usability - bleibt anscheinend nur ein trade-off zwischen sicherheit und nutzerkreis... :?

vielleicht hat ja jemand von euch eine erklärung dafür.
bis dahin bleib ich dabei: it's a bug, no feature! :lol:

@nooby:
siehe "use custom port range" in den passive-mode settings. häkchen setzen, range festlegen und diese ports durchrouten lassen. wenn du einen festen hostnamen hast (dyndns funktioniert ganz prima für dialup/dsl), solltest du diesen unbedingt bei "use the following ip" eintragen, der wird dann automatisch per dns-lookup in eine ip aufgelöst. siehe dazu auch dieses thema: http://community.apachefriends.org/f/viewtopic.php?t=24476


greetz, Woody/mC
Greetz, Woody/mC
User avatar
Woody/mC
 
Posts: 13
Joined: 22. June 2006 17:34
Location: DE/SAN/MD

Postby Wiedmann » 08. June 2007 09:00

vielleicht hat ja jemand von euch eine erklärung dafür.

Das FTP-Protokoll ist ein Dinosaurier und wurde zur einer Zeit entwickelt, als es noch kein NAT gab.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Mehrere Frage zu Filezilla Server (Useracc)(Ports hinterNAT)

Postby knutwilli » 10. May 2009 19:23

hier wurde ich fündig:

http://doktorz.mooltied.de/delphi/filez ... .html#a1_3

20090510 - alles befolgt und es klappt jetzt
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin


Return to FileZilla

Who is online

Users browsing this forum: No registered users and 3 guests