Can't Get Perl Add On To Work?

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Can't Get Perl Add On To Work?

Postby vincentrich » 19. January 2005 10:12

Hello everyone,

I'm sorry I can't write in german so I hope you can help me out anyway.

I have XAMPP version 1.4.9. I wish to install PERL and I downloaded:

http://www.apachefriends.org/download.p ... taller.exe

I installed it and the in the instruction:

http://www.apachefriends.org/en/winxamp ... n-perl.txt

"GERMAN: Einfach das Add-on in das gültige XAMPP-Verzeichnis entpacken.
Danach bitte die "setup_xampp.bat" für eine Aktualisierung der Konfiguration
starten. Mit der erneuten Betätigung der "setup_xampp.bat" kann das Modul
mod_perl aktiviert oder deaktiviert werden. "

"EMGLISH: Simply extract this add-on in your current XAMPP-Directory.
All older files are overwritten. Then start the "setup_xampp.bat"
to configure XAMPP with Perl. Now restart the apache. After that with the
"setup_xampp.bat" file, you can choice "with mod_perl" or "without mod_perl". "

--------- > start the "setup_xampp.bat": When i do this, I enter "1" to restart XAMPP config but it exits the screen without doing anything!

I don't understant how to "you can choice "with mod_perl" or "without mod_perl".

Anyone help?

Cheers,

Vincent
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby Wiedmann » 19. January 2005 10:33

Your XAMPP installation path?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vincentrich » 19. January 2005 11:21

C:\ my home web server\xampp
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby Wiedmann » 19. January 2005 11:57

Hmm, bad :-(

der is a bug in the XAMPP installer. The installation path should not contain the word "server" (at the moment).

Can you install XAMPP in an other path?

(or try to meet me in the IRC chat)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vincentrich » 19. January 2005 12:07

what? damn.... its a lot of work to re-install it.... i'll get back to you once i have done it
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 19. January 2005 16:39

I think i don't have to reinstall...

I checked out my XAMPP home page and found a "PERL" link... I clicked on it and i see this:

PERL 5.8.4
Apache module: PERL/1.99_16
Extensions: .pl
Document root: C:\My Home Web Server\xampp\htdocs\modperl\
Configuration files: C:\My Home Web Server\xampp\apache\conf\perl.conf + C:\My Home Web Server\xampp\apache\conf\startup.pl
Examples: C:\My Home Web Server\xampp\htdocs\modperl\modperl.pl | Alias: http://localhost/perl/modperl.pl

Extensions: .asp
Document root: C:\My Home Web Server\xampp\htdocs\modperlasp\
Configuration files: C:\My Home Web Server\xampp\apache\conf\perl.conf
Examples: C:\My Home Web Server\xampp\htdocs\modperlasp\loop.asp | Alias: http://localhost/asp/loop.asp

Extensions: .cgi
Document root: C:\My Home Web Server\xampp\cgi-bin\
Configuration files: C:\My Home Web Server\xampp\apache\conf\httpd.conf
Examples: C:\My Home Web Server\xampp\cgi-bin\perltest.cgi | Alias: http://localhost/cgi-bin/perltest.cgi

Homepage: http://www.perl.org

------------------------

All i can say is that:

http://localhost/cgi-bin/perltest.cgi -----> works
http://localhost/perl/modperl.pl -----> works

But...

My other web site doesn't work. It seems to be only working with the XAMPP home page.

Do i need to change some settings some where?
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby No-Sense » 21. January 2005 12:55

got the same problem with the perl addon. and when i start xampp i can't even get passed the language choice on the xampp splash screen.
there is definitively somthing wrong with the perl addon.
if i install only xampp 1.4.11 everything is fine and i'm running it for some time one.
my installation path is "d:\webserver\xampp\"
http://www.no-sense.8s.nl
Trying to make a dutch Xampp help guide
User avatar
No-Sense
 
Posts: 12
Joined: 21. January 2005 02:55
Location: Netherlands


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 2 guests