Welche perl exec mit mod_perl wird benutzt?

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Welche perl exec mit mod_perl wird benutzt?

Postby tphyahoo » 30. December 2004 20:19

Hi apache friends! Ich habe gerade die folgende frage über apache friends mit dem perl extension bei perlmonks gepostet (in Englisch).

http://www.perlmonks.org/?node_id=418345

Wenn irgendeiner von euch mich helfen konnte, es wäre wunderbar.

Meine Frage lautet:

***********

Monks, I have winxp with active state perl.

I have also apachefriends/XAMPP, with the perl add-on, for an OOTB apache with mod_perl. See:
http://www.apachefriends.org/en/winxamp ... n-perl.txt

This means I have two "perl homes", the one installed by apachefriends, and the one installed by active state.

A simple script like

print "ok";

works. But, I have a script that has

use HTML::TokeParser::Simple;

and apache chokes on this line:

Internal Server Error

The server encountered an internal error or misconfiguration and was u
+nable to complete your request.

Please contact the server administrator, admin@localhost and inform th
+em of the time the error occurred, and anything you might have done t
+hat may have caused the error.

More information about this error may be available in the server error
+ log.
Apache/2.0.50 (Win32) mod_perl/1.99_14 Perl/v5.8.4 PHP/5.0.1 SVN/1.1.1
+ DAV/2 mod_ssl/2.0.50 OpenSSL/0.9.7c Server at localhost Port 80

I installed HTML::TokeParser::Simple for my "usual" Active State perl, but I guess this hasn't been installed for the version of perl being called by apache.

Could someone with apache experience -- or ideally, with ApacheFriends/XAMPP experience -- give me some pointers on how to get my script to run?

Also, is there some way I can get more helpful error messages? Right now I am commenting out lines of script playing hit and miss.

Much obliged!

thomas.
tphyahoo
 
Posts: 3
Joined: 30. December 2004 20:12

antwort...

Postby tphyahoo » 03. January 2005 10:23

I received the following email from the programmer who wrote the original script.

**************************

thomas,

The problem is that you are using mod_perl. I think even if you fix the problem with the missing module, the program won't work becouse I don't think mod_perl supports forks (but I might be wrong).

What I do on my system (on both xp and linux) is use CGI. Default apache installations already have a cgi directory, named cgi-bin. You have to make sure that the .pl file is located on the cgi-bin directory, and that the first line of the script has the correct location of the perl executable on your system. If you have more than one perl executable, it should be the one with the needed modules. Remember that it should be version 5.8 on xp, becouse previous versions don't have good fork support. On my system the first line is this:

#!c:/perl/bin/perl.exe -w

If you have perl in another directory is easy to change this line to fit your perl installation.

I hope this was helpful.

X.

************************

I'm going to try this advice right after I post, but I expect this to work, because it does on his system.

thomas.
tphyahoo
 
Posts: 3
Joined: 30. December 2004 20:12


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 3 guests