Fehler bei Jakarta Tomcat 5.0.25 Addon für XAMPP (LAMPP)

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler bei Jakarta Tomcat 5.0.25 Addon für XAMPP (LAMPP)

Postby sucht » 12. July 2004 14:02

Das steht in der apachestart.log

Syntax error on line 1 of /opt/lampp/etc/tomcat.conf:
Cannot load /opt/lampp/modules/mod_jk2.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by
/opt/lampp/modules/mod_jk2.so)

Bekomme diese Fehlermeldung beim Stoppen des Lampp



XAMPP: Stopping Apache with SSL...
Syntax error on line 1 of /opt/lampp/etc/tomcat.conf:
Cannot load /opt/lampp/modules/mod_jk2.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/modules/mod_jk2.so)


das steht in der catalina.err

jsvc.exec error: Service exit with a return value of 143
jsvc.exec error: Service exit with a return value of 143
jsvc.exec error: Cannot start daemon
jsvc.exec error: Service exit with a return value of 5
jsvc.exec error: Service did not exit cleanly



Bitte um Hilfe

Tschau Sucht
Last edited by sucht on 12. July 2004 14:28, edited 1 time in total.
sucht
 
Posts: 3
Joined: 12. July 2004 13:52

Postby Kristian Marcroft » 12. July 2004 14:11

Hi,

was hast du denn für ein linux?
und was für ne libc Version?
Oder hat DiLu eine zu "neue" glibc verwendet? *g*

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

tomcat

Postby sucht » 12. July 2004 14:32

@KriS

linux version sles 8

glibc 2.2.5
sucht
 
Posts: 3
Joined: 12. July 2004 13:52

Re: Fehler bei Jakarta Tomcat 5.0.25 Addon für XAMPP (LAMPP)

Postby Kristian Marcroft » 12. July 2004 15:28

sucht wrote:Das steht in der apachestart.log

Syntax error on line 1 of /opt/lampp/etc/tomcat.conf:
Cannot load /opt/lampp/modules/mod_jk2.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by
/opt/lampp/modules/mod_jk2.so)

Hi,

das weisst sehr stark darauf hin, das DiLu nicht abwärts kompatible compiliert hat.

Er schient die glibc 2.3.X zu verwenden, du aber eine ältere...
Nun wer muss wem entgegen kommen? *g*

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Tomcat

Postby sucht » 12. July 2004 15:58

werde ihm mal ne Mail schreiben

Sucht
sucht
 
Posts: 3
Joined: 12. July 2004 13:52

mod_jk2 binary ist vom Jakarta server

Postby DiLu » 12. July 2004 20:21

Hallo sucht und KriS,

nur noch mal zur Klarstellung, das mod_jk2 Apache Modul sowohl in der Win32- als auch die Linux-Version stammt von den Jakarta binary distributions auf http://mirrors.speednetwork.de/apache.org/dist/jakarta/tomcat-connectors/jk2/binaries/.
Ich habe da also gar nichts kompiliert, warum auch, es läuft ja auch alles wunderbar (das Linux shared object ist übrigens aus dem Fedora Core 1 Package).
Die Tomcat-Addons stehen ja nun seit Ende Mai zum Donwload zur Verfügung, es sind mittlerweile knapp 300 Downloads für beide Versionen seither. Bisher bestand noch keine Anfrage bzgl. Support für alte Glibc-Versionen < V2.3.

Also mein Tipp an sucht:
Entweder die Connector-Sources downloaden und das Apache Module für dein individuelles System selbst kompilieren (du brauchst dann das xampp-dev Paket) oder vielleicht doch lieber auf eine aktuelle Glibc V2.3.x updaten. (V2.3.2 ist glaube ich die latest stable)

Di|Lu
Once I had a dream... and this is it :)

Homepage: http://dilu.homeip.net
Email: dilu@dilu.homeip.net
DiLu
 
Posts: 14
Joined: 24. May 2004 06:39
Location: Rodenbach


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 1 guest

cron