Apache won't start after Python add-on

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Apache won't start after Python add-on

Postby mnemotronic » 30. October 2006 23:52

I had a running XAMPP 1.5.4 (Windows, via Installer), which I upgraded to 1.5.4a with the upgrade Installer (http://www.apachefriends.org/download.php?xampp-win32-upgrade-1.5.4-1.5.4a-installer.exe)
Things were working. I downloaded and installed the Python addon (xampp-python-addon-2.3.5-installer.exe) from SourceForge and ran it. With the defaults, Apache refuses to start. The Python installer apparently appended this line to httpd.conf:"Include conf/extra/python.conf". The named file doesn't exist. There is a "conf/python.conf.new", so I copied that to "conf/extra/python.conf". The modules referenced by the LoadFile and LoadModule lines in python.conf file exist ("/xampp/python/python23.dll" and "/xampp/python/mod_python.so"), but those lines prevent apache from starting.

This may be irrelevant, but prior to this I did have ActiveState Python 2.4.3 installed in C:\Program files\ActiveState\python, and that dir is in PATH. The xampp addon python dir is not in PATH.

I tried copying the python23.dll file to xampp/apache/bin, and I also copied mod_python.so to apache/modules -- apache still doesn't start.

My only solution is to comment out everything in python.conf -- not a great solution.

Is there something I'm missing???
mnemotronic
 
Posts: 11
Joined: 16. October 2006 06:07
Location: Boulder

Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 1 guest