Python: *.py Dateien werden nicht geparst

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Python: *.py Dateien werden nicht geparst

Postby eJunkie » 20. June 2006 18:51

hallo,

ich habe python auf meinem xampp entpackt und auch alles eingerichtet, python wird nun auch als modul mitgeladen. allerdings bekomm ich keine *.py datei zum laufen und ich weiß nicht mehr weiter :-(

rufe ich das verzeichnis auf, indem sich die *.pydateien befinden (u.a. auch eine index.py), so kommt folgender text:

Code: Select all
Mod_python error: "PythonHandler index"

Traceback (most recent call last):

  File "C:\PYTHON\Lib\site-packages\mod_python\apache.py", line 287, in HandlerDispatch

  File "C:\PYTHON\Lib\site-packages\mod_python\apache.py", line 457, in import_module

  File "G:/htdocs/python/\index.py", line 31, in ?
    import liteweb.path as path

ImportError: No module named liteweb.path



meine python.conf schaut so aus:
Code: Select all
LoadFile "/python/python23.dll"
LoadModule python_module "/python/mod_python.so"

<Directory "/htdocs/python/">
  AddHandler python-program .py .spy
  PythonDebug On
    <Files *.py>
        PythonPath "['/htdocs/python/'] + sys.path"
    </Files>
    <Files "index.py">
      PythonHandler index
    </Files>
    <Files "xa.py">
      PythonHandler xa
    </Files>
     PythonHandler run_spyceModpy::spyceMain
  PythonPath "sys.path+[r'/python/Lib/site-packages/spyce/']"
  PythonOption SPYCE_CONFIG "/python/Lib/site-packages/spyce/spyceconf.py"
# PythonHandler default
#  PythonHandler mod_python.publisher
</Directory>


weiß jemand rat? bitte :)!
eJunkie
 
Posts: 1
Joined: 20. June 2006 16:50
Location: Bremen

Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 2 guests