Unterschied: TOMCAT als Dienst bzw. Anwendung gestartet ???

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Unterschied: TOMCAT als Dienst bzw. Anwendung gestartet ???

Postby d1ck135 » 11. May 2006 22:33

Hi ich verwende:
-XAMPP 1.5.2 in Verbindung mit Tomcat 5.5.15-pl2
-Windows 2000 Advanced Server SP4 ( standalone bzw. keine Domäne / AD )
-Sun Java SDK 1.5.0 Update 6
-Sun Java JDK 1.5.0 Update 6
-Netbeans 5.0
-Microsoft Office 2000 Premium

Ich habe den Auftrag eine Applikation zur Befragung von Lehrgangsteilnehmern in meinen XAMPP zu integrieren. Die Applikation ist in Java programmiert und greift auf eine Access Datenbank zu, welche per DSN/ODBC angesteuert wird ( Windows --> Start --> Verwaltung --> Datenquellen ). Ihr braucht mir nicht sagen das Access als Datenbank nix taugt, soweit bin ich schon selber gekommen mit meiner Erkenntnis, seit ich mich mit dieser Lehrgangsteilnehmerbefragung herumschlage...

Mein Problem ist folgendes:
Ich installiere Tomcat als Windows-Dienst über die beim Addon beiliegende Batch Datei... mit dem Ergebnis die Lehrgangsteilnehmerbefragung läuft nicht, weil die Verbindung zu der Access Datenbank / Auf die ODBC Datenquelle nicht hergestellt werden kann

Starte ich Tomcat jedoch als Applikation über die dem Addon beiliegende Batch funktioniert die Lehrgangsteilnehmerbefragung läuft wunderbar und die Verbindung zu der Access Datenbank / Auf die ODBC Datenquelle funktioniert wunderbar...

Kann mir einer von euch lieben evtl. weiterhelfen... Vorgabe für mich ist, das Tomcat als Dienst läuft und nicht als Anwendung... Was sind die Unterschiede zwischen dienst und Anwendung bzw. wie bekomm ich den Dienst dazu das gleiche zu tun wie die Anwendung...

Vielen Dank vorab - d1CK135
d1ck135
 
Posts: 2
Joined: 11. May 2006 10:51

Postby Wiedmann » 11. May 2006 22:39

welche per DSN/ODBC angesteuert wird

System- oder User-DSN?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby d1ck135 » 11. May 2006 22:56

Beides schon probiert...

mit der User-DSN klappts im Anwendungsmodus aber als Dienst nicht
mit der System DSN klappts gar nicht
d1ck135
 
Posts: 2
Joined: 11. May 2006 10:51


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 2 guests