org.apache.catalina.Deployer

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

org.apache.catalina.Deployer

Postby rulix » 08. January 2006 17:10

First of all, hello everybody, my name is Raul and I'm new on this community.

I'm sorry if this was posted before but I have no idea about german so if anybody is able to help me in english I would much apreciate it.

I have a problem with the tomcat addon in XAMPP. The thing is that I am unable to enter the tomcat manager in order to deploy/undeploy applications.
When I try to do that, I get the following error:

javax.servlet.ServletException:
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:482)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
java.lang.Thread.run(Thread.java:595)

root cause

java.lang.NoClassDefFoundError: org/apache/catalina/Deployer
org.apache.catalina.manager.ManagerServlet.setWrapper(ManagerServlet.java:259)
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:482)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
java.lang.Thread.run(Thread.java:595)



I think it's a matter of the classpath but i've tried tons of combinations and I always get the same error.
I can't understand what the hell is going on and I can't find any documentation to solve this problem.

Well, I didn't tell this but I think it's important: My XAMPP distribution is 1.5 and my OS is windows XP.

Thank you very much!!
Ragards.
rulix
 
Posts: 1
Joined: 08. January 2006 16:46

Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 1 guest