apanatschi-installation

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

apanatschi-installation

Postby wolfgangftl » 22. April 2005 11:17

Hallo,

Nach der Installation beim letzten Punkt "Installationsdateien löschen"
löscht es dan den gesamten apanatschi-Ordner in htdocs.
Habe es paarmal versucht. Oder sollte man nicht auf den Link
"Installationsdateien löschen" klicken.
Herzliche Grüße aus Freital
Wolfgang
User avatar
wolfgangftl
 
Posts: 45
Joined: 20. April 2005 19:22
Location: Freital

Postby Apache-User » 22. April 2005 12:07

das ist sinn der ganzen sache das die install datein verschwinden da sie nicht mehr benötigt werden habe diese funktion extra dafür geschaffen das man mit den datein nicht durcheinnander kommt apanatschi läuft nach der install aus einem anderen verzeichniss x:\xampp\apanatschi somit ist er auch weitesgehnst von der ausenwelt sicher...

hoffe ich konnte deine frage beantworten und schön zu sehn das noch jemand die erste apanatschi version nuzt obwphl die zweite kurz vor der tür steht in diesem sinne...
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym

Postby wolfgangftl » 23. April 2005 07:40

Apache-User wrote:das ist sinn der ganzen sache das die install datein verschwinden da sie nicht mehr benötigt werden habe diese funktion extra dafür geschaffen das man mit den datein nicht durcheinnander kommt apanatschi läuft nach der install aus einem anderen verzeichniss x:\xampp\apanatschi somit ist er auch weitesgehnst von der ausenwelt sicher...

hoffe ich konnte deine frage beantworten und schön zu sehn das noch jemand die erste apanatschi version nuzt obwphl die zweite kurz vor der tür steht in diesem sinne...


Ich weiß nicht, ob Du mich verstanden hast. Es bleibt nirgens etwas von
apanatschi übrig. Wenn man es aufruft nach dem wie es im readme steht,
findet es ja nichts. Klar es hat ja alles gelöscht. Weiterhin habe ich eine ganze Seite Fehlermeldungen bei der Installation.
Herzliche Grüße aus Freital
Wolfgang
User avatar
wolfgangftl
 
Posts: 45
Joined: 20. April 2005 19:22
Location: Freital

Postby Apache-User » 23. April 2005 14:23

ok dann sag mir doch mal genau welche fehlermeldungen er ausspuckt.. wenn es welche sind wie zb. (Warning: unlink(source/includes/.): Permission denied in X:\xampp\htdocs\apanatschi\.........php
dann is das normal aber das steht ja auch in der readme...

schau mal ob im verzeichniss /xampp/apache/conf/ eine datei namens apanatschi.conf zu finden ist.

auserdem sollte im root verzeichniss von xampp ein ordner Apanatschi exestieren und NICHT unter htdocs
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym

Postby greenmaster » 04. April 2006 22:04

kann man es nicht auch so machen das man von "aussen" da ran kommt?
ich meine was bringt sonst ein "web"interface wenn man aus dem internet nicht darauf zugreifen kann :?

sry soll nicht provozierend oder aggressiv klingen oder so wollt ich nur mal fragen.
greenmaster
 
Posts: 9
Joined: 16. March 2006 15:27

Postby KingCrunch » 04. April 2006 22:18

Du kannst nen Alias oder nen Vhost drauf ansetzen, aber dann denk auch an die Sicherheit (htacces und Co) ;)

Edit:
Achja, weil ich grad so drauf stehe: Kannst auch aussm htdocs Symlinks setzen :)
Es ist übrigens in dem Sinne kein Webinterface, sondern mehr nur ein Konfigurations-Interface (ähnlich einem GUI).
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby greenmaster » 04. April 2006 22:55

ja ne so "machtvoll" wie das ist muss man auch an die sicherheit denken. da gebe ich dir recht ;)
muss ich morgen dann mal versuchen das einzurichten.
greenmaster
 
Posts: 9
Joined: 16. March 2006 15:27

Auch Probleme Apanatschi zu installieren

Postby tocke » 25. May 2006 13:15

Hi Leute,

seit gestern habe ich xamp 1.5.2 (z.Z. aktuellste Version) auf meinen Rechner winxp home.

folgende Fehlermeldung kommt, wenn ich apanatschi aufrufe und die daten eingebe:

Code: Select all
Warning: mkdir() [function.mkdir]: File exists in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 4

Warning: mkdir() [function.mkdir]: File exists in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 5

Warning: mkdir() [function.mkdir]: File exists in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 6

Warning: mkdir() [function.mkdir]: File exists in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 7
apanatschi/config.php wurde erstellt....
httpd.conf wurde in apanatschi/backups gesichert....

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 58

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 58

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in C:\Programme\xampp\htdocs\apanatschi\make_install.php on line 58
apanatschi.conf wurde erstellt und erfolgreich in die httpd.conf eingebunden....
Schritt 2 SQL Strucktur erstellen


gehe ich dann schritt 2 Datenbank anlegen steht die fehlermeldung "keine Verbindung". Verzeichnisse oder ähnliches werden auch nicht angelegt.


Mach ich grundsätzlich was falsch?

folgendes zur umgebung:

xamp liegt hier:
C:/Programme/xamp/
C:/Programme/xamp/htdocs/

hier liegen die webseiten von xAMP
C:\Programme\xampp\htdocs\xampp
muss da die apanachti rein?

Ich bitte um schnelle Hilfe!


C:\Programme\xampp\htdocs\xampp
tocke
 
Posts: 2
Joined: 25. May 2006 12:46

Ein Schritt weiter!

Postby tocke » 25. May 2006 13:54

Hi,

ich habe die aktuelle xamp version 1.5.2 deinstalliert und
die version 1.4.2 installiert.

dann apanatschi installiert

alles funktioniert ohne fehlermeldung, alle ordner dateien werden angelegt,

bloß wie komm ich jetzt an die administration dran.

mit http://localhost/apanatschi/ funktioniert es aufjedenfall nicht

Was muß ich tun bitte um schnelle hilfe!

folgendes steht in der apanatschi.conf:
Code: Select all
##### Apanatschi Config File #####
<VirtualHost 127.0.0.1:80>
ServerAlias 127.0.0.1
DocumentRoot "C:/Programme/xampp/htdocs"
Alias /apanatschi "C:/Programme/xampp/apanatschi/"
<Directory "C:/Programme/xampp/apanatschi/">
Options Indexes MultiViews
DirectoryIndex index.php
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
tocke
 
Posts: 2
Joined: 25. May 2006 12:46


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 2 guests