MYSQL phpMyAdmin 2.7.0-pl2 Solaris 8.1

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

Postby steves » 28. July 2006 20:44

Wiedmann wrote:Well, the main problem is your install path.
Try:
Code: Select all
/opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock ping

(one line)

For PHP you can config the socket in "php.ini":
Code: Select all
[MySQL]
mysql.default_socket = /opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock


Well I do not have root access, like most developers to the unix box and can not install to /opt, so i have to put it where I can :-)

I had that already set in my php.ini

The ping had the same error

If I look at the var/mysql the mysql.sock has --> mysql.sock=
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 28. July 2006 20:47

The ping had the same error

It can't be the /same/ error...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 28. July 2006 20:50

Wiedmann wrote:
The ping had the same error

It can't be the /same/ error...



hawk@wsqeai05-> /opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock ping
/opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock' exists!
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 28. July 2006 20:58

You can see: The path in the two messages are different ;-)


But I don't know why we have this message:
'Can't connect to local MySQL server through socket '/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock' (2)'


Because:
hawk 13573 0.0 0.126168 7752 pts/10 S 14:38:37 0:00 /opt/app/wsqeai05c01/atlas/xampp/sbin/mysqld --defaults-file=/opt/app/wsqeai05c01/atlas/xampp/etc/my.cnf --basedir=/opt/app/wsqeai05c01/atlas/xampp --datadir=/opt/app/wsqeai05c01/atlas/xampp/var/mysql --pid-file=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/wsqeai05.pid --port=3306 --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock


And you told us the socket exists:
If I look at the var/mysql the mysql.sock has --> mysql.sock=


Maybe we have to wait for Oswald...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 28. July 2006 21:18

Wiedmann wrote:You can see: The path in the two messages are different ;-)


But I don't know why we have this message:
'Can't connect to local MySQL server through socket '/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock' (2)'


Because:
hawk 13573 0.0 0.126168 7752 pts/10 S 14:38:37 0:00 /opt/app/wsqeai05c01/atlas/xampp/sbin/mysqld --defaults-file=/opt/app/wsqeai05c01/atlas/xampp/etc/my.cnf --basedir=/opt/app/wsqeai05c01/atlas/xampp --datadir=/opt/app/wsqeai05c01/atlas/xampp/var/mysql --pid-file=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/wsqeai05.pid --port=3306 --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock


And you told us the socket exists:
If I look at the var/mysql the mysql.sock has --> mysql.sock=


Maybe we have to wait for Oswald...



Maybe I am getting confussed what should the entry be for mysql.sock= ?
steves
 
Posts: 23
Joined: 26. July 2006 21:59

reinstalled xampp

Postby steves » 28. July 2006 21:39

Ok I reinstalled xampp and only changed the entries to start apache and I still have the same problem. Just wanted to cleanup in case I made some other changes that might have affected it. So I still get

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 28. July 2006 21:44

what should the entry be for mysql.sock= ?

Sorry, don't unterstand.
You told me you have this file:
/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock

That's all. And exactly this string you must have in "php.ini" (and maybe config.inc.php)

BTW:
The "=" is just the sign for a socket in a directory listing with ls.
--> man ls

But you remember?
Wiedmann wrote:Is there a log file for MySQL somewhere?

Have you found something?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 28. July 2006 22:30

Wiedmann wrote:
what should the entry be for mysql.sock= ?

Sorry, don't unterstand.
You told me you have this file:
/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock

That's all. And exactly this string you must have in "php.ini" (and maybe config.inc.php)

BTW:
The "=" is just the sign for a socket in a directory listing with ls.
--> man ls

But you remember?
Wiedmann wrote:Is there a log file for MySQL somewhere?

Have you found something?



dir list of var/mysql
drwx------ 2 hawk hawk 512 Feb 18 2004 cdcol/
drwx------ 2 hawk hawk 1536 Nov 27 2005 mysql/
srwxrwxrwx 1 hawk hawk 0 Jul 28 16:36 mysql.sock=
drwx------ 2 hawk hawk 512 Feb 18 2004 test/
-rw-r----- 1 hawk hawk 357 Jan 8 2006 ultra10.err
-rw-rw---- 1 hawk hawk 685 Jul 28 16:36 wsqeai05.err
-rw-rw---- 1 hawk hawk 6 Jul 28 16:36 wsqeai05.pid

The wsqeai05.err has:
060728 16:36:13 mysqld started
060728 16:36:13 [Note] /opt/app/wsqeai05c01/atlas/xampp/sbin/mysqld: ready for connections.
Version: '5.0.18' socket: '/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock' port: 3306 Source distribution

in /logs:

erro.log:

[Fri Jul 28 16:36:12 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jul 28 16:36:12 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Fri Jul 28 16:36:15 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jul 28 16:36:15 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Fri Jul 28 16:36:15 2006] [notice] Apache/2.2.0 (Unix) PHP/5.1.1 DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a configured -- resuming normal operations



I redid the ping and I get:

hawk@wsqeai05-> /opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock ping
mysqld is alive
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby steves » 01. August 2006 02:10

No other ideas????
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 01. August 2006 02:30

hawk@wsqeai05-> /opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock ping
mysqld is alive

Sorry, I must have overlook this part, the first time I read your anwser...

Ok, MySQL is working :-)

Now open phpinfo() with: http://localhost/xampp/phpinfo.php

There is a section about MySQL. Can you copy 'n paste this section?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 01. August 2006 02:42

Wiedmann wrote:
hawk@wsqeai05-> /opt/app/wsqeai05c01/atlas/xampp/bin/mysqladmin --socket=/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock ping
mysqld is alive

Sorry, I must have overlook this part, the first time I read your anwser...

Ok, MySQL is working :-)

Now open phpinfo() with: http://localhost/xampp/phpinfo.php

There is a section about MySQL. Can you copy 'n paste this section?


I see it is trying to get the mysql.sock from root!

MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.0.18
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /opt/xampp/var/mysql/mysql.sock
MYSQL_INCLUDE -I/opt/xampp/include/mysql
MYSQL_LIBS -L/opt/xampp/lib/mysql -lmysqlclient

Directive Local Value Master Value
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket no value no value
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 01. August 2006 12:07

I see it is trying to get the mysql.sock from root!
Code: Select all
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /opt/xampp/var/mysql/mysql.sock
MYSQL_INCLUDE -I/opt/xampp/include/mysql
MYSQL_LIBS -L/opt/xampp/lib/mysql -lmysqlclient

These are the configure settings during the build. So it's correct. But:
mysql.default_socket no value no value

Why have "mysql.default_socket" no value?

Because:
steves wrote:
Wiedmann wrote:For PHP you can config the socket in "php.ini":
Code: Select all
[MySQL]
mysql.default_socket = /opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock

I had that already set in my php.ini

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 01. August 2006 12:31

Wiedmann wrote:
I see it is trying to get the mysql.sock from root!
Code: Select all
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /opt/xampp/var/mysql/mysql.sock
MYSQL_INCLUDE -I/opt/xampp/include/mysql
MYSQL_LIBS -L/opt/xampp/lib/mysql -lmysqlclient

These are the configure settings during the build. So it's correct. But:
mysql.default_socket no value no value

Why have "mysql.default_socket" no value?

Because:
steves wrote:
Wiedmann wrote:For PHP you can config the socket in "php.ini":
Code: Select all
[MySQL]
mysql.default_socket = /opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock

I had that already set in my php.ini

:?:


In php.ini:

Code: Select all

[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = On

; Maximum number of persistent links.  -1 means no limit.
mysql.max_persistent = -1

; Maximum number of links (persistent + non-persistent).  -1 means no limit.
mysql.max_links = -1

; Default port number for mysql_connect().  If unset, mysql_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order).  Win32 will only look
; at MYSQL_PORT.
mysql.default_port =

; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
mysql.default_socket = "/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock"

; Default host for mysql_connect() (doesn't apply in safe mode).
mysql.default_host = "localhost"

; Default user for mysql_connect() (doesn't apply in safe mode).
mysql.default_user =


In my config.inc.php

Code: Select all
[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = On

; Maximum number of persistent links.  -1 means no limit.
mysql.max_persistent = -1

; Maximum number of links (persistent + non-persistent).  -1 means no limit.
mysql.max_links = -1

; Default port number for mysql_connect().  If unset, mysql_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order).  Win32 will only look
; at MYSQL_PORT.
mysql.default_port =

; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
mysql.default_socket = "/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock"

; Default host for mysql_connect() (doesn't apply in safe mode).
mysql.default_host = "localhost"

; Default user for mysql_connect() (doesn't apply in safe mode).
mysql.default_user =


????
steves
 
Posts: 23
Joined: 26. July 2006 21:59

Postby Wiedmann » 01. August 2006 13:00

In php.ini:
Code: Select all
[MySQL]
; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
mysql.default_socket = "/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock"

This is from the "php.ini" that PHP used? See at the beginning of phpinfo().

BTW:
You have restarted Apache after the change?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steves » 01. August 2006 13:46

Wiedmann wrote:
In php.ini:
Code: Select all
[MySQL]
; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
mysql.default_socket = "/opt/app/wsqeai05c01/atlas/xampp/var/mysql/mysql.sock"

This is from the "php.ini" that PHP used? See at the beginning of phpinfo().

BTW:
You have restarted Apache after the change?


The php.ini is from -> /opt/app/wsqeai05c01/atlas/xampp/etc/php.ini

Yes I restarted.

I also added the path in mysql.server

# If you change base dir, you must also change datadir. These may get
# overwritten by settings in the MySQL configuration files.

basedir=/opt/app/wsqeai05c01/atlas/xampp
datadir=/opt/app/wsqeai05c01/atlas/xampp/var/mysql

This did not help either
steves
 
Posts: 23
Joined: 26. July 2006 21:59

PreviousNext

Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 1 guest