Odd problem

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

Odd problem

Postby setuk » 29. September 2005 22:00

I wonder if you can help with the problem below - it might be something to do with the setup and config of the Xampp we are using on production:-

I am experiencing odd behaviour on our prod box when what i want to happen works on our dev box.
What we are trying to achieve is to hit the index.html in the root of a virtual host and have that file redirect the browser to another page - a jsp - and then after that page it should redirect to a web page in the root of the virtual host.

The problem we have is that we cant reference the file that we should be redirected to after the jsp - because the browser makes a request that is prefixed with the alias to arsys63 (see below). - - [29/Sep/2005:19:27:11 +0100] "POST /arsys63/servlet/LoginServlet HTTP/1.1" 302 - "http://enmc-remedy/arsys63/shared/login.jsp?goto=/remedy_main.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)" - - [29/Sep/2005:19:27:11 +0100] "GET /arsys63/remedy_main.html HTTP/1.1" 404 1494 "http://enmc-remedy/arsys63/shared/login.jsp?goto=/remedy_main.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"

In dev we managed to get around this using relative urls for the goto - like this:-

<meta http-equiv="refresh" content="0; URL=/arsys63/shared/login.jsp?goto=../../remedy_main.html">

But when we try this on prod we get this in the apache log:- - - [29/Sep/2005:20:58:32 +0100] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
And then nothing further and a Cannot find server in the browser.

Dev is using mod_jk2 and prod mod_jk - and prod is using pre-compiled xampp install.

The html request isnt being passed to tomcat since its not showing in the mod_jk logs

I'm sure i must be missing something simple

Configuration Details

On production the set up is as follows:-

The virtual host def looks like:-

<VirtualHost *:80>
DocumentRoot "/opt/xampp/htdocs/www-remedy"
ServerName enmc-remedy
ErrorLog "|/usr/local/sbin/cronolog /opt/xampp/logs/%Y/%m/%d/error_remedy.log"
LogLevel Debug
RewriteLog "/opt/xampp/logs/rewrite.log"
RewriteLogLevel 9
CustomLog "|/usr/local/sbin/cronolog /opt/xampp/logs/%Y/%m/%d/remedy_access.log" combined
ScriptAlias /cgi-bin/ "/opt/xampp/htdocs/www-remedy/cgi-bin/"
Alias /arsys63 "/opt/tomcat/webapps/arsys63"
Alias /root "/opt/xampp/htdocs/www-remedy"
<Directory "/opt/xampp/htdocs/www-remedy">
Options FollowSymLinks Indexes Includes
Order deny,allow
Allow from all
<Location />
Order deny,allow
Allow from all

The static html files live in

The redirect information in index.html looks like:-

<meta http-equiv="refresh" content="0; URL=/arsys63/shared/login.jsp?goto=/remedy_main.html">^M
<meta name="keywords" content="automatic redirection">^M

Thu Sep 29 18:50:40 2005
Apache/2.0.52 (Unix) DAV/2 mod_jk/1.2.6 mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.4-dev

Connected to tomcat 5.5.9 with a default configuration

Apache JK Directives:-

JkWorkersFile /opt/xampp/etc/workers.properties
JkLogFile /opt/xampp/logs/mod_jk.log
JkLogLevel debug
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkRequestLogFormat "%w %V %T %q %r"
#JkAutoAlias /opt/tomcat/webapps
JkMount /arsys63/*.jsp ajp13w
JkMount /arsys63/*.css ajp13w
JkMount /arsys63/servlet/* ajp13w
JkMount /arsys63/resources/* ajp13w
JkMount /arsys63/BackChannel/* ajp13w
JkMount /arsys63/forms/* ajp13w
JkMount /arsys63/apps/* ajp13w
Posts: 2
Joined: 29. September 2005 21:55

Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 1 guest