host:port problem with phpmyadmin

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

host:port problem with phpmyadmin

Postby jdigaudi » 22. March 2005 19:06

Hi. I've installed XAMPP on solaris today, user account, not root...so the port is 8080.

Everything seems to be working as expected EXCEPT PHPMyAdmin. The page comes up, but no graphics and anything selected from the page gets "Page Not Found". The reason is because it's putting together the URLs as 'hostport' instead of 'host:port'.

Example: the "Show MySQL runtime information " link is:

http://10.128.23.1008080/phpmyadmin/server_status.php?lang=en-utf-8&server=1&collation_connection=utf8_general_ci


So I'm assuming that all links are being formed incorrectly.

Can someone direct me to the correct place to fix this problem. I could't find anything in the forum...in english, anyway ;)

Thanks in advance,
John
JD
jdigaudi
 
Posts: 5
Joined: 21. March 2005 16:10
Location: New York

Postby Wiedmann » 22. March 2005 19:47

The version of phpMyAdmin?

(in some Versions there is a bug, if you use it on ports other then 80/443)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jdigaudi » 22. March 2005 19:53

phpmyadmin version is 2.6.0-pl3
JD
jdigaudi
 
Posts: 5
Joined: 21. March 2005 16:10
Location: New York

Postby Wiedmann » 22. March 2005 19:59

OK. This is such a version (with bug)...

You can update to the latest phpMyAdmin, or i can mail you a patch for your version.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jdigaudi » 22. March 2005 20:31

Thank you!

I'd like to stick with the same version as the distribution.

Can you please email me a patch, or just tell me where to fix the code, if there are not too many places.

Thanks again,
John
JD
jdigaudi
 
Posts: 5
Joined: 21. March 2005 16:10
Location: New York

Postby Wiedmann » 22. March 2005 22:45

patch.diff
Code: Select all
*** libraries/common.lib.php.orig   Tue Nov 09 16:40:48 2004
--- libraries/common.lib.php   Sun Dec 26 20:27:00 2004
***************
*** 1041,1047 ****
          $cfg['PmaAbsoluteUri'] .= $url['host'];
          // Add port, if it not the default one
          if (!empty($url['port']) && (($url['scheme'] == 'http' && $url['port'] != 80) || ($url['scheme'] == 'https' && $url['port'] != 443))) {
!             $cfg['PmaAbsoluteUri'] .= $url['port'];
          }
          // And finally path, without script name
          $cfg['PmaAbsoluteUri'] .= substr($url['path'], 0, strrpos($url['path'], '/') + 1);
--- 1041,1047 ----
          $cfg['PmaAbsoluteUri'] .= $url['host'];
          // Add port, if it not the default one
          if (!empty($url['port']) && (($url['scheme'] == 'http' && $url['port'] != 80) || ($url['scheme'] == 'https' && $url['port'] != 443))) {
!             $cfg['PmaAbsoluteUri'] .= ':' . $url['port'];
          }
          // And finally path, without script name
          $cfg['PmaAbsoluteUri'] .= substr($url['path'], 0, strrpos($url['path'], '/') + 1);
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jdigaudi » 23. March 2005 15:20

Thank you very much.....I'll give it a try

John
JD
jdigaudi
 
Posts: 5
Joined: 21. March 2005 16:10
Location: New York


Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 1 guest