apxs not working?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

apxs not working?

Postby jammer » 07. January 2005 09:39

hi..

i'm trying to compile mod_jk.so using the apxs that comes with xampp 1.4.11.
however, it's returning this error:

cannot open /opt/lampp/build/config_vars.mk: No such file or directory at /opt/lampp/bin/apxs line 217.

the only option i see right now is for me to recompile apache httpd to get a valid apxs.

would anybody know if there is an alternative to recompiling?

thanks
jammer
 
Posts: 3
Joined: 07. January 2005 09:22

Postby Oswald » 07. January 2005 14:22

Dear jammer!

You also need the XAMPP development package. It contains the missing files. You can get it from the same place where you downloaded XAMPP: http://www.apachefriends.org/en/xampp-linux.html

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

thanks!

Postby jammer » 10. January 2005 05:02

thanks Oswald!

i managed to compile mod_jk.so without a hitch and now i've now got tomcat 5.5.4 running alongside apache...

now i've just got to connect mysql with tomcat and i'm all set :D
jammer
 
Posts: 3
Joined: 07. January 2005 09:22


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests