Client does not support authentication protocol - Mysql

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Client does not support authentication protocol - Mysql

Postby mobious » 02. January 2005 19:35

Hello,

I am getting a error attempting to access the Mysql server from a remote website.

Could not connect to mysql: Client does not support authentication protocol requested by server; consider upgrading MySQL client


I allowed mysql to be accessed from the network and set my user account to be allowed from any domain and the webserver I am trying to access it from.

Also, I just updated Xampp for version 1.4.11..

Thanks for the help..
mobious
 
Posts: 8
Joined: 02. January 2005 19:28

Postby mobious » 04. January 2005 15:10

No one has an idea about this problem?? I saw the error in the German support forums but could get a good translation for it..
mobious
 
Posts: 8
Joined: 02. January 2005 19:28

Postby Oswald » 04. January 2005 20:33

Dear mobious!

Simply edit the file /opt/lampp/etc/my.cnf and insert old-passwords after the line containing [mysqld]. It should look like:

...
# The MySQL server
[mysqld]
old-passwords
port = 3306
...


Restart MySQL or XAMPP and now you should be able to connect with an old client.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby mobious » 05. January 2005 04:50

Thanks for the effort..
But it still didnt work..
Here is part of my my.cnf file

[mysqld]
# commented out by lampp security
old-passwords
port = 3306
socket = /opt/lampp/var/mysql/mysql.sock
skip-locking
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin
server-id = 1
mobious
 
Posts: 8
Joined: 02. January 2005 19:28

Postby Oswald » 05. January 2005 10:18

Dear mobious!

That's bad. First a question: Which version of XAMPP do you used as you were setting passwords for MySQL?

The problem is you are using the new password hash format of MySQL and your client is to old to support this new format.

A solution is described here: http://dev.mysql.com/doc/mysql/en/Old_client.html

But in my opinion you shoud try to upgrade your client. If possible.

Greetings and good luck
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby mobious » 05. January 2005 14:24

I used the previous version of 1.4.11 to set my passwords.

I installed XAMPP for windows on my windows 2k server.. Where I am trying to access the data from. I can access the database locally but can not connect to the remote db on my linux server..


I will try that link you sent and see if that works.

BTW.. When I SSH to the box I cant even logon to the mysql server at the command line..
Do you think if I back up the website.. Uninstall Xampp remove all the old files and folders then install the new version again and set up the DB again.. Do you think this would fix my problem? I noticed when i installed the pervious version I couldnt even login locally as root. It kept saying root@localhost not allowed..
mobious
 
Posts: 8
Joined: 02. January 2005 19:28

Postby mobious » 06. January 2005 17:14

Ok I found my answer.. If anyone ever needs to access the mysql DB from a remote application or website and get this error go here..

http://dev.mysql.com/doc/mysql/en/Old_client.html

it fixed me right up!

Thanks for the help!
mobious
 
Posts: 8
Joined: 02. January 2005 19:28


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests

cron