turkmmcache in 1.4.11 problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

turkmmcache in 1.4.11 problem

Postby LazyP » 29. December 2004 17:19

I get the following error message when starting apache with php

PHP Warning: [Turck MMCache] This build of "Turck MMCache" was compiled for PHP version 4.3.9. Rebuild it for your PHP version (4.3.10) or download precompiled binaries.
in Unknown on line 0
PHP Warning: Unknown(): Unable to initialize module 'Turck MMCache' in Unknown on line 0

Is this an error in 1.4.11 or could this be a local problem?
LazyP
 
Posts: 4
Joined: 11. November 2004 15:55

Postby LazyP » 29. December 2004 17:29

one more thing, I upgraded from 1.4.9 to 1.4.10a to 1.4.11 today using the upgrade files from sourceforge.
LazyP
 
Posts: 4
Joined: 11. November 2004 15:55

Postby Oswald » 29. December 2004 18:00

Dear LazyP!

Oh sorry. It's a XAMPP error: I forgot to recompile Turck MM Cache for the new versions of PHP. I will provide a patch to fix this problem soon.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Oswald » 29. December 2004 19:38

Dear LazyP!

I just build a patch fixing the problem. You could download it from the following url:

http://www.apachefriends.org/tmp/xampp- ... .11.tar.gz

Use the patch the following way:

1: Extract the archive with tar xvfz xampp-linux-mmcache-patch-1.4.11.tar.gz

2: Enter the patch directory: cd xampp-patch

3: Start the patch process: ./start

That's all. Turck MMCache should work now. You now may delete the xampp-patch directory.

Greetings and thank you very much for finding the problem so fast.
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby akirmeir » 31. December 2004 02:13

maybe theres another Problem with mmcache:

One of the "fixes" in 4.3.10 involves backporting the foreach() code from PHP 5.0 and this in turn seems to be incompatible with Zend Optimizer, Turck MMcache, PHP Accelerator, etc. In the case of Zend Optimizer there is an update available that fixes the problem. I am not aware of any similar fixes for the others, except to disable them.

the "foreach" will no longer work if the turckloader is used to compile the scripts. runtime compile will work i think

eAccelerator is a further development from mmcache PHP Accelerator & Encoder and works with php 4.3.10
akirmeir
 
Posts: 24
Joined: 27. October 2003 10:39
Location: Riedstadt

Postby RaVen69 » 01. February 2005 19:58

akirmeir wrote:... eAccelerator is a further development from mmcache PHP Accelerator & Encoder and works with php 4.3.10 ...


Sorry to tell you that eAccelerator doesn't work for me with XAMPP 1.4.11 and XAMPP 1.4.12 beta (but only with PHP4 => 4.3.10, PHP 5 is ok)

I always get:
Code: Select all
PHP Warning:  Unknown(): Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/eaccelerator.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/eaccelerator.so: undefined symbol: OnUpdateLong in Unknown on line 0


So if anyone has an idea please let me know

Greetz from Vienna

RaVen
RaVen69
 
Posts: 1
Joined: 01. February 2005 13:43

eaccelerator

Postby akirmeir » 01. February 2005 20:44

what version of eaccelerator ?
akirmeir
 
Posts: 24
Joined: 27. October 2003 10:39
Location: Riedstadt

Postby Oswald » 01. February 2005 22:21

Dear RaVen!

Thank you very much! It's my fault. I compiled eAccellerator for PHP 4.3.10 with the header files from PHP 5.0.3.

Uploading right now a new fixed BETA version...

Thanks again and many greetings from Berlin to Vienna!!
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests