POSTEGRESQL PROBLEM HELP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

POSTEGRESQL PROBLEM HELP

Postby aigida » 01. December 2004 12:20

just installed the postgresql addon but cant seem to login....
cannot find an error log file....dont know where it is located so i can examine...
do i have to have a postegresql database server insatalled first and then the addon ?
please help
aigida
 
Posts: 2
Joined: 01. December 2004 12:09

Postby PF4 » 01. December 2004 15:55

Hi,
you have to start postgresql : /opt/lampp/postgresql start

then login:
user: root
pw: lampp
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby aigida » 02. December 2004 09:09

correct me if i am wrong.... the actual server of postgresql is inside the addon...just like mysqld ....and i have to start it....

/--------------------------------------------/

this happens when i try to start postgresql


$ ./postgresql start
Starting PostgreSQL
This account is currently not available.

what seems to be the problem?

after that i try to login but....nothing happens...i get login failed

Thanx in advance
aigida
 
Posts: 2
Joined: 01. December 2004 12:09

I have the same problem.¡

Postby christoo » 11. January 2005 16:14

Hi.

I have the same problem.. I'm waiting an answer, when I got it, I'll send it to you, ok? :)

See you then....
christoo
 
Posts: 8
Joined: 04. January 2005 16:31

Postby Kristian Marcroft » 11. January 2005 16:19

Hi,

you have to start postgre like this:

/opt/lampp/lampp startpostgresql

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

that's what I do ¡¡¡

Postby christoo » 11. January 2005 16:36

Hi Kris

That's what I did, but I have the same problem ¡¡


It looks like this:

[root@colivaresc etc]#
[root@colivaresc etc]# /opt/lampp/lampp startpostgresql
Starting PostgreSQL
This account is currently not available.
[root@colivaresc etc]#

I have other postgresql application, but I've stoped it before I start the lampp one.

So, what I can do?
christoo
 
Posts: 8
Joined: 04. January 2005 16:31

Same problem...

Postby carlH » 03. January 2006 14:24

Hi all

I've got the same problem (xamp1.5 / addon postgresql 1.0)

I saw that the last post was very old, hoping that there is an solution now for this issue.

TIA
carlH
 
Posts: 4
Joined: 03. January 2006 14:15

Postby carlH » 05. January 2006 06:45

I guess PostgreSQL can't be launched by root

I do not lauch PG with lampp, I use this command instead :

Code: Select all
sudo -u postgresql /opt/lamp/bin/postmaster -D /opt/lamp/var/pgsql/data/
carlH
 
Posts: 4
Joined: 03. January 2006 14:15


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests