Firebird 1.5 / Interbase and Xampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

hmm...

Postby whiterabbit » 03. January 2005 23:01

hmm, no idea. I recommend the php-firebird and firebird-support forums at yahoo.com group for this question you have. they are super helpful.

It sounds like an issue with the lock manager that the classic server uses. does it also happen with superserver?

post your question to: http://groups.yahoo.com/group/firebird-support/

and http://groups.yahoo.com/group/firebird-php/

Cheers David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby MrSpock » 04. January 2005 10:24

Thank you David,

I will try to find an answer there.
Live long and prosper

MrSpock
MrSpock
 
Posts: 5
Joined: 03. January 2005 19:30

Request for help with RHEL 4 with XAMPP and Firebird

Postby whiterabbit » 07. June 2005 17:42

Hello Kristian and apachefriends,

We started to move our servers over to redhat enterprise 4. On my test server I could not get the procedures we followed in this thread to work for recompiling php to work with firebird and xampp. The errors I was getting were related to bz2 libraries? Can you or someone else give assistance please? Below are the differences:

PREVIOUS NEW
redhat 9 -> RHEL 4
xampp-linux-1.4.9a -> XAMPP Linux 1.4.13
php-4.3.9 -> php-4.3.11



Below is the procedure I used to get the previous in Nov 2004 working.

Code: Select all
----------------------------------------------------------------
;;using Redhat 9.0
su root
tar xvfz [b]xampp-linux-1.4.9a.tar.gz[/b] -C /opt
tar xvfz [b]xampp-linux-devel-1.4.9.tar.gz[/b] -C /opt
rpm -ivh FirebirdSS*.rpm (1.5.1.4481-0 or 1.5.2.4731-0)**NPTL build!!**
ln -s /opt/firebird /opt/interbase
;;;[this is because the default install directory for ver 1.5 is /opt/firebird]
/opt/firebird/bin/gsec
modify sysdba -pw newpasswordhere
quit
tar zxf [b]php-4.3.9.tar.gz[/b]
cd php*
CFLAGS="-I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" \
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc \
--with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase \
--enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp \
--enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit \
--enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars \
--enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp \
--with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp \
--without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp \
--enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp \
--with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp \
--with-gettext=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-mcrypt=/opt/lampp \
--with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex \
--enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --with-bz2=/opt/lampp --with-interbase=shared,/opt/interbase

make && make install
vi /opt/lampp/etc/php.ini [turn sybase magic quotes=On and add/uncomment extension="interbase.so"]

--------------------------------------------------------------



Kristian Marcroft wrote:Hi,

btw,
you did do a "make && make install" right?
and then you have to add the extension in php.ini

Hope it helps

So long
KriS
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Previous

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests