Firebird 1.5 / Interbase and Xampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Firebird 1.5 / Interbase and Xampp

Postby whiterabbit » 15. November 2004 16:37

Hello!
I am wondering if anyone has had success integrating the interbase/firebird support with xampp on linux. Or windows for that matter. I have be trying for the last week to get it working both with a raw source code install of FB and apache and php. It seems that even with a compile and retrieving the interbase.so file into the modules/extensions directory and modifying php.ini to point to it just generates errors.

Does anyone have a hack of xampp with Firebird integrated. I would like to use FB rather than mysql, as my frustration with lack of views, and triggers is high.

Is anyone is the same boat??

Thanks,

David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

actually Xampp 1.4.9a only works with Firebird 1.0, not 1.5

Postby whiterabbit » 15. November 2004 18:36

[note: added after realization that Xampp supports Firebird 1.0 only.]

Would anyone be willing to help me get FB 1.5 to work with Xampp without breaking Xampp. Can I just recompile the php sources in Xampp? Is there a list of the configure options that xampp uses?

Thanks,

David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

further realization with compiling php sources with xampp

Postby whiterabbit » 15. November 2004 18:48

I just realized that phpinfo() shows the configuration that was used to compile php.

Therefore I am going to try recompiling php in xampp for FB 1.5 support.

Does anyone know if I should be using the "development" version of xampp??

Thanks,

David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby Kristian Marcroft » 15. November 2004 19:16

Hi,

yes you have to also install the dev. Version.
You have to copy it over the normall XAMPP.
The dev. Version just adds some Libs and some header files...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

possible procedure for Firebird 1.5 and xampp

Postby whiterabbit » 15. November 2004 20:01

Thanks Kris for your reply.

Would you please comment on whether the following procedure is correct or missing anything?

I am using VMWare so installing and rolling back is easy.

su root
tar xvfz xampp-linux-1.4.9a.tar.gz
tar xvfz xampp-linux-devel-1.4.9.tar.gz
rpm -ivh FirebirdSS-1.5.1.4481-0.i686.rpm
ln -s /opt/firebird /opt/interbase
;;;[this is because the default install directory for ver 1.5 is /opt/firebird]
tar zxf php-4.3.9.tar.gz
cd php*
;;;[next is taken from from the phpinfo() configure]
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc --with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp --with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp --without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp --enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp --with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp --with-gettext=/opt/lampp --with-mssql=/opt/lampp --with-interbase=/opt/interbase --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-oci8=shared --with-mcrypt=/opt/lampp --with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex --enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --enable-pcntl --with-bz2=/opt/lampp

make
;;; Now what should i do? I have seen different people to different steps after this. Some just copy the interbase.so to extensions, so copy it to modules.
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby Kristian Marcroft » 15. November 2004 20:09

Hi,

since you don't have all the sources.. for example for Oracle SUpport, you should deactivate this.

configure should then look something like this:

CFLAGS="-I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" \
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc \
--with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase \
--enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp \
--enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit \
--enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars \
--enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp \
--with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp \
--without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp \
--enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp \
--with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp \
--with-gettext=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-mcrypt=/opt/lampp \
--with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex \
--enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --with-bz2=/opt/lampp --with-interbase=shared,/opt/interbase

should work anyways...
works here fince..
This is how I compile the AddOns for XAMPP.

Hope it helps
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Thanks Kris!

Postby whiterabbit » 15. November 2004 20:29

Thanks Kris, I will give it a go!!

Cheers,

David

Kristian Marcroft wrote:Hi,

since you don't have all the sources.. for example for Oracle SUpport, you should deactivate this.

configure should then look something like this:

CFLAGS="-I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" \
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc \
--with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase \
--enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp \
--enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit \
--enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars \
--enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp \
--with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp \
--without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp \
--enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp \
--with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp \
--with-gettext=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-mcrypt=/opt/lampp \
--with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex \
--enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --with-bz2=/opt/lampp --with-interbase=shared,/opt/interbase

should work anyways...
works here fince..
This is how I compile the AddOns for XAMPP.

Hope it helps
So long
KriS
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

it did not work

Postby whiterabbit » 15. November 2004 21:37

Hello Kris or other helpers.

After running configure on php with your suggestions, would you be so kind as to tell me what I need to integrate the newly compiled php into xampp?

This is the error I get when I publish my project:

Code: Select all
Warning: Unknown(/opt/lampp/htdocs/firebirdtest3/NewPage1.php): failed to open stream: Permission denied in Unknown on line 0

Warning: (null)(): Failed opening '/opt/lampp/htdocs/firebirdtest3/NewPage1.php' for inclusion (include_path='.:/opt/lampp/lib/php') in Unknown on line 0


Thanks,

David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby Kristian Marcroft » 15. November 2004 21:45

Hi,

who does the File:
/opt/lampp/htdocs/firebirdtest3/NewPage1.php
belong to?
Check the rights on the file.
should be nobody.root

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Kristian Marcroft » 16. November 2004 06:39

Hi,

btw,
you did do a "make && make install" right?
and then you have to add the extension in php.ini

Hope it helps

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby MrSpock » 03. January 2005 19:37

Since I also have some difficulties, to access firebird 1.5 with my XAMPP distribution, I followed the above shown way, but downloaded the latest XAMPP Version 1.4.11. I unpacked both archives. Do I have to download php sources additionally? And if yes, which version? Because after unpacking, there is no php* folder.
Live long and prosper

MrSpock
MrSpock
 
Posts: 5
Joined: 03. January 2005 19:30

My final solution for FB 1.5 PHP and Xampp and Codecharge.

Postby whiterabbit » 03. January 2005 20:19

This was with a lot of help from Kristian et al at apachefriends, and the codecharge folks.

Code: Select all
----------------------------------------------------------------
first download latest stable build or use your existing of PHP, Xampp, (You also need the Developer build of Xampp.) Firebird Superserver.  Below uses these.  Substitute the version names with whichever build you used.
;;using Redhat 9.0

su root

tar xvfz xampp-linux-*.tar.gz -C /opt

tar xvfz xampp-linux-devel-*.tar.gz -C /opt

rpm -ivh FirebirdSS*.rpm (1.5.1.4481-0 or 1.5.2.4731-0)
;;;; **USE THE NPTL BUILD OF FIREBIRD IF YOU ARE USING REDHAT9, FEDORA, MANDRAKE OR ANY NEW LINUX BUILD USING POSIX BLAH BLAH

ln -s /opt/firebird /opt/interbase
;;;[this is because the default install directory for ver 1.5 is /opt/firebird]

/opt/firebird/bin/gsec

modify sysdba -pw newpasswordhere

quit

tar zxf php-4.3.9.tar.gz

cd php*

;;;; Past the section below text into a bash box. 
CFLAGS="-I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" \
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc \
--with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase \
--enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp \
--enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit \
--enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars \
--enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp \
--with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp \
--without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp \
--enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp \
--with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp \
--with-gettext=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-mcrypt=/opt/lampp \
--with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex \
--enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --with-bz2=/opt/lampp --with-interbase=shared,/opt/interbase


make && make install

vi /opt/lampp/etc/php.ini
;;;;turn sybase magic quotes=On and add/uncomment extension="interbase.so"

;;; restart firebird and xampp now and you are good to go!!!

--------------------------------------------------------------

Let me know if you need codecharge to work with this config.[/quote]
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby MrSpock » 03. January 2005 20:36

Hi whiterabbit,

thank you for the quick answer. I have downloaded php-4.3.10 and unpacked it into /usr/src/php-4.3.10. When I call configure with the command, that you have postet, I receive the following error:

checking for Sablotron version... configure: error: Sablotron version 0.96 or greater required.


What is Sablotron :shock: ?

By the way: I am using SuSE 9.0
Live long and prosper

MrSpock
MrSpock
 
Posts: 5
Joined: 03. January 2005 19:30

Postby whiterabbit » 03. January 2005 20:46

you know, with linux i use www.vmware.com workstation extensively on both my servers and test stations. The reason is that linux often breaks on me, and rather than try to fix it, which i often cant, i just revert to my last good snapshot. Or quickly build a new install with nothing extra on it. I recommend this.

Google found http://www.gingerall.com/charlie/ga/xml ... .xml?s=org

Get vmware, and build your server from scratch, snapshot, then try to break it until you get it right.

Cheers.

David
whiterabbit
 
Posts: 10
Joined: 15. November 2004 16:28
Location: Canada

Postby MrSpock » 03. January 2005 22:45

Hello whiterabbit,

I downloaded the sources for php 5.0.3 configured it, called make and makeinstall and it worked! I did not have to modify php.ini. Actually trying to activate the extension php_interbase.so failed, since this file does not exist. It was interesting that the firebird passwort, that I had already changed before, after installing FirebirdCS (not the superserver!), had been changed somehow. But your call of gsec and modify did work perfectly.

Thanks for your help. Now I have full access to the firebird server.

I use ibWebAdmin 0.99.1 and it makes it easy to access all data. Only, if I call the Admin page and look e.g. for server statistic or database statistic, I receive the following error message:

/opt/firebird/bin/fb_lock_mgr returned error code 126


Do you have any idea, what that means?
Live long and prosper

MrSpock
MrSpock
 
Posts: 5
Joined: 03. January 2005 19:30

Next

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests