Got an error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Got an error

Postby io » 10. November 2004 09:04

hi,

when i started XAMPP on debian, i got an error message as following;

Starting XAMPP for Linux 1.4.9a...
/bin/sh: error while loading shared libraries: /opt/lampp/lib/libncurses.so.5: E
LF file data encoding not big-endian
/bin/bash: error while loading shared libraries: /opt/lampp/lib/libncurses.so.5:
ELF file data encoding not big-endian
/bin/bash: error while loading shared libraries: /opt/lampp/lib/libncurses.so.5:
ELF file data encoding not big-endian
/bin/bash: error while loading shared libraries: /opt/lampp/lib/libncurses.so.5:
ELF file data encoding not big-endian
XAMPP for Linux started.


does anybody have any information about that?

p.s. since I'm not a speaker of german, i'd be happy if you write your message in english. Thank you.
io
 
Posts: 4
Joined: 10. November 2004 08:41

Postby Oswald » 10. November 2004 09:32

Hi io!

Never saw this error before. Could you please call the following three commands and post the output here:

ls -l /opt/lampp/lib/libncurses.so.5
ls -l /opt/lampp/lib/libncurses.so.5.3
file /opt/lampp/lib/libncurses.so.5.3


Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby io » 10. November 2004 10:06

hi, Oswald! Thank you for your reply.

Kai 'Oswald' Seidler wrote:Never saw this error before. Could you please call the following three commands and post the output here:


I tried what you mentioned.

KURO-BOX:~# ls -l /opt/lampp/lib/libncurses.so.5
lrwxrwxrwx 1 root root 17 Jan 28 22:30 /opt/lampp/lib/libncurse
s.so.5 -> libncurses.so.5.3

KURO-BOX:~# ls -l /opt/lampp/lib/libncurses.so.5.3
-rw-r--r-- 1 root root 261676 Oct 4 2004 /opt/lampp/lib/libncurses.so.5.3

i couldn't use 'file' command on my debian. I don't know why. Sorry about that.
io
 
Posts: 4
Joined: 10. November 2004 08:41

Postby Oswald » 10. November 2004 10:36

Hi io!

The output looks like expected. Everything seems to be okay.

What processor does your system have?

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby io » 10. November 2004 10:49

Thank for your help, Oswald.

Kai 'Oswald' Seidler wrote:What processor does your system have?


motorola 8241 200MHz+RAM 64MB+flashROM 4MB

well, i use a KURO-BOX , which is a very unique tool.

http://kurobox.com/news.html

if i get such errors, is XAMPP working normally? Or are there any problems?

Thanks again.
io
 
Posts: 4
Joined: 10. November 2004 08:41

Postby Oswald » 10. November 2004 11:10

Dear io!

I'm afraid XAMPP will not work on your system. XAMPP for Linux is only build for Intel and Intel-compatible CPUs.

I mention it on the top of the XAMPP for Linux page but possibly I should make the notice more eye-catching.

Sorry for the misunderstanding!

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby io » 10. November 2004 13:44

Dear Oswald!

Thank you for taking your time to help me out. Now I understand why I got such errors on my system.

I love this wonderful XAMPP, and it works on my windows PC perfectly. It really helps me. Keep going and make us happy!

Danke! And thank you so much!
io
 
Posts: 4
Joined: 10. November 2004 08:41


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests