Page 1 of 1

Problem with MySQL - Gentoo box

PostPosted: 28. October 2004 21:14
by Wampas
Hey there,

A while ago i used Xampp on my RedHat box, was working fine.
Now i installed Gentoo, its working pretty well, appart for Xampp :(

What happens :
1) i follow installation (well its simple, just need to download and unzip in /opt)
2) i start /opt/lampp/lampp start
3) i go to http://localhost/
It gives me XAMPP page as intended. Now i try to go to phpmyadmin, result :

Error :
MySQL said:
#2002 : Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (111)

So i go back to Xampp status, it says MySQL database DEACTIVATED.
I dont understand this, since MySQL started ! I have it running in the process.

I did several installations, tries, attempts, and still i get an error. Tried to configure php.ini or my.cnf and more... still would not work.

SOOOooooo i did a new install, exactely like on this website, and retried.
I start /opt/lampp/lampp security
to check it out.
And it says that MySQL has a passwort, fine! :)

I never gave passwort to MySQL... And everytime i install XAMPP it says MySQL has a passwort. Any clue?.



PostPosted: 28. October 2004 21:18
by Wampas
Btw also tried to chmod 777 /opt/lampp/var/mysql, doesnt help much.
Also tried with php4, doesnt work better.
Also tried to put instead of localhost in both php.ini and on browser, doesnt help.
I tried to put path to socket in php.ini, doesnt help more
I tried cookie, http, modes doesnt help more. Tried a bit of everything :(

I may have to try to download new files, maybe i had a corrupted version.. /shrug

thanks for reading,


PostPosted: 28. October 2004 21:26
by Kristian Marcroft

you have a mysqld running from Gentoo.
Stop it.. and then start the one of XAMPP.

Then It'll work

Good Luck
So long

PostPosted: 28. October 2004 21:32
by Wampas
I thought about this, but when doing ps -A i see nothing running looking like a mysql process.



PostPosted: 28. October 2004 21:38
by Wampas
Maybe i missed something, here are my process. Sorry to bother, but ive been looking for 2-3 days lolll...

bash-2.05b# ps -A
1 ? 00:00:05 init
2 ? 00:00:00 keventd
3 ? 00:00:00 ksoftirqd_CPU0
4 ? 00:00:00 kswapd
5 ? 00:00:00 bdflush
6 ? 00:00:01 kupdated
7 ? 00:00:00 jfsIO
8 ? 00:00:00 jfsCommit
9 ? 00:00:00 jfsSync
10 ? 00:00:00 xfsbufd
11 ? 00:00:00 xfslogd/0
12 ? 00:00:00 xfsdatad/0
14 ? 00:00:00 khubd
17 ? 00:00:41 kjournald
157 ? 00:00:00 devfsd
971 ? 00:00:00 metalog
976 ? 00:00:00 metalog
1091 ? 00:00:00 dhcpcd
1262 ? 00:00:00 cron
1334 vc/1 00:00:00 agetty
1335 vc/2 00:00:00 agetty
1336 vc/3 00:00:00 agetty
1337 vc/4 00:00:00 agetty
1338 vc/5 00:00:00 agetty
1339 vc/6 00:00:00 agetty
1355 ? 00:00:00 kdm
1358 ? 00:02:03 X
11462 ? 00:00:00 kdm
11469 ? 00:00:00 startkde
11501 ? 00:00:00 kdeinit
11504 ? 00:00:00 kdeinit
11506 ? 00:00:00 kdeinit
11509 ? 00:00:00 kdeinit
11518 ? 00:01:19 artsd
11539 ? 00:00:18 kdeinit
11540 ? 00:00:00 kwrapper
11542 ? 00:00:00 kdeinit
11543 ? 00:00:01 kdeinit
11546 ? 00:00:00 kdeinit
11547 ? 00:00:01 kdeinit
11549 ? 00:00:16 kdeinit
11550 ? 00:00:00 kdeinit
11552 ? 00:00:02 kdeinit
11554 ? 00:00:00 krandrtray
11557 ? 00:00:04 kdeinit
11558 pts/1 00:00:00 bash
9394 ? 00:00:01 kdeinit
9414 pts/2 00:00:00 bash
13713 pts/2 00:00:00 ps



Re: Problem with MySQL - Gentoo box

PostPosted: 28. October 2004 21:40
by Kristian Marcroft
Wampas wrote:So i go back to Xampp status, it says MySQL database DEACTIVATED.
I dont understand this, since MySQL started ! I have it running in the process.


then I'm sorry to say I don't understand the above Quote.
try changing to user root and then type:

ps aux | grep mysql

Whats the output?

So long

PostPosted: 28. October 2004 21:45
by Wampas
Oh no, the quote above is when i start XAMPP :
1) when i start Xampp, it says MySQL starts.... But on the website http://localhost, i click status, and it says MySQL databade DEACTIVATED.
2) when Xampp is stopped, i check the process and the result is what i posted.

To your question :

tux / # ps aux | grep mysql
root 13959 0.0 0.0 1408 448 pts/2 R+ 20:44 0:00 grep mysql
tux / #



PostPosted: 28. October 2004 21:56
by Kristian Marcroft

could you please check the .err file from mysql?
its located in /opt/lampp/var/mysql

So long

PostPosted: 28. October 2004 21:58
by Wampas

Here is machinename.err, the last lines :

Code: Select all
041029 19:58:53  mysqld started
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 80383 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbfffef58, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
New value of fp=(nil) failed sanity check, terminating stack trace!
Please read and follow instructions on how to resolve the $
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
The manual page at contains
information that should help you find out what is causing the crash.
041029 21:10:29  mysqld ended

This is chinese for me :D



PostPosted: 28. October 2004 22:18
by Kristian Marcroft

we only recently had a simular Problem in the German Forum.
The guy forgot to set the Localtime right.

could you please also check this?

So long

PostPosted: 28. October 2004 22:25
by Wampas
You right ! :oops:

I have 21:24 on KDE on October 28 (is the correct day), but if i type /date it returns me October 29, which is tomorrow.

Wouldnt have thought it could cause this kind of errors, thanks a ton;
now need to figure out how to fix it without messing;

thanks a lot,



PostPosted: 28. October 2004 23:14
by Wampas
The link /etc/localtime was all messed! ><
Went also in Bios to set the time right, set kde time right at same time ^^
Then created the link :
ln -sf /usr/share/zoneinfo/Europe/Paris /etc/localtime

MySQL works just fine now.

Thanks alot for the help,
I found it amuzing how a mysql password issue is solved by seting the time right :)