Problems with the Linux version of XAMPP, questions, comments, and anything related.


Postby vydex » 22. October 2004 10:32

Just wondering if someone could help me with this. I have read and searched the forum and apache docs and cant really find a clear and consise answer
Basically all i want to do is change the root directory from where apache serves the web pages. At the moment its still set to default which is


I want to change this to


What parts do I have to change in the httpd.conf file in order for this to work ive tried changing these sections in httpd.conf

DocumentRoot "/opt/lampp/htdocs" to
DocumentRoot "/opt/lampp/htdocs/public/postnuke/html"

# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
# First, we configure the "default" to be a very restrictive set of
# features.
<Directory />
Options FollowSymLinks
AllowOverride None

# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.

# This should be changed to whatever you set DocumentRoot to.
<Directory "/opt/lampp/htdocs"> to
<Directory "/opt/lampp/htdocs/public/postnuke/html">

I have made sure that all " etc are correct but it doesnt seem to work.
any help would be gratefully appreciated thanks
Posts: 2
Joined: 15. October 2004 09:53

Postby Kristian Marcroft » 22. October 2004 10:53


what is the error?
What error do you get?
Whats in the logfile?
Maybe the Owner of the new Files are not set right (nobody.root)

So long
User avatar
Kristian Marcroft
AF Moderator
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests