Can't access WordPress db anymore [solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Can't access WordPress db anymore [solved]

Postby claus_01 » 21. June 2020 20:46

Hi all,

I am running XAMPP for Linux 7.4.6 and WordPress 5 on Ubuntu Mate 20.04. In order to make my blog available to a few people via the internet, I opened a port on my router. In order to make XAMPP more secure, I performed 'sudo /opt/lampp/lampp security', but now I can't access WordPress anymore. Alas, I forgot to export the WordPress database :(, which is not present in phpMyAdmin (user pma) anymore. I already checked 'config.inc.php', but to no avail. My question: Is there a way to reverse the steps I have taken, or do I have to install everything anew?

TIA,

Claus

P. S. I could solve the issue by opening 'wp-config.php' with a text editor ('sudo ...') and inserting the MySQL password. Then I logged in to phpMyAdmin with the user 'root' and my MySQL password. Now I have the WordPress database back again and made a backup. :D
claus_01
 
Posts: 12
Joined: 01. July 2010 15:35
Location: Ludwigsburg
XAMPP version: 7.4.6-0
Operating System: Ubuntu 20.04

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 15 guests