Page 1 of 1

phpmyadmin not working properly

PostPosted: 14. March 2020 03:50
by alfiebear
I have just installed XAMPP 7.4.3 on Linux Mint 19.3 and all seemed to go well. I am able to initiate the Control Panel and start/restart servers etc. Also able to display Dashboard in Browser (Firefox). Dashboard will open PHPinfo window but the phpMyadmin page just shows a lot of text which looks like code.

I have checked a good many pages of solutions but without success and I do not want to try too many suggestion in case I stuff up my installation and many of the solutions apply to older versions of the installed XAMPP applications.

Any advice would be much appreciated.

Re: phpmyadmin not working properly

PostPosted: 14. March 2020 15:12
by Nobbie
I have exactly the same software (Xampp 7.4.3, Linux Mint 19.3) and it runs fine. Did you click on the phpmyadmin link in the dashboard? Or click here: http://localhost/phpmyadmin

Re: phpmyadmin not working properly

PostPosted: 15. March 2020 10:06
by alfiebear
Thankyou Nobbie - yes i tried the Dashboard phpmyadmin link and all I got was a page of text.

I tried http://localhost/phpmyadmin also with same result.

Then I finally read somewhere (after God knows how many Googled suggestions) about localhost might need to be changed to for php (cannot recall right now which file it was in - might have been an .ini) so I did that and viola! it worked ok. So now the Dashboard link works and so does and also somewhat strangely so does localhost/phpmyadmin...