Configuring XAMPP/MySQL to use INNODB Tables

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Configuring XAMPP/MySQL to use INNODB Tables

Postby cygnus8929 » 07. October 2004 06:13

Does the MySQL included with XAMPP for Linux support the INNODB table type? If so, how does one go about configuring MySQL to use them?

I've edited /opt/lampp/etc/my.cnf by commenting the skip-innodb line and uncommenting the other lines as instructed in the file.

However, MySQL will not start w/o the skip-innodb line in my.cnf. :(

Any help would be greatly appreciated.

Thanks.
cygnus8929
 
Posts: 1
Joined: 07. October 2004 06:09

Postby Oswald » 07. October 2004 08:16

Hi Cygnus!

XAMPP for Linux comes with InnoDB support and it should work the way you reported. I just tried it with XAMPP for Linux 1.4.9a:

- Comment out skip-innodb
- Uncomment the InnoDB settings below the skip-innodb. Looks now like:
Code: Select all
#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = /opt/lampp/var/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /opt/lampp/var/mysql/
innodb_log_arch_dir = /opt/lampp/var/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50


- Restart XAMPP

Than take a look into your /opt/lampp/var/mysql directory and you should see the InnoDB files:
Code: Select all
-rw-rw----  1 nobody nobody    25088 Oct  7 09:10 ib_arch_log_0000000000
-rw-rw----  1 nobody nobody  5242880 Oct  7 09:10 ib_logfile0
-rw-rw----  1 nobody nobody  5242880 Oct  7 09:10 ib_logfile1
-rw-rw----  1 nobody nobody 10485760 Oct  7 09:10 ibdata1


And in the .err file in the same directory you shuld find the following messages:
Code: Select all
041007 09:10:31  mysqld started
InnoDB: The first specified data file /opt/lampp/var/mysql/ibdata1 did not exist:
InnoDB: a new database to be created!
041007  9:10:32  InnoDB: Setting file /opt/lampp/var/mysql/ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
041007  9:10:34  InnoDB: Log file /opt/lampp/var/mysql/ib_logfile0 did not exist: new to be created
InnoDB: Setting log file /opt/lampp/var/mysql/ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
041007  9:10:34  InnoDB: Log file /opt/lampp/var/mysql/ib_logfile1 did not exist: new to be created
InnoDB: Setting log file /opt/lampp/var/mysql/ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
041007  9:10:36  InnoDB: Started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.21-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306  Source distribution


Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby komakoma » 28. January 2005 07:30

how to solve the problem of cannor read and creat a file from /root/tmp

i change mode to 777 , it still don't work
mysql cannot start
komakoma
 
Posts: 3
Joined: 25. January 2005 04:42


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests