PHP5 comfigure/compile

Problems with the Linux version of XAMPP, questions, comments, and anything related.

PHP5 comfigure/compile

Postby dnuttall » 06. October 2004 12:03

I've been trying to emulate the XAMPP concept for a Whitebox Enterprise Linux "upgrade" for my own purposes.

The Apache 2.0.52 compiles/installs fine from my home-brewed RPMS.
RPMs from install and work fine ala version 4.0.21

PHP 4.3.9 seems to build OK using the SPEC file from a RHEL src rpm and then removing the obviously outdated patches.

Conventional wisdom (on the net) seems to imply that a SPEC file for PHP 4 should work for PHP5 if you change salient references in the SPEC file. I've done that, but when it goes to build, it gets very far into the compile and fails on "mbstring" and/or cgi-redirect.

Looking at the phpinfo() from XAMPP for PHP5, the configure options don't seem to turn up anything we haven't seen before, so my question is whether or not there is some dependency that changed between PHP 4.3.9 and PHP 5.0.2.

Posted or private comments/suggestions will be greatly appreciated.

Dave Nuttall
San Antonio, TX
Posts: 2
Joined: 05. October 2004 15:10
Location: San Antonio, Texas

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests