Install / activate ssl for Xampp on CentOS

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Install / activate ssl for Xampp on CentOS

Postby milind1983 » 10. December 2018 09:36

Hello,
I am not able to activate the ssl. My xampp version is 7.2.9 & OS is Centos 7.
I have done the changes as per the following link,
http://www.zunisoft.com/2008/10/10/kb-x ... on-ubuntu/

But it's not working.
I am not getting any error, but https is not working, even port 443 is not listening.
So please help me, I am stuck on this last 4 days.
milind1983
 
Posts: 5
Joined: 10. December 2018 08:59
XAMPP version: 7.2.9
Operating System: Centos 7

Re: Install / activate ssl for Xampp on CentOS

Postby Nobbie » 10. December 2018 10:17

That link is incomplete.
Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04

Re: Install / activate ssl for Xampp on CentOS

Postby milind1983 » 10. December 2018 10:26

Sorry
http://www.zunisoft.com/2008/10/10/kb-xampp-ssl-configuration-on-ubuntu/
milind1983
 
Posts: 5
Joined: 10. December 2018 08:59
XAMPP version: 7.2.9
Operating System: Centos 7

Re: Install / activate ssl for Xampp on CentOS

Postby Nobbie » 10. December 2018 17:30

That link contains some old and deprecated configurations as for example "NameVirtualHost". Please show us your full httpd.conf and httpd-ssl.conf

In the default configuration Apache listens on ALL ports, if it does not listen to 443, you must have changed something.
Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04

Re: Install / activate ssl for Xampp on CentOS

Postby milind1983 » 11. December 2018 07:50

Thanks for your reply.
I have changed the httpd.conf & https-ssl.conf file to the original one but still I am facing port 443 not listening issue.
Even i commented the Include etc/extra/httpd-ssl.conf line but still i am getting following errors.
I getting the following error all the times.
In error_log, I am getting following errors,

[mpm_prefork:notice] [pid 23233] AH00169: caught SIGTERM, shutting down
[ssl:warn] [pid 23298] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[lbmethod_heartbeat:notice] [pid 23298] AH02282: No slotmem from mod_heartmonitor
[mpm_prefork:notice] [pid 23298] AH00163: Apache/2.4.34 (Unix) OpenSSL/1.0.2p PHP/7.2.9 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[core:notice] [pid 23298] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D PHP'

Even in httpd.config
LoadModule ssl_module modules/mod_ssl.so
above line is uncommented.

One more thing I want to tell you when I am trying to start the service httpd then it's started fine & listen to the port 443 successfully.
but https service starts only when xampp is stopped.

Xampp starts only when httpd service is stopped.
milind1983
 
Posts: 5
Joined: 10. December 2018 08:59
XAMPP version: 7.2.9
Operating System: Centos 7

Re: Install / activate ssl for Xampp on CentOS

Postby Nobbie » 11. December 2018 10:44

milind1983 wrote:Xampp starts only when httpd service is stopped.


??

Do you have a httpd service running plus Xampp? Thats wild, dont you know that httpd is the program name of Apache? If i got it tight, you already have Apache up and runnig, for what do you need Xampp?

If not and its all Xampp, look for the inlude of http-ssl.conf in httpd.conf and remove the surrounding ifdef SSL option. Obviously your Apache isnt startet with the option -D SSL, this should be the case. Usually this is triggered by the existence of the file /opt/lampp/etc/xampp/startssl, but for any reason that doesnt work in your installation. Did you remove files?
Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04

Re: Install / activate ssl for Xampp on CentOS

Postby milind1983 » 11. December 2018 11:51

Thanks for your reply.
Do you have a httpd service running plus Xampp?

No, httpd service is not running.
It's all Xampp.

Nobbie, /opt/lampp/etc/xampp/startssl this file does not exist.
what should i do now?
milind1983
 
Posts: 5
Joined: 10. December 2018 08:59
XAMPP version: 7.2.9
Operating System: Centos 7

Re: Install / activate ssl for Xampp on CentOS

Postby Nobbie » 11. December 2018 12:46

Did you remove it? I have Xampp for linux and in my installation it exists! Try to create a file "startssl" (simply run "sudo touch /opt/lampp/etc/xampp/startssl"). Then try to restart Xampp.
Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04

Re: Install / activate ssl for Xampp on CentOS

Postby milind1983 » 12. December 2018 08:43

Thanks, Nobbie,
I didn't remove it.
As per your guideline, I have created the file & it working fine now.

You saved my days......Thanks a lot . you are awesome :)
milind1983
 
Posts: 5
Joined: 10. December 2018 08:59
XAMPP version: 7.2.9
Operating System: Centos 7

Re: Install / activate ssl for Xampp on CentOS

Postby Nobbie » 12. December 2018 14:07

Finally....
Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests