XAMPP 7.2.12 Syntax Error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP 7.2.12 Syntax Error

Postby DampesAcorn » 29. November 2018 03:02

I tried to install XAMPP onto my Ubuntu 16.04 LTS machine I tried the latest version I could see. The first time that I downloaded it from https://www.apachefriends.org/download.html the file was not run-able and was treated as a text file by my computer, so I went to SorceForge and when I downloaded the file it was seen correctly by my computer but when I tried to execute the file through the command line I got an error about an unterminated quoted string. I tried to look in the code to edit the error, but the code looked like random numbers and symbols (I guess that's from sha1).
This is what the code looked like
sudo chmod 755 xampp-linux-x64-7.2.12-0-installer.run
sudo ./xampp-linux-x64-7.2.12-0-installer.run
./xampp-linux-x64-7.2.12-0-installer.run: 1: ./xampp-linux-x64-7.2.12-0-installer.run: Syntax error: Unterminated quoted string
DampesAcorn
 
Posts: 1
Joined: 29. November 2018 02:46
XAMPP version: 7.2.12
Operating System: Linux

Re: XAMPP 7.2.12 Syntax Error

Postby Nobbie » 29. November 2018 11:44

That typically means, that you are trying to run a 64bit executable in a 32bit linux. That does not work, you must install Xampp into a 64bit linux.
Nobbie
 
Posts: 10780
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests